[PATCH] gnu: python-pydata-sphinx-theme: Fix build.

  • Done
  • quality assurance status badge
Details
3 participants
  • Aleksandr Vityazev
  • Efraim Flashner
  • Maxime Devos
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal

Debbugs page

Aleksandr Vityazev wrote 3 years ago
(address . guix-patches@gnu.org)
e0d96e33c82390f4bb8d6a77e8c6a7d17f8f8d10.1640125976.git.avityazev@posteo.org
Hi,

the build fails because a package is required python-docutils < 0.17.


Toggle snippet (7 lines)
ERROR: Could not find a version that satisfies the requirement docutils<0.17 (from versions: none)
ERROR: No matching distribution found for docutils<0.17
error: Command '['/gnu/store/3282r97il61j9jkv2aaifa3nwdylzfsv-python-wrapper-3.9.6/bin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/guix-build-python-pydata-sphinx-theme-0.6.3.drv-0/tmpqhg_sgru', '--quiet', 'docutils<0.17']' returned non-zero exit status 1.



* gnu/packages/sphinx (python-pydata-sphinx-theme):
[native-inputs]: Replace python-docutils with python-docutils-0.15.
---
gnu/packages/sphinx.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3ac5b5e22c..957c4dc9c4 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -919,7 +920,7 @@ (define-public python-pydata-sphinx-theme
(list python-beautifulsoup4))
(native-inputs
(list python-beautifulsoup4
- python-docutils
+ python-docutils-0.15
python-jupyter-sphinx
python-numpy
python-numpydoc
--
2.34.0



--

Aleksandr Vityazev
Maxime Devos wrote 3 years ago
(address . 52721@debbugs.gnu.org)
bfccd3fc7fd11b39dcfd061146b56107204bec66.camel@telenet.be
Hi,

Toggle quote (2 lines)
> the build fails because a package is required python-docutils < 0.17.

Is python-docutils<0.17 truly required, or are the version requirements
in the source code overly strict? If it's the latter, you could patch
the source code to relax the requirements.

The latter happens often, because library developers often don't know
in advance whether the library is compatible with future versions of
the dependencies.

Greetings,
Maxime.
Aleksandr Vityazev wrote 3 years ago
[PATCH]v2 gnu: python-pydata-sphinx-theme: Fix build.
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 52721@debbugs.gnu.org)
87r1a433my.fsf_-_@posteo.org
Hi,
On 2021-12-22, 10:53 +0000, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (10 lines)
>> the build fails because a package is required python-docutils < 0.17.
>
> Is python-docutils<0.17 truly required, or are the version requirements
> in the source code overly strict? If it's the latter, you could patch
> the source code to relax the requirements.
>
> The latter happens often, because library developers often don't know
> in advance whether the library is compatible with future versions of
> the dependencies.

For version 0.6.3 there is a file
pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
contains:

docutils==0.16 # temporary pin (0.17 broken captions).

Also, the master version requires "docutils!=0.17.0.

So I created a patch that adds an extra phase.
From 7301a82b07e73c3bdbeef0d1375094d625336766 Mon Sep 17 00:00:00 2001
Message-Id: <7301a82b07e73c3bdbeef0d1375094d625336766.1640196453.git.avityazev@posteo.org>
From: Aleksandr Vityazev <avityazev@posteo.org>
Date: Wed, 22 Dec 2021 17:25:18 +0300
Subject: [PATCH] gnu: python-pydata-sphinx-theme: Fix build.

* gnu/packages/sphinx (python-pydata-sphinx-theme):
[arguments]: add phase "relax-dependency-requirements".
---
gnu/packages/sphinx.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3ac5b5e22c..c9a9a2efbb 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -915,6 +916,13 @@ (define-public python-pydata-sphinx-theme
(base32
"055bh3hyh72pafiylvgpsjlk18wm15gg4azc5rjlsww5z475iq1j"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'relax-dependency-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("docutils<0.17") "docutils")))))))
(propagated-inputs
(list python-beautifulsoup4))
(native-inputs
--
2.34.0
--
Best regards,
Aleksandr Vityazev
Maxime Devos wrote 3 years ago
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)(address . 52721@debbugs.gnu.org)
c2a40cf5fe74db5d508c88bf8bd3d6e455d28d06.camel@telenet.be
Aleksandr Vityazev schreef op wo 22-12-2021 om 18:17 [+0000]:
Toggle quote (26 lines)
>
> > > the build fails because a package is required python-docutils <
> > > 0.17.
> >
> > Is python-docutils<0.17 truly required, or are the version
> > requirements
> > in the source code overly strict? If it's the latter, you could
> > patch
> > the source code to relax the requirements.
> >
> > The latter happens often, because library developers often don't
> > know
> > in advance whether the library is compatible with future versions
> > of
> > the dependencies.
>
> For version 0.6.3 there is a file
> pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
> contains:
>
> docutils==0.16 # temporary pin (0.17 broken captions).
>
> Also, the master version requires "docutils!=0.17.0.
>
> So I created a patch that adds an extra phase.

In that case, docutil<0.17 appears to be actually required, so the
solution would be to use docutils=0.15 as you did originally, I think?
Preferably with a comment ; captions are broken in 0.17..

Greetings,
Maxime.
Aleksandr Vityazev wrote 3 years ago
Re: bug#52721: [PATCH] gnu: python-pydata-sphinx-theme: Fix build.
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 52721@debbugs.gnu.org)
878rwbj5jw.fsf_-_@posteo.org
Hi,

On 2021-12-22, 18:25 +0000, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (15 lines)
>> For version 0.6.3 there is a file
>> pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
>> contains:
>>
>> docutils==0.16 # temporary pin (0.17 broken captions).
>>
>> Also, the master version requires "docutils!=0.17.0.
>>
>> So I created a patch that adds an extra phase.
>
> In that case, docutil<0.17 appears to be actually required, so the
> solution would be to use docutils=0.15 as you did originally, I think?
> Preferably with a comment ; captions are broken in 0.17..
>

These were pushed by Efraim Flashner with
8efa775653f78dad8b254e719677e663be8f3240.

--
Best regards,
Aleksandr Vityazev
Efraim Flashner wrote 3 years ago
Re: [bug#52721] [PATCH] gnu: python-pydata-sphinx-theme: Fix build.
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)
Ycd43c7+lto2tG/c@3900XT
On Thu, Dec 23, 2021 at 10:54:27PM +0000, Aleksandr Vityazev wrote:
Toggle quote (23 lines)
> Hi,
>
> On 2021-12-22, 18:25 +0000, Maxime Devos <maximedevos@telenet.be> wrote:
>
> >> For version 0.6.3 there is a file
> >> pydata-sphinx-theme-0.6.3/docs/requirements.txt where the last line
> >> contains:
> >>
> >> docutils==0.16 # temporary pin (0.17 broken captions).
> >>
> >> Also, the master version requires "docutils!=0.17.0.
> >>
> >> So I created a patch that adds an extra phase.
> >
> > In that case, docutil<0.17 appears to be actually required, so the
> > solution would be to use docutils=0.15 as you did originally, I think?
> > Preferably with a comment ; captions are broken in 0.17..
> >
>
> These were pushed by Efraim Flashner with
> 8efa775653f78dad8b254e719677e663be8f3240.
>

Sorry, I didn't check for patches before working on this patch.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmHHeNoACgkQQarn3Mo9
g1FSgxAAqlNveXsDbfeQwE5mVA50Jy/cOcqi4k/j/Q2yTRKggRb3WTaGVQoFCUBq
I7sn5KCgj8KGWv4jniOZ1jEJZlJSx0EUHfuU/WRGoFkOPFRah5GwsYHa45F3P0nE
vW37Zpp0VL1DnAkEKmCybjvaKMXNnGS7LfI2GcZJSbCSi9PnpKPhO20R4/dDmzZ+
vlcFkVXiYt/4yjKYi5+mX4NkWfxkO7uw4uQmTympMDLOQ1smF7Mm5q3KX2a4JUcg
0QEw+YzOUMSPMpyXRFExytC6GdElRusjzQYWoe8QJcvTgwPakg3iO39i3DhU7C8U
9eijfjcz8X3tKXQXe7uihUTbwiCzzQFmpIKrTHqyaq6zFFRRnHBGUu3WZmlWUs3x
ycf046A34b8Kb3otKE5eAmEUIUYKz4wfxO93E+1UsNNVZldhEtdeDg8CqSVAkQUq
jNesjorIHT/lNEWdAx3/d8s3eHJF8AIDOLmdSiMsTTTRFzWq+QdE4keAhMpetsGG
/78+V8ww3A458MXco/uAmsT3zqU8PSKZf/XI+zAkqYvqNIUjIlAvEUAUP2UEdYHy
ll+rCuyReP5NqsgPtMaa3KyOYgvyUYvPCKcVecC3DOAoduBbdDuFtkwbsN6BcfEg
2pS1JtN4K3AD1ZPiUNwEUKrVgctgkqLGzF2cieJwURrVeBtwpvo=
=4qF3
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52721@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52721
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help