System reconfiguration fails to build linux-modules.drv

  • Done
  • quality assurance status badge
Details
4 participants
  • Julien L.
  • Leo Famulari
  • Tobias Geerinckx-Rice
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
Merged with
V
V
Vivien Kraus wrote on 19 Dec 2021 21:35
(address . bug-guix@gnu.org)
871r28uyc7.fsf@planete-kraus.eu
Dear guix,

On master, I can’t reconfigure my system, because the linux-modules.drv
fails with the following error:

Backtrace:
17 (primitive-load "/gnu/store/bvjcb7jbwlky0czin8p66949mil?")
In ice-9/eval.scm:
619:8 16 (_ #f)
626:19 15 (_ #<directory (guile-user) 7ffff5fdbc80>)
293:34 14 (_ #(#<directory (guile-user) 7ffff5fdbc80> #<procedu?>))
In srfi/srfi-1.scm:
586:29 13 (map1 _)
586:29 12 (map1 _)
586:29 11 (map1 _)
586:29 10 (map1 _)
586:29 9 (map1 _)
586:29 8 (map1 _)
586:29 7 (map1 _)
586:29 6 (map1 _)
586:29 5 (map1 _)
586:29 4 (map1 _)
586:29 3 (map1 _)
586:29 2 (map1 _)
586:17 1 (map1 ("simplefb" "pata_acpi" "pata_atiixp" "isci" "?" ?))
In gnu/build/linux-modules.scm:
257:5 0 (_)

gnu/build/linux-modules.scm:257:5: kernel module not found "simplefb" "/gnu/store/1ai7mxw5ad58ic9slxsjzsxaryi5wksp-linux-libre-5.10.87/lib/modules"


The top of the backtrace is this file,
/gnu/store/bvjcb7jbwlky0czin8p66949milhvrql-linux-modules-builder:

(begin (use-modules (gnu build linux-modules) (guix build utils) (srfi
srfi-1) (srfi srfi-26)) (define module-dir (string-append
"/gnu/store/1ai7mxw5ad58ic9slxsjzsxaryi5wksp-linux-libre-5.10.87"
"/lib/modules")) (define modules (let* ((lookup (cut find-module-file
module-dir <>)) (modules (map lookup (quote ("ahci" "usb-storage" "uas"
"usbhid" "hid-generic" "hid-apple" "dm-crypt" "xts" "serpent_generic"
"wp512" "nls_iso8859-1" "framebuffer_coreboot" "simplefb" "pata_acpi"
"pata_atiixp" "isci" "virtio_pci" "virtio_balloon" "virtio_blk"
"virtio_net" "virtio_console" "virtio-rng"))))) (append modules
(recursive-module-dependencies modules #:lookup-module lookup))))
(define (maybe-uncompress file) (cond ((string-contains file ".ko.gz")
(invoke
"/gnu/store/9q9z91mvc1r3h8zmi135msv3j1dgv2js-gzip-1.10/bin/gunzip"
file)))) (mkdir ((@ (guile) getenv) "out")) (for-each (lambda (module)
(let ((out-module (string-append ((@ (guile) getenv) "out") "/"
(basename module)))) (format #t "copying '~a'...~%" module) (copy-file
module out-module) (maybe-uncompress out-module))) (delete-duplicates
modules)) (write-module-name-database ((@ (guile) getenv) "out")))

This is the linux-related part of my system configuration:

(operating-system
(kernel linux-libre-lts)
(kernel-arguments
`(,@%default-kernel-arguments
"modprobe.blacklist=amdgpu,radeon"))
…)

Best regards,

Vivien
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCAAdFiEEq4yIHjMvkliPpwQnO7C8EjLYuCwFAmG/l6kACgkQO7C8EjLY
uCw0zgwAkiMu4gysFcrrelt2a5I0cKfE2rjHi3LQbNNTnDks44FhlcrAoOHnmCZD
377LGQDalumTOQJXUb1EpHIIjl0JxgYQMnikNT0zXxnKfOQXNFk/3wfHDv0GFUrP
pEHuOnULc11tuYQK55vi9FTH7SNn6cZ1rtWfRpzV5Pfa5jEeXd4lvmjQGJU6BFsN
6ZxtLkKX0pb1V8gNwsicaQ8DhB758fwkm6MPak3NjjBttWzPKwhs8Q0lQJ+Mn6rL
cmvQAd9jluuE65XrPPYADZJLTuSuMCg18ppZQtT1hD4KlneB6jwQ9SVhk33aHDso
LBH6A1QWjW+tdCxn9tz4e+t5+9yVxjGShRZDQ0AxGymzk/34aiH+0b23PTE286If
uFrJcpHlX9flw/UfhntLyihfzCbynlPyrYd+Rg6r2XG+jKtINlapjbvXFlqldpxh
8Y7xg4CYb2j9kiKOy7sGhL9lspb63npy9tpI56c6XdcKcF/PPi9Be+VyhwvvHgu0
5UHLa0+l
=pQ0X
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 21 Dec 2021 23:14
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87y24dehb1.fsf@nckx
merge 52667 52719
T
T
Tobias Geerinckx-Rice wrote on 21 Dec 2021 23:38
Re: System reconfiguration fails to build linux-modules.drv
(address . 52667@debbugs.gnu.org)
87tuf1efn8.fsf@nckx
Vivien,

Thanks for the report! Sorry it took me a while to get back to
you.

As discussed in #guix, an immediate work-around is:

(initrd-modules
;; This cannot be built as a module for linux-libre-lts.
((@ (srfi srfi-1) delete) "simplefb" %base-initrd-modules))

I'm not sure what to do going forward. I see two reasonable
solutions. Perhaps there are more, and I welcome suggestions.

One is to provide a separate %base-initrd-modules-lts list that's
equivalent to the snippet above. It's… not great, but then
linux-libre-lts itself isn't documented and people still seem to
find it. If someone were to document it, they could also add a
note about modules.

A more straightforward route is to simply build in simplefb even
for kernels 5.15 and beyond. Apart from an (unmeasured) size
increase of the base image, the main drawback here is that we lose
our long-standing CONFIG_DRM_SIMPLEDRM=m due to a conflict:

- CONFIG_DRM_GEM_SHMEM_HELPER=y
- CONFIG_DRM_SIMPLEDRM=m
+ # CONFIG_DRM_SIMPLEDRM unset tristate: Simple framebuffer driver
- CONFIG_FB_SIMPLE=m
+ CONFIG_FB_SIMPLE=y tristate: Simple framebuffer support

When preparing https://issues.guix.gnu.org/51619 I considered
this a regression and hence bad, but maybe nobody cares…?

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYcJaSw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15PBABAN9s31O1VVHFIBLhO3nc1ccrq/qjUW8dVUC+pWGL
vtjqAQDafVjv0uQsFH813IZidEZmIkdbLF9Eei2Q74SJEZAFAA==
=4Gzy
-----END PGP SIGNATURE-----

T
T
Tobias Geerinckx-Rice wrote on 22 Dec 2021 00:00
Re: bug#52667: System reconfiguration fails to build linux-modules.drv
87pmppeev5.fsf@nckx
Tobias Geerinckx-Rice via Bug reports for GNU Guix ???
Toggle quote (2 lines)
> I see two reasonable solutions.

By the way, I think a better solution longer-term is to merge
these tightly-coupled kernel attributes into a single object:

(kernel (linux-libre-configuration
(package linux-libre-lts …)
(modules-needed-for-boot …)
…))

Naming aside, something like that.

A variant like linux-libre-lts-kernel could then be a coherent &
self-contained whole. This has bugged me for a long time,
actually…

Thoughts?

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYcJePg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15PTQBAMlEphUCev8/+WlTD+A4/fIvWf7difg/MOKmqAB1
UwyfAP9cc5AQ9SkxtMNbLeYCeJRpXhlXfKlKwd8LuK/+KuGfBg==
=ddOj
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 22 Dec 2021 00:11
(no subject)
(address . control@debbugs.gnu.org)
YcJfLQWI9E8uOffg@jasmine.lan
merge 52719 52667
L
L
Leo Famulari wrote on 22 Dec 2021 19:28
Re: bug#52667: System reconfiguration fails to build linux-modules.drv
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)(address . 52667@debbugs.gnu.org)
YcNuTowqY/FxLTpp@jasmine.lan
On Tue, Dec 21, 2021 at 11:38:44PM +0100, Tobias Geerinckx-Rice via Bug reports for GNU Guix wrote:
Toggle quote (4 lines)
> (initrd-modules
> ;; This cannot be built as a module for linux-libre-lts.
> ((@ (srfi srfi-1) delete) "simplefb" %base-initrd-modules))

Sorry if this question has already been answered, but is the problem
specific to linux-libre-lts? Or linux-libre-5.10? Or all linux-libre
packages aside from the 5.15 series?

I'm inclined to just revert the commit that introduced the regression
until we have a better solution...
T
T
Tobias Geerinckx-Rice wrote on 22 Dec 2021 20:25
(name . Leo Famulari)(address . leo@famulari.name)(address . 52667@debbugs.gnu.org)
2e16e98b78683bf669bfc3fa26224a39@tobias.gr
Hi Leo,

On 2021-12-22 19:28, Leo Famulari wrote:
Toggle quote (2 lines)
> Or all linux-libre packages aside from the 5.15 series?

This.

Toggle quote (3 lines)
> I'm inclined to just revert the commit that introduced the regression
> until we have a better solution...

I think this is merely trading one regression for another, IMO
*slightly* nastier one. And no, I'm not personally affected by this bug
:-)

What about my third suggestion?

Toggle quote (2 lines)
> build in simplefb even for kernels 5.15 and beyond

Your approval as definitely-not-our-linux-libre-maintainer would be one
of the major factors. If you have no opinion, I doubt anyone else will
object. Realistically, the only way to tease out any unknown users out
there is to try it.

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
T
T
Tobias Geerinckx-Rice wrote on 22 Dec 2021 20:27
(name . Leo Famulari)(address . leo@famulari.name)(address . 52667@debbugs.gnu.org)
cbf02e115ca6e483e6854f091ca30f7f@tobias.gr
Toggle quote (2 lines)
> unknown users

of the conflicting DRM module, I mean.

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
L
L
Leo Famulari wrote on 22 Dec 2021 21:11
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 52667@debbugs.gnu.org)
YcOGejPKMT6jK3UX@jasmine.lan
On Wed, Dec 22, 2021 at 08:25:27PM +0100, Tobias Geerinckx-Rice wrote:
Toggle quote (2 lines)
> This.

Well, I guess this episode demonstrates that people are using 5.15,
5.10, and not much else. It's useful information.

Toggle quote (6 lines)
> > I'm inclined to just revert the commit that introduced the regression
> > until we have a better solution...
>
> I think this is merely trading one regression for another, IMO *slightly*
> nastier one. And no, I'm not personally affected by this bug :-)

Okay. From my point of view, things were fine until we added the
simplefb module. So that was the regression.

Toggle quote (6 lines)
>
> Your approval as definitely-not-our-linux-libre-maintainer would be one of
> the major factors. If you have no opinion, I doubt anyone else will object.
> Realistically, the only way to tease out any unknown users out there is to
> try it.

I have no opinion :)
J
J
Julien L. wrote on 28 Dec 2021 23:26
System reconfiguration fails to build linux-modules.drv
(address . 52667@debbugs.gnu.org)
AM0PR02MB57636F3C9D87CB67C9CDD4CCBB439@AM0PR02MB5763.eurprd02.prod.outlook.com
Dear Guix team,

I am using linux-libre in version 4.19. In this version there are no
modules named framebuffer_coreboot and simplefb.

So system reconfiguration complains about framebuffer_corebook being not
found.

I of course applied the workaround (specifying initrd-modules with
%base-initrd-modules minus framebuffer_coreboot and simplefb) but this
is not really nice.

I also understand the constraints.

Would it be a valid solution that linux-modules.scm discards modules
which are not found (instead of returning an error and stopping)?

Thanks,

--
Julien L.
L
L
Leo Famulari wrote on 5 Feb 2022 01:01
(no subject)
(address . control@debbugs.gnu.org)
Yf2+V/N2MXVtBvV8@jasmine.lan
merge 53554 52667
L
L
Leo Famulari wrote on 9 Feb 2022 17:39
Re: bug#52667: System reconfiguration fails to build linux-modules.drv
(name . Vivien Kraus via Bug reports for GNU Guix)(address . bug-guix@gnu.org)(address . 52667-done@debbugs.gnu.org)
YgPuJIBnIpRhEPxO@jasmine.lan
On Sun, Dec 19, 2021 at 09:35:52PM +0100, Vivien Kraus via Bug reports for GNU Guix wrote:
Toggle quote (2 lines)
> On master, I can’t reconfigure my system, because the linux-modules.drv
> fails with the following error:
[...]
Toggle quote (2 lines)
> gnu/build/linux-modules.scm:257:5: kernel module not found "simplefb" "/gnu/store/1ai7mxw5ad58ic9slxsjzsxaryi5wksp-linux-libre-5.10.87/lib/modules"

This should be fixed with commit
fd6cfbc05ac093a6b9497e6c38bb4678f33ac14d
?