Clojure-build-system failure at the unpack phase

  • Done
  • quality assurance status badge
Details
4 participants
  • Aleksandr Vityazev
  • Reily Siegel
  • Maxime Devos
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal

Debbugs page

Aleksandr Vityazev wrote 3 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
87v8zmb0yw.fsf@posteo.org
Hello,

Tried to build all the packages from gnu/package/clojure.scm that use
clojure-build-system. All have the same error:

Toggle snippet (29 lines)
starting phase `unpack'
error: in phase 'unpack': uncaught exception:
wrong-type-arg "string-suffix?" "Wrong type argument in position ~A (expecting ~A): ~S" (2 "string" #f) (#f)
phase `unpack' failed after 0.0 seconds
Backtrace:
9 (primitive-load "/gnu/store/rw9rz7hahnvmlgk8ii1nfd94yc0…")
In guix/build/gnu-build-system.scm:
904:2 8 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1752:10 7 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
634:9 6 (for-each #<procedure 7ffff25c7540 at guix/build/gnu-b…> …)
In ice-9/boot-9.scm:
1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In guix/build/gnu-build-system.scm:
925:23 4 (_)
In guix/build/ant-build-system.scm:
147:6 3 (unpack #:source _)
In unknown file:
2 (string-suffix? ".jar" #f #<undefined> #<undefined> #<…> …)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure string-suffix?: Wrong type argument in position 2 (expecting string): #f
builder for `/gnu/store/8zzfxjymy042l28d3mryqgxgdq3f6pv3-clojure-tools-cli-1.0.206.drv' failed with exit code 1

--
Best regards,
Aleksandr Vityazev
Maxime Devos wrote 3 years ago
6195edb9433687d45c4d89c275caecd4c61116e1.camel@telenet.be
Aleksandr Vityazev schreef op za 18-12-2021 om 11:34 [+0000]:
Toggle quote (5 lines)
> Hello,
>
> Tried to build all the packages from gnu/package/clojure.scm that use
> clojure-build-system. All have the same error: [...]

I think the problem is that #:source is included in the private-
keywords in (guix build-system clojure), so the source isn't passed to
the builder, instead #false is passed. (untested)

While we're at it, we might want to modify 'unpack' in ant-build-system
to fail gracefully if there's no source (e.g. print an error like
‘source code is missing’ or something). That would probably incur many
rebuilds (though only of Java packages?), so that might need to be done
on a separate branch.


Greetings,
Maxime.
Reily Siegel wrote 3 years ago
[PATCH] build-system: clojure: Allow clojure-build-system to pass source to ant.
(address . 52598@debbugs.gnu.org)
87k0fvglxd.fsf@reilysiegel.com

* guix/build-system/clojure.scm (lower): Remove #:source from private
keywords, preventing an error in ant-build-system.
---
guix/build-system/clojure.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (16 lines)
diff --git a/guix/build-system/clojure.scm b/guix/build-system/clojure.scm
index 39b7f44e89..634854cf1b 100644
--- a/guix/build-system/clojure.scm
+++ b/guix/build-system/clojure.scm
@@ -81,8 +81,7 @@ (define* (lower name
#:allow-other-keys
#:rest arguments)
"Return a bag for NAME."
- (let ((private-keywords '(#:source #:target
- #:inputs #:native-inputs
+ (let ((private-keywords '(#:target #:inputs #:native-inputs
#:clojure #:jdk #:zip)))
(if target
--
2.34.0
Ricardo Wurmus wrote 3 years ago
Clojure-build-system failure at the unpack phase
(address . 52598-done@debbugs.gnu.org)
87v8yp5q63.fsf@elephly.net
Thank you. I applied this and pushed it to the master branch with
commit ee6c43f8cd46897bbe1a5a16c68049d7237ea806.

My apologies for the delay.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52598@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52598
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help