[PATCH] gnu: visidata: Update to 2.8.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal

Debbugs page

Ryan Prior wrote 3 years ago
(address . guix-patches@gnu.org)
20211217231624.30690-1-rprior@protonmail.com
* gnu/packages/spreadsheet.scm (visidata): Update to 2.8.
Additionally, migrate inputs to new style.
---
gnu/packages/spreadsheet.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/spreadsheet.scm b/gnu/packages/spreadsheet.scm
index b81c67d63f..0016f38aff 100644
--- a/gnu/packages/spreadsheet.scm
+++ b/gnu/packages/spreadsheet.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Jorge Gomez <jgart@dismail.de>
;;;
@@ -86,14 +86,14 @@ (define-public sc-im
(define-public visidata
(package
(name "visidata")
- (version "2.5")
+ (version "2.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "visidata" version))
(sha256
(base32
- "19fbjr9j91pcazcz0bqx3qrasmr8xdsb13haf5lfbpyxj23f7f1j"))))
+ "1jfhrk0xvzzqfzs0khbig2dc94718qki8zys1f1a9553vjncvmi6"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -103,13 +103,13 @@ (define-public visidata
(when tests? (invoke "pytest"))
#t)))))
(inputs
- `(("dateutil" ,python-dateutil)
- ("requests" ,python-requests)
- ("lxml" ,python-lxml)
- ("openpyxl" ,python-openpyxl)
- ("xlrd" ,python-xlrd)))
+ (list python-dateutil
+ python-requests
+ python-lxml
+ python-openpyxl
+ python-xlrd))
(native-inputs
- `(("pytest" ,python-pytest)))
+ (list python-pytest))
(synopsis "Terminal spreadsheet multitool for discovering and arranging data")
(description
"VisiData is an interactive multitool for tabular data. It combines the
--
2.34.0
Leo Famulari wrote 3 years ago
(name . Ryan Prior via Guix-patches via)(address . guix-patches@gnu.org)(address . 52589-done@debbugs.gnu.org)
Yb5AyC2m8SQmbCmO@jasmine.lan
On Fri, Dec 17, 2021 at 11:16:26PM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (3 lines)
> * gnu/packages/spreadsheet.scm (visidata): Update to 2.8.
> Additionally, migrate inputs to new style.

Thanks! Pushed as fcb5b3176c7e752f3ed7816588973a47abcdc304
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52589@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52589
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help