[PATCH] gnu: add font-plemoljp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Taiju HIGASHI
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Taiju HIGASHI
Severity
normal

Debbugs page

Taiju HIGASHI wrote 3 years ago
(address . guix-patches@gnu.org)(name . Taiju HIGASHI)(address . higashi@taiju.info)
20211217162849.14198-1-higashi@taiju.info
---
gnu/packages/fonts.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 63d1240d5c..3cf927f979 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2288,3 +2289,20 @@ (define-public font-overpass
Overpass includes proportional and monospace variants.")
(license (list license:silofl1.1
license:lgpl2.1))))
+
+(define-public font-plemoljp
+ (package
+ (name "font-plemoljp")
+ (version "1.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/yuru7/PlemolJP/releases/download/v" version "/PlemolJP_v" version ".zip"))
+ (sha256
+ (base32
+ "03cwzkqg09c87lmsx9xfzdrlgjml93bhhp1dqq3qkpdfww30wkaw"))))
+ (build-system font-build-system)
+ (home-page "https://github.com/yuru7/PlemolJP")
+ (synopsis "Plex Mono Language JP")
+ (description "PlemolJP (Plex Mono Language JP) is a Japanese programming font that is a composite of IBM Plex Mono and IBM Plex Sans JP.")
+ (license license:silofl1.1)))
--
2.34.0
Nicolas Goaziou wrote 3 years ago
(name . Taiju HIGASHI)(address . higashi@taiju.info)(address . 52581-done@debbugs.gnu.org)
87mtjuhdrh.fsf@nicolasgoaziou.fr
Hello,

Taiju HIGASHI <higashi@taiju.info> writes:

Toggle quote (2 lines)
> +(define-public font-plemoljp

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52581@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52581
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help