[PATCH] gnu: ableton-link: Run tests conditionally.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal

Debbugs page

Aleksandr Vityazev wrote 3 years ago
(address . guix-patches@gnu.org)
e3f1183f0405a24d3194ce0a886fd15f08eacefc.1639729803.git.avityazev@posteo.org
* gnu/packages/audio.scm (ableton-link)[arguments]: Respect TESTS? option.
---
gnu/packages/audio.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f5fda6d4e9..beae167fb3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5245,11 +5245,12 @@ (define-public ableton-link
#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((python (search-input-file inputs "/bin/python3"))
- (run-tests "../source/ci/run-tests.py"))
- (invoke python run-tests "--target" "LinkCoreTest")
- (invoke python run-tests "--target" "LinkDiscoveryTest"))))
+ (lambda* (#:key inputs tests? #:allow-other-keys)
+ (when tests?
+ (let* ((python (search-input-file inputs "/bin/python3"))
+ (run-tests "../source/ci/run-tests.py"))
+ (invoke python run-tests "--target" "LinkCoreTest")
+ (invoke python run-tests "--target" "LinkDiscoveryTest")))))
(add-before 'install 'patch-cmake
(lambda* (#:key inputs #:allow-other-keys)
(let* ((source "../source/"))
--
2.34.0



--

Aleksandr Vityazev
Nicolas Goaziou wrote 3 years ago
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)(address . 52568-done@debbugs.gnu.org)
875yrn632p.fsf@nicolasgoaziou.fr
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

Toggle quote (3 lines)
> * gnu/packages/audio.scm (ableton-link)[arguments]: Respect TESTS?
> option.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52568@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52568
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help