Aleksandr Vityazev wrote 3 years ago
(address . guix-patches@gnu.org)
* gnu/packages/audio.scm (ableton-link)[arguments]: Respect TESTS? option.
---
gnu/packages/audio.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
Toggle diff (30 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index f5fda6d4e9..beae167fb3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5245,11 +5245,12 @@ (define-public ableton-link
#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((python (search-input-file inputs "/bin/python3"))
- (run-tests "../source/ci/run-tests.py"))
- (invoke python run-tests "--target" "LinkCoreTest")
- (invoke python run-tests "--target" "LinkDiscoveryTest"))))
+ (lambda* (#:key inputs tests? #:allow-other-keys)
+ (when tests?
+ (let* ((python (search-input-file inputs "/bin/python3"))
+ (run-tests "../source/ci/run-tests.py"))
+ (invoke python run-tests "--target" "LinkCoreTest")
+ (invoke python run-tests "--target" "LinkDiscoveryTest")))))
(add-before 'install 'patch-cmake
(lambda* (#:key inputs #:allow-other-keys)
(let* ((source "../source/"))
--
2.34.0
--
Aleksandr Vityazev