(address . bug-guix@gnu.org)
In my Guix system's /etc/passwd file, my user named "abc" has a
comment attached to it. The relevant line is:
abc:x:1000:998:Old
Comment:/home/jkf:/gnu/store/71yp1p06jy2j96bfdz43f4p6ncdym5a1-zsh-5.8/bin/zsh
Today the users section of my current config.scm looks like this:
(users (cons* (user-account
(name "abc")
(group "users")
(comment "New Comment")
(supplementary-groups '("wheel"
"netdev"
"audio"
"video"
"disk"
"cdrom"
"docker"
"libvirt"
"kvm"))
(shell #~(string-append #$zsh "/bin/zsh")))
%base-user-accounts))
After I apply this configuration with `guix system reconfigure', I
expect /etc/passwd to have been updated with "New Comment" in place of
"Old Comment". However, "Old Comment" remains.
Similarly, if I omit the `comment' field entirely, I expect my user
comment to be removed from /etc/passwd, since the default value of the
`comment' field is documented to be an empty string (manual 10.6).
Again, the old comment remains.
I am reporting this on a recent Guix version cev9c6c5, but have
noticed this issue for a year at least.