[PATCH 0/4] gnu: Add ghc-tidal.

  • Open
  • quality assurance status badge
Details
One participant
  • Aleksandr Vityazev
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal
A
A
Aleksandr Vityazev wrote on 15 Dec 2021 23:58
(address . guix-patches@gnu.org)
cover.1639609080.git.avityazev@posteo.org
Aleksandr Vityazev (4):
gnu: Add ghc-data-binary-ieee754.
gnu: Add ghc-hosc.
gnu: Add ghc-microspec.
gnu: Add ghc-tidal

gnu/packages/haskell-xyz.scm | 83 +++++++++++++++++++++++++++++++++++-
1 file changed, 82 insertions(+), 1 deletion(-)

--
2.34.0

--

Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 16 Dec 2021 00:01
[PATCH 1/4] gnu: Add ghc-data-binary-ieee754.
(address . 52527@debbugs.gnu.org)
336160615ebdb1893d39a88f5b935b8c6b86eec6.1639609080.git.avityazev@posteo.org
* gnu/packages/haskell-xyz.scm (ghc-data-binary-ieee754): New variable.
---
gnu/packages/haskell-xyz.scm | 17 ++++++++++++++++-
1 file changed, 16 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f5d15bcc2f..476a2b98a6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3011,6 +3011,22 @@ (define-public ghc-data-ordlist
"This module provides set and multiset operations on ordered lists.")
(license license:bsd-3)))
+(define-public ghc-data-binary-ieee754
+ (package
+ (name "ghc-data-binary-ieee754")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "data-binary-ieee754" version))
+ (sha256
+ (base32 "02nzg1barhqhpf4x26mpzvk7jd29nali033qy01adjplv2z5m5sr"))))
+ (build-system haskell-build-system)
+ (home-page "https://john-millikin.com/software/")
+ (synopsis "Parser/Serialiser for IEEE-754 floating-point values")
+ (description "Convert Float and Decimal values to/from raw octets.")
+ (license license:expat)))
+
(define-public ghc-dbus
(package
(name "ghc-dbus")
@@ -16026,4 +16042,3 @@ (define-public ghc-singleton-bool
(description
"This package provides Type-level booleans.")
(license license:bsd-3)))
-
--
2.34.0



--

Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 16 Dec 2021 00:01
[PATCH 2/4] gnu: Add ghc-hosc.
(address . 52527@debbugs.gnu.org)
acf19929e57d52225180f26fa525a03212443eea.1639609080.git.avityazev@posteo.org
* gnu/packages/haskell-xyz.scm (ghc-hosc): New variable.
---
gnu/packages/haskell-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 476a2b98a6..5e009862d6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3027,6 +3027,26 @@ (define-public ghc-data-binary-ieee754
(description "Convert Float and Decimal values to/from raw octets.")
(license license:expat)))
+(define-public ghc-hosc
+ (package
+ (name "ghc-hosc")
+ (version "0.19.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "hosc" version))
+ (sha256
+ (base32 "08q218p1skqxwa7f55nsgmv9z8digf1c0f1wi6p562q6d4i044z7"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-blaze-builder ghc-data-binary-ieee754 ghc-network))
+ (home-page "https://rohandrape.net/?t=hosc")
+ (synopsis "Haskell Open Sound Control")
+ (description
+ "This package provides Sound.OSC, a haskell module implementing a subset
+of the Open Sound Control byte protocol. @{hosc} is required by the @{hsc3}
+haskell @code{supercollider} bindings.")
+ (license license:gpl3)))
+
(define-public ghc-dbus
(package
(name "ghc-dbus")
--
2.34.0



--

Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 16 Dec 2021 00:01
[PATCH 3/4] gnu: Add ghc-microspec.
(address . 52527@debbugs.gnu.org)
ecc2c07f3e9abe3bc14b0f623a0a4a25f811e5d6.1639609080.git.avityazev@posteo.org
* gnu/packages/haskell-xyz.scm (ghc-microspec): New variable.
---
gnu/packages/haskell-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5e009862d6..a253962142 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3047,6 +3047,25 @@ (define-public ghc-hosc
haskell @code{supercollider} bindings.")
(license license:gpl3)))
+(define-public ghc-microspec
+ (package
+ (name "ghc-microspec")
+ (version "0.2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "microspec" version))
+ (sha256
+ (base32 "0615gdbsk7i3w71adjp69zabw4mli965wffm2h846hp6pjj31xcb"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-quickcheck))
+ (home-page "https://hackage.haskell.org/package/microspec")
+ (synopsis "Tiny QuickCheck test library with minimal dependencies")
+ (description
+ "A tiny, property-based and unit testing library with minimal
+dependencies.")
+ (license license:bsd-3)))
+
(define-public ghc-dbus
(package
(name "ghc-dbus")
--
2.34.0



--

Aleksandr Vityazev
A
A
Aleksandr Vityazev wrote on 16 Dec 2021 00:01
[PATCH 4/4] gnu: Add ghc-tidal
(address . 52527@debbugs.gnu.org)
8b62882634a2bb03f1eea74dc24c0e3e07ee1d91.1639609080.git.avityazev@posteo.org
* gnu/packages/haskell-xyz.scm (ghc-tidal): New variable.
---
gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a253962142..20e62d85c2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3066,6 +3067,32 @@ (define-public ghc-microspec
dependencies.")
(license license:bsd-3)))
+(define-public ghc-tidal
+ (package
+ (name "ghc-tidal")
+ (version "1.7.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "tidal" version))
+ (sha256
+ (base32 "0l8k4f89rhmvd0ys7klgi57k0313ki1vr256mkc60xc6a6gb3g93"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-colour
+ ghc-hosc
+ ghc-network
+ ghc-bifunctors
+ ghc-clock
+ ghc-primitive
+ ghc-random))
+ (native-inputs (list ghc-microspec))
+ (home-page "https://tidalcycles.org/")
+ (synopsis "Pattern language for improvised music")
+ (description
+ "Tidal is a domain specific language for live coding patterns.")
+ (license license:gpl3+)))
+
(define-public ghc-dbus
(package
(name "ghc-dbus")
--
2.34.0



--

Aleksandr Vityazev
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 52527@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52527
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch