[PATCH 1/2] Guix Documentation Meetup Patches

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(name . Guix Patches)(address . guix-patches@gnu.org)
20211215061623.GB25522@gac.attlocal.net
Hi Guixers,

We had a great turnout for the first Guix Documentation Meetup.

Here are two patches that we worked on.

Let's keep it going :)

all best,

jgart
J
[PATCH 1/2] doc: Explain the use of make clean-go when an ABI mismatch occurs.
(address . 52505@debbugs.gnu.org)
20211215112040.25851-1-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

* doc/contributing.texi (Building from Git): Adds section on using
make clean-go.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
---
doc/contributing.texi | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index db1c4c6921..1bcb550aac 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -157,6 +157,18 @@ You are advised to run @command{make authenticate} after every
changes to the repository.
@end quotation
+After updating the repository, @command{make} might fail with an error
+similar to the following example:
+
+@example
+error: failed to load 'gnu/packages/dunst.scm':
+ice-9/eval.scm:293:34: In procedure abi-check: #<record-type <origin>>: record ABI mismatch; recompilation needed
+@end example
+
+This means that one of the record types that Guix defines (in this
+example, the @code{origin} record) has changed, and all of guix needs
+to be recompiled to take that change into account. To do so, run
+@command{make clean-go} followed by @command{make}.
@node Running Guix Before It Is Installed
@section Running Guix Before It Is Installed
--
2.34.0
J
[PATCH 2/2] doc: Mention how to remedy "source file ... newer than compiled error".
(address . 52505@debbugs.gnu.org)
20211215112040.25851-2-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

* doc/contributing.texi (Running Guix Before It Is Installed): Mention
how to remedy "source file ... newer than compiled" error by running
`make -j`.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
---
doc/contributing.texi | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 1bcb550aac..fa8dd376d2 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -243,6 +243,24 @@ local source tree; it simply updates the @file{~/.config/guix/current}
symlink (@pxref{Invoking guix pull}). Run @command{git pull} instead if
you want to upgrade your local source tree.
+Sometimes, especially if you have recently updated your repository,
+running @command{./pre-inst-env} will print a message similar to the
+following example:
+
+@example
+;;; note: source file /home/user/projects/guix/guix/progress.scm
+;;; newer than compiled /home/user/projects/guix/guix/progress.go
+@end example
+
+This is only a note and you can safely ignore it. You can get rid of
+the message by running @command{make -j}. Until you do, Guile will run
+slightly slower because it will interpret the code instead of using
+prepared Guile object (@code{.go}) files.
+
+You can run @command{make} automatically as you work using
+@command{watchexec} from the @code{watchexec} package. For example,
+to build again each time you update a package file, you can run
+@command{watchexec -w gnu/packages make -j}.
@node The Perfect Setup
@section The Perfect Setup
--
2.34.0
Z
Z
zimoun wrote on 15 Dec 2021 13:39
(name . jgart)(address . jgart@dismail.de)
CAJ3okZ1F-UqCQzKQaDEvEx7srW4ucTbPLB8zZtpGJqzvukWWJg@mail.gmail.com
Hi,

On Wed, 15 Dec 2021 at 12:36, jgart via Guix-patches via
<guix-patches@gnu.org> wrote:
Toggle quote (15 lines)
>
> From: Guix Together <jgart@dismail.de>
>
> * doc/contributing.texi (Running Guix Before It Is Installed): Mention
> how to remedy "source file ... newer than compiled" error by running
> `make -j`.
>
> Co-authored-by: jgart <jgart@dismail.de>
> Co-authored-by: Julien Lepiller <julien@lepiller.eu>
> Co-authored-by: Ryan Prior <rprior@protonmail.com>
> Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
> ---
> doc/contributing.texi | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)

Cool!


Toggle quote (2 lines)
> +the message by running @command{make -j}. Until you do, Guile will run

[...]

Toggle quote (2 lines)
> +@command{watchexec -w gnu/packages make -j}.

Personally, I would not recommand inside the manual the command "make
-j", but instead "make" or "make -j4" (4 or whatever number); as it
was done in "guix environment" section [1].



Cheers,
simon
N
N
Nicolas Goaziou wrote on 15 Dec 2021 14:08
Re: [bug#52505] [PATCH 1/2] doc: Explain the use of make clean-go when an ABI mismatch occurs.
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87lf0mow17.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> +This means that one of the record types that Guix defines (in this
> +example, the @code{origin} record) has changed, and all of guix needs
> +to be recompiled to take that change into account. To do so, run
^^^
You need to put two spaces at the end of sentences.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 15 Dec 2021 14:14
Re: [bug#52505] [PATCH 2/2] doc: Mention how to remedy "source file ... newer than compiled error".
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87h7baovru.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> +This is only a note and you can safely ignore it. You can get rid of
> +the message by running @command{make -j}. Until you do, Guile will run
> +slightly slower because it will interpret the code instead of using
> +prepared Guile object (@code{.go}) files.

@code{.go} -> @file{.go}

Toggle quote (3 lines)
> +You can run @command{make} automatically as you work using
> +@command{watchexec} from the @code{watchexec} package.

I'm not sure about the policy for the packages (assuming there is one).
I think @code{watchexec} should be used for the Guix variable containing
the package, and capitalized Watchexec may be appropriate for the
package name, which may not be the same as the variable.

Anyway, I'm just thinking out loud. In this situation.

Toggle quote (3 lines)
> For example, to build again each time you update a package file, you
> can run +@command{watchexec -w gnu/packages make -j}.

According to the Texinfo manual, entire shell commands may use @samp.
@command is for the command name. Thus:

@command{watchexec -w gnu/packages make -j} -> @samp{watchexec -w gnu/packages make -j}

Regards,
--
Nicolas Goaziou
J
[PATCH v2 1/2] doc: Explain the use of make clean-go when an ABI mismatch occurs.
(address . 52505@debbugs.gnu.org)
20211215223455.4990-1-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

Hi all,

Here is version 2 with your requested changes. Let me know if there is anything else I might have missed.

Thank you for the review.

all best,

jgart

* doc/contributing.texi (Building from Git): Adds section on using
make clean-go.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
---
doc/contributing.texi | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index db1c4c6921..164e353884 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -157,6 +157,18 @@ You are advised to run @command{make authenticate} after every
changes to the repository.
@end quotation
+After updating the repository, @command{make} might fail with an error
+similar to the following example:
+
+@example
+error: failed to load 'gnu/packages/dunst.scm':
+ice-9/eval.scm:293:34: In procedure abi-check: #<record-type <origin>>: record ABI mismatch; recompilation needed
+@end example
+
+This means that one of the record types that Guix defines (in this
+example, the @code{origin} record) has changed, and all of guix needs
+to be recompiled to take that change into account. To do so, run
+@command{make clean-go} followed by @command{make}.
@node Running Guix Before It Is Installed
@section Running Guix Before It Is Installed
--
2.34.0
J
[PATCH v2 2/2] doc: Mention how to remedy "source file ... newer than compiled error".
(address . 52505@debbugs.gnu.org)
20211215223455.4990-2-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

* doc/contributing.texi (Running Guix Before It Is Installed): Mention
how to remedy "source file ... newer than compiled" error by running
`make -j`.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
---
doc/contributing.texi | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 164e353884..a9bb310dab 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -243,6 +243,24 @@ local source tree; it simply updates the @file{~/.config/guix/current}
symlink (@pxref{Invoking guix pull}). Run @command{git pull} instead if
you want to upgrade your local source tree.
+Sometimes, especially if you have recently updated your repository,
+running @command{./pre-inst-env} will print a message similar to the
+following example:
+
+@example
+;;; note: source file /home/user/projects/guix/guix/progress.scm
+;;; newer than compiled /home/user/projects/guix/guix/progress.go
+@end example
+
+This is only a note and you can safely ignore it. You can get rid of
+the message by running @command{make -j4}. Until you do, Guile will run
+slightly slower because it will interpret the code instead of using
+prepared Guile object (@file{.go}) files.
+
+You can run @command{make} automatically as you work using
+@command{watchexec} from the @code{watchexec} package. For example,
+to build again each time you update a package file, you can run
+@samp{watchexec -w gnu/packages make -j4}.
@node The Perfect Setup
@section The Perfect Setup
--
2.34.0
J
[PATCH v3 1/2] doc: Explain the use of make clean-go when an ABI mismatch occurs.
(address . 52505@debbugs.gnu.org)
20211216064649.15033-1-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

Hi Guixers,

Here is version 3 of our Documentation patchset.

Ryan had pointed out some other "two spaces after sentence" issues offlist.

all best,

jgart

* doc/contributing.texi (Building from Git): Adds section on using
make clean-go.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
---
doc/contributing.texi | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index db1c4c6921..164e353884 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -157,6 +157,18 @@ You are advised to run @command{make authenticate} after every
changes to the repository.
@end quotation
+After updating the repository, @command{make} might fail with an error
+similar to the following example:
+
+@example
+error: failed to load 'gnu/packages/dunst.scm':
+ice-9/eval.scm:293:34: In procedure abi-check: #<record-type <origin>>: record ABI mismatch; recompilation needed
+@end example
+
+This means that one of the record types that Guix defines (in this
+example, the @code{origin} record) has changed, and all of guix needs
+to be recompiled to take that change into account. To do so, run
+@command{make clean-go} followed by @command{make}.
@node Running Guix Before It Is Installed
@section Running Guix Before It Is Installed
--
2.34.0
J
[PATCH v3 2/2] doc: Mention how to remedy "source file ... newer than compiled error".
(address . 52505@debbugs.gnu.org)
20211216064649.15033-2-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

* doc/contributing.texi (Running Guix Before It Is Installed): Mention
how to remedy "source file ... newer than compiled" error by running
`make -j`.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Julien Lepiller <julien@lepiller.eu>
Co-authored-by: Ryan Prior <rprior@protonmail.com>
Co-authored-by: Blake Shaw <blake@nonconstructivism.com>
---
doc/contributing.texi | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 164e353884..f3182b1564 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -243,6 +243,24 @@ local source tree; it simply updates the @file{~/.config/guix/current}
symlink (@pxref{Invoking guix pull}). Run @command{git pull} instead if
you want to upgrade your local source tree.
+Sometimes, especially if you have recently updated your repository,
+running @command{./pre-inst-env} will print a message similar to the
+following example:
+
+@example
+;;; note: source file /home/user/projects/guix/guix/progress.scm
+;;; newer than compiled /home/user/projects/guix/guix/progress.go
+@end example
+
+This is only a note and you can safely ignore it. You can get rid of
+the message by running @command{make -j4}. Until you do, Guile will run
+slightly slower because it will interpret the code instead of using
+prepared Guile object (@file{.go}) files.
+
+You can run @command{make} automatically as you work using
+@command{watchexec} from the @code{watchexec} package. For example,
+to build again each time you update a package file, you can run
+@samp{watchexec -w gnu/packages make -j4}.
@node The Perfect Setup
@section The Perfect Setup
--
2.34.0
N
N
Nicolas Goaziou wrote on 28 Jan 2022 10:16
Re: [bug#52505] [PATCH 1/2] Guix Documentation Meetup Patches
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87k0ekuso8.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> Here are two patches that we worked on.

Applied v3. Thank you!

Regards,
--
Nicolas Goaziou
J
J
jgart wrote on 3 Feb 2022 01:43
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
20220202194308.GC8620@gac.attlocal.net
On Fri, 28 Jan 2022 10:16:07 +0100 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (8 lines)
> Hello,
>
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
>
> > Here are two patches that we worked on.
>
> Applied v3. Thank you!

Thanks Nicolas!

much appreciated,

jgart
?