[PATCH] home: Add gexp-compiler for home-environments.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal

Debbugs page

Andrew Tropin wrote 3 years ago
(address . guix-patches@gnu.org)
87czly9vod.fsf@trop.in
* gnu/home.scm (home-environment-compiler): New variable.
---
gnu/home.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/home.scm b/gnu/home.scm
index d8134693e5..a9f0a469a5 100644
--- a/gnu/home.scm
+++ b/gnu/home.scm
@@ -25,6 +25,8 @@ (define-module (gnu home)
#:use-module (gnu services)
#:use-module (guix records)
#:use-module (guix diagnostics)
+ #:use-module (guix gexp)
+ #:use-module (guix store)
#:export (home-environment
home-environment?
@@ -104,3 +106,11 @@ (define* (home-environment-with-provenance he config-file)
(inherit he)
(services (cons (service home-provenance-service-type config-file)
(home-environment-user-services he)))))
+
+(define-gexp-compiler (home-environment-compiler (he <home-environment>)
+ system target)
+ ((store-lift
+ (lambda (store)
+ (run-with-store store (home-environment-derivation he)
+ #:system system
+ #:target target)))))
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmG5mGIPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wZtwP/33nU5QyV7WCpBrXeMamAB3/ifAz6iPtuz4m
9FGU+5gHuiOiX9jDrMS8lXre+zFwHOO5OOp/lSxvpP+xcoPgqL1eCDucyZgyp+gV
DIff5fNl5r+QgzsN/+myS5ssmOR3difDEW9c/AlF0R/NUFEt24H6BnKh4q+9idSc
4kTPxYhX+8LOVK9WFV3Mjk9Z5nGHBjfWtrLAORE1Tf+kx0IBRufvs+vCarJT96FF
5DRzgYsa3jFtyCZOSI1X0zEzNDncCwQy20nHxju0318cUF/bwJjfFCKlSuLYHr3+
Sy3qrraNPWMhVbxtk9qySSYvz2I9oRSWSeMegAPTxsJVN9l8X+PUdS6IDODjKGid
u0azWFDjqJN1tnlEuR/haHe1HxRJhJPpPCZhVu23Z/QWFVrHrnh/tSDsUKVGq7bC
iFnhwgeDu7cEXMbeD8hvqGlcARbfRLLZLQywtbNtQwqST38TwWSmBCbA/nU8PUDN
giwC8ejD1Z9I7u7cbUORmYwygE5EpPReVkfADDB/zhLvdmdBFeFl7JaLFU+5/m1J
7yRGFYJzc+E0BNgLUNBBgGy6ta8ftQ55OUPSvoAEvED0vnaKDdzSmFr7yZ4aTp6E
RTropYP9vtqIZJLAHmPEHLctkbzAcuqGuoicWAfBu34YXXDRh3n3HuhKFjEiWBKf
iIgIASy7
=AsWh
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
(name . Andrew Tropin)(address . andrew@trop.in)(address . 52502-done@debbugs.gnu.org)
87k0g0me2c.fsf@gnu.org
Hi,

Andrew Tropin <andrew@trop.in> skribis:

Toggle quote (2 lines)
> * gnu/home.scm (home-environment-compiler): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52502@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52502
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help