[PATCH] linux-modules: Ignore EINVAL in ‘modprobe’ mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 15 Dec 2021 01:47
[PATCH] linux-modules: Ignore EINVAL in ‘modprobe’ mode.
(address . guix-patches@gnu.org)
20211215004704.25215-1-me@tobias.gr
Loading the framebuffer-coreboot module simply fails with EINVAL on a
non-Corebooted system. Crashing the system with a kernel panic is not
a reasonable reaction to loading valid modules on unsupported hardware.
The kernel should log an error, which the user is expected to see.

Bogus module names will still be fatally reported by linux-modules.drv.

* gnu/build/linux-modules.scm (load-linux-module*):
Ignore EINVAL errors when operating recursively.
---
gnu/build/linux-modules.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/build/linux-modules.scm b/gnu/build/linux-modules.scm
index 3a47322065..053720574b 100644
--- a/gnu/build/linux-modules.scm
+++ b/gnu/build/linux-modules.scm
@@ -354,11 +354,13 @@ (define (load-dependencies file)
(close-fdes fd)
#t)
(lambda args
- ;; If this module was already loaded and we're in modprobe style, ignore
- ;; the error.
(when fd (close-fdes fd))
- (or (and recursive? (= EEXIST (system-error-errno args)))
- (apply throw args)))))))
+ (let ((errno (system-error-errno args)))
+ (or (and recursive? ; we're operating in ‘modprobe’ style
+ (member errno
+ (list EEXIST ; already loaded
+ EINVAL))) ; unsupported by hardware
+ (apply throw args))))))))
(define (load-linux-modules-from-directory modules directory)
"Load MODULES and their dependencies from DIRECTORY, a directory containing
--
2.34.0
L
L
Leo Famulari wrote on 15 Dec 2021 02:41
(no subject)
(address . control@debbugs.gnu.org)
YblHyQhjg9jl6wd9@jasmine.lan
block 51619 with 52498
L
L
Leo Famulari wrote on 16 Dec 2021 18:59
Re: [bug#52498] [PATCH] linux-mo dules: Ignore EINVAL in ‘modprobe’ mode.
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 52498-done@debbugs.gnu.org)
Ybt+ZTOR5lEEUef5@jasmine.lan
On Wed, Dec 15, 2021 at 01:47:04AM +0100, Tobias Geerinckx-Rice via Guix-patches via wrote:
Toggle quote (10 lines)
> Loading the framebuffer-coreboot module simply fails with EINVAL on a
> non-Corebooted system. Crashing the system with a kernel panic is not
> a reasonable reaction to loading valid modules on unsupported hardware.
> The kernel should log an error, which the user is expected to see.
>
> Bogus module names will still be fatally reported by linux-modules.drv.
>
> * gnu/build/linux-modules.scm (load-linux-module*):
> Ignore EINVAL errors when operating recursively.

Thanks, pushed as 13f13554433c9dd47503131107dfbdd8a8031832
Closed
?