(address . guix-patches@gnu.org)
Hello Guix,
A number of times I got hit by newly configured service not starting because
of wrong ownership for files they ought to own. This appear when
reconfiguring a operating system with a service that was unsed in the past,
but not present in previous generation. For example, this time, cuirass and
postgresql service wouldn't start because that system had them running before,
but a few weeks ago I reconfigured the operating system without them and now
that I want to have these services running again they won't start because the
activation scripts were only changing the ownership of the runtime, data, log
and co. directories but not their content. Concretely
/var/lib/postgresql/data/PG_VERSION (and others) wasn't owned by
postgresql:postgresql but by an other pair of UID/GID, however
/var/lib/postgresql had the correct ownership
This patch fix such UID/GID mismatch for the cuirass and postgresql service by
recusrivly changing the owner and group of the whole tree these services
need. And not just the root directories of theses trees. It is related to the issue
https://issues.guix.gnu.org/45571 about stable UID/GID in Guix's containers.
Cheers,
- Brice
Brice Waegeneire (4):
syscalls: Add 'lchown'.
activation: Add 'lchown-recursive'.
services: postgresql: Ensure correct ownership of directory trees.
services: cuirass: Ensure correct ownership of directory trees.
gnu/build/activation.scm | 22 ++++++++++++++++++++--
gnu/services/cuirass.scm | 18 +++++++++++-------
gnu/services/databases.scm | 14 +++++++++-----
guix/build/syscalls.scm | 16 ++++++++++++++++
4 files changed, 56 insertions(+), 14 deletions(-)
base-commit: 604880ae22e1a7662acb1d3f282242470de0cd03
--
2.34.0