[PATCH 1/2] gnu: Add emacs-rec-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023BC5CD23214FFD726A4A2C5729@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-rec-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4fdc5f1bb3..aada2b17ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22004,6 +22004,46 @@ (define-public emacs-org-brain
wiki.")
(license license:expat)))
+(define-public emacs-rec-mode
+ ;; Compilation issues with latest release. When updating to a proper
+ ;; version, we should change the origin to elpa.
+ (let ((commit "646962cff4f728cfa56c72ed43de8936713c8bb6")
+ (revision "0"))
+ (package
+ (name "emacs-rec-mode")
+ (version (git-version "1.8.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/recutils/rec-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1f5d5kf4rc84v8208qh0l8f5ac92fjqvrlgz0hhgj764v8w2ahpq"))
+ (modules '((guix build utils)))
+ (snippet '(begin (delete-file "rec-mode.info")))))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "makeinfo" "--no-split"
+ "-o" "rec-mode.info" "rec-mode.texi"))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (build-system emacs-build-system)
+ (home-page "https://www.gnu.org/software/recutils/")
+ (synopsis "Major mode for viewing/editing rec files")
+ (description "Rec Mode is a mode for browsing and editing recfiles,
+which are text files containing data structured in fields and records. It is
+part of the GNU recutils suite.
+
+Recfiles are text-based databases which are easy to read and write manually
+using a text editor. At the same time they feature enough structure so they
+can be read, edited and processed automatically by programs.")
+ (license license:gpl3+))))
+
(define-public emacs-recent-addresses
(let ((commit "afbbfdc43b81e620acf827ca20d297e0c517b6eb")
(revision "1"))
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH 2/2] gnu: emacs-recutils: Deprecate in favor of emacs-rec-mode
(address . 52439@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB40233970DEA6D6240C8D6DC7C5729@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/databases.scm (emacs-recutils): Remove package definition and
add deprecated alias to emacs-rec-mode
---
gnu/packages/databases.scm | 21 +++------------------
1 file changed, 3 insertions(+), 18 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7cff0f99c5..616a981cca 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -89,6 +89,7 @@ (define-module (gnu packages databases)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages dbm)
#:use-module (gnu packages emacs)
+ #:use-module ((gnu packages emacs-xyz) #:select (emacs-rec-mode))
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gawk)
@@ -1384,24 +1385,8 @@ (define-public recutils
(home-page "https://www.gnu.org/software/recutils/")))
(define-public emacs-recutils
- (package
- (inherit recutils)
- (name "emacs-recutils")
- (build-system emacs-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "etc")
- #t)))))
- (native-inputs '())
- (inputs '())
- (synopsis "Emacs mode for working with recutils database files")
- (description "This package provides an Emacs major mode @code{rec-mode}
-for working with GNU Recutils text-based, human-editable databases. It
-supports editing, navigation, and querying of recutils database files
-including field and record folding.")))
+ ;; XXX: When removing, also remove relevant #:use-modules
+ (deprecated-package "emacs-recutils" emacs-rec-mode))
(define-public rocksdb
(package
--
2.34.0
Liliana Marie Prikler wrote 3 years ago
Re: [PATCH 1/2] gnu: Add emacs-rec-mode.
7e5fc6a666d2bfe43e193aaf4b8df755ee5b9899.camel@gmail.com
Hi,

Am Samstag, den 11.12.2021, 14:39 -0500 schrieb
Morgan.J.Smith@outlook.com:
Toggle quote (66 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-rec-mode): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 40
> ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 4fdc5f1bb3..aada2b17ce 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -22004,6 +22004,46 @@ (define-public emacs-org-brain
> wiki.")
> (license license:expat)))
>
> +(define-public emacs-rec-mode
> + ;; Compilation issues with latest release. When updating to a
> proper
> + ;; version, we should change the origin to elpa.
> + (let ((commit "646962cff4f728cfa56c72ed43de8936713c8bb6")
> + (revision "0"))
> + (package
> + (name "emacs-rec-mode")
> + (version (git-version "1.8.1" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "
> https://git.savannah.gnu.org/git/recutils/rec-mode.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1f5d5kf4rc84v8208qh0l8f5ac92fjqvrlgz0hhgj764v8w2a
> hpq"))
> + (modules '((guix build utils)))
> + (snippet '(begin (delete-file "rec-mode.info")))))
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (add-before 'install 'make-info
> + (lambda _
> + (invoke "makeinfo" "--no-split"
> + "-o" "rec-mode.info" "rec-mode.texi"))))))
> + (native-inputs
> + `(("texinfo" ,texinfo)))
> + (build-system emacs-build-system)
> + (home-page "https://www.gnu.org/software/recutils/")
> + (synopsis "Major mode for viewing/editing rec files")
> + (description "Rec Mode is a mode for browsing and editing
> recfiles,
> +which are text files containing data structured in fields and
> records. It is
> +part of the GNU recutils suite.
> +
> +Recfiles are text-based databases which are easy to read and write
> manually
> +using a text editor. At the same time they feature enough structure
> so they
> +can be read, edited and processed automatically by programs.")
> + (license license:gpl3+))))
> +
> (define-public emacs-recent-addresses
> (let ((commit "afbbfdc43b81e620acf827ca20d297e0c517b6eb")
> (revision "1"))
Rather than a new package, I think we can very well edit the existing
package in-place, so that we don't need to add a meaningless
deprecation. For all intents and purposes, this still is emacs-
recutils -- it's still hosted alongside recutils even though it's no
longer bundled with it.

As a second patch, we could move it to emacs-xyz, but personally both
locations feel fine. WDYT?
Morgan Smith wrote 3 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 52439@debbugs.gnu.org)
BYAPR05MB4023ADC56881243600380063C5739@BYAPR05MB4023.namprd05.prod.outlook.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (6 lines)
> Rather than a new package, I think we can very well edit the existing
> package in-place, so that we don't need to add a meaningless
> deprecation. For all intents and purposes, this still is emacs-
> recutils -- it's still hosted alongside recutils even though it's no
> longer bundled with it.

I have no clue if this is the intention or not but I always find that
the emacs package names are in the format: emacs-FEATURE. As in I can
just do (load "FEATURE") to load the package and start exploring. I was
very confused when I first downloaded the package as (load "recutils")
did nothing and I had to do (load "rec-mode"). I realize this
convention isn't written down anywhere but I think maybe it should be
because it's very helpful to me personally.

Toggle quote (3 lines)
> As a second patch, we could move it to emacs-xyz, but personally both
> locations feel fine. WDYT?

The location means very little to me. If I was just editing the package
instead of replacing it I wouldn't have moved it.
Liliana Marie Prikler wrote 3 years ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 52439@debbugs.gnu.org)
1d60848f3732844757e25a29db1d155dd7d885b3.camel@gmail.com
Hi,

Am Samstag, den 11.12.2021, 19:09 -0500 schrieb Morgan Smith:
Toggle quote (14 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > Rather than a new package, I think we can very well edit the
> > existing package in-place, so that we don't need to add a
> > meaningless deprecation. For all intents and purposes, this still
> > is emacs-recutils -- it's still hosted alongside recutils even
> > though it's no longer bundled with it.
>
> I have no clue if this is the intention or not but I always find that
> the emacs package names are in the format: emacs-FEATURE. As in I
> can just do (load "FEATURE") to load the package and start
> exploring. I was very confused when I first downloaded the package
> as (load "recutils") did nothing and I had to do (load "rec-
> mode"). I realize this convention isn't written down anywhere but I
> think maybe it should be because it's very helpful to me personally.
For the record, the convention is usually to use the upstream name, but
that's not always reasonable. In this particular case, I'd argue that
emacs-recutils is equally good as it's still close enough to upstream,
plus the package does not solely contain rec-mode and ob-rec could
equally be seen as entry point.

As for loading FEATURE, that again only works for single-feature
libraries. In addition, you shouldn't typically rely on (load
"FEATURE") or (require 'FEATURE) outside of other libraries anyway.
Autoloads exist and Guix handles them.

Cheers
Morgan Smith wrote 3 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 52439@debbugs.gnu.org)
BYAPR05MB4023FE1B2C1725F5931FA335C5739@BYAPR05MB4023.namprd05.prod.outlook.com
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (6 lines)
> For the record, the convention is usually to use the upstream name, but
> that's not always reasonable. In this particular case, I'd argue that
> emacs-recutils is equally good as it's still close enough to upstream,
> plus the package does not solely contain rec-mode and ob-rec could
> equally be seen as entry point.

The multiple entry points issue is certainly a valid issue with my idea.

Using the upstream name makes a lot of sense and I suppose my experience
of the main feature being equal to the name is actually a convention
that emacs package maintainers are doing, not guix.

That being said, the official upstream name is 100%, without a doubt,
"rec-mode".

The recutils info page only mentions the emacs mode once and explicitly
names it "rec-mode".

The rec-mode info page (as in `info rec-mode`) does say rec-mode is part
of the "recutils suite" but doesn't seem to ever refer to it as anything
other than rec-mode.

Toggle quote (5 lines)
> As for loading FEATURE, that again only works for single-feature
> libraries. In addition, you shouldn't typically rely on (load
> "FEATURE") or (require 'FEATURE) outside of other libraries anyway.
> Autoloads exist and Guix handles them.

I agree with you. Any programmatic thing based on package names is
bound to break. I was saying that interactive exploration was made
easier because I always had a good guess on what to load based on the
package name. I do rely on Guix to manage my autoloads but I don't
restart my Emacs just to check out a package.
Liliana Marie Prikler wrote 3 years ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)(address . 52439@debbugs.gnu.org)
e14f5a841d7ff49cc8e3a8bf3e407e755154114d.camel@gmail.com
Hi,

Am Samstag, den 11.12.2021, 20:15 -0500 schrieb Morgan Smith:
Toggle quote (6 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > For the record, the convention is usually to use the upstream name,
> > *but that's not always reasonable*.

> > *In this particular case*, I'd argue that emacs-recutils *is
> > equally good*
Emphasis added.

Toggle quote (3 lines)
> Using the upstream name makes a lot of sense [...]
> That being said, the official upstream name is 100%, without a doubt,
> "rec-mode".
While yes, the usual convention is to use the upstream name, and that
is rec-mode, there are also packages which break this convention
somewhere. For instance, there are many packages which drop their
-mode suffix on ELPA or MELPA, in which we use the dropped suffix
convention, most notably emacs-org.

On a somewhat related note, due to a bug report from yours truly, rec-
mode has recently bumped its version. There is no tag yet and it's not
available through ELPA (though it is already in their git), but the
latest version as of writing is 1.8.2. If you still insist on the
rename, I suggest doing a series, which
1. bumps the version and changes the origin,
2. moves the package to emacs-xyz (optional), and
3. does the rename,
once we have an official 1.8.2 tarball from somewhere, or otherwise
reference the version-bumping commit.
In any case, we shouldn't add noise such as re-exporting the package
from a different module.

Cheers
Morgan.J.Smith wrote 3 years ago
[PATCH] gnu: emacs-recutils: Update to 1.8.2-0.058dbe4.
(address . liliana.prikler@gmail.com)
BYAPR05MB402343D6BA6C604D5DE1755CC5759@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/databases.scm (emacs-recutils): Update to 1.8.2-0.058dbe4.
[inherit]: Don't inherit from recutils
[source]: Add
[native-inputs]: Add texinfo
[home-page]: Add
[arguments]: Add make-info phase
[license]: Add
---

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (3 lines)
> For the record, the convention is usually to use the upstream name,
> *but that's not always reasonable*.

I am very tempted to put rec-mode in the upstream-name package
properties but I feel like that is not at all what that property is
intended for.

Thanks for being open to a name change but I'm starting to feel like
maybe I'm just being stubborn and there would be very little benefit
:P. Especially since you've raised some very good points.

Also thanks for reporting that bug! I had experienced it but didn't
bother to debug it :P

gnu/packages/databases.scm | 49 +++++++++++++++++++++++++-------------
1 file changed, 33 insertions(+), 16 deletions(-)

Toggle diff (69 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7cff0f99c5..c0b714fc37 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -141,6 +141,7 @@ (define-module (gnu packages databases)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tcl)
#:use-module (gnu packages terminals)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -1384,24 +1385,40 @@ (define-public recutils
(home-page "https://www.gnu.org/software/recutils/")))
(define-public emacs-recutils
- (package
- (inherit recutils)
- (name "emacs-recutils")
- (build-system emacs-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "etc")
- #t)))))
- (native-inputs '())
- (inputs '())
- (synopsis "Emacs mode for working with recutils database files")
- (description "This package provides an Emacs major mode @code{rec-mode}
+ ;; Untagged release
+ (let ((commit "058dbe420e63bd460c0c8d09dd97ab55bc45533a")
+ (revision "0"))
+ (package
+ (name "emacs-recutils")
+ (version (git-version "1.8.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/recutils/rec-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qy8wrj14nzxzr6zvs4574v54jlhqszm1ybgq4a8pavkx2ay4c7r"))
+ (modules '((guix build utils)))
+ (snippet '(begin (delete-file "rec-mode.info")))))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "makeinfo" "--no-split"
+ "-o" "rec-mode.info" "rec-mode.texi"))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (build-system emacs-build-system)
+ (home-page "https://www.gnu.org/software/recutils/")
+ (synopsis "Emacs mode for working with recutils database files")
+ (description "This package provides an Emacs major mode @code{rec-mode}
for working with GNU Recutils text-based, human-editable databases. It
supports editing, navigation, and querying of recutils database files
-including field and record folding.")))
+including field and record folding.")
+ (license license:gpl3+))))
(define-public rocksdb
(package
--
2.34.0
Liliana Marie Prikler wrote 3 years ago
(address . Morgan.J.Smith@outlook.com)(address . 52439@debbugs.gnu.org)
15aecbbfba26c94dc856f516dbe39d27c910d254.camel@gmail.com
Hi,

Note, that you don't need to clean any of this up; I'll do it myself
before pushing. However, due to the recent c-u-f merge and the fact
that I only have limited time per day to actually push things, I wanted
to give some feedback ahead of time for the sake of transparency.

Am Montag, den 13.12.2021, 19:54 -0500 schrieb
Morgan.J.Smith@outlook.com:
Toggle quote (11 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/databases.scm (emacs-recutils): Update to 1.8.2-
> 0.058dbe4.
> [inherit]: Don't inherit from recutils
> [source]: Add
> [native-inputs]: Add texinfo
> [home-page]: Add
> [arguments]: Add make-info phase
> [license]: Add
> ---
Generally, we use full sentences here.
Toggle quote (8 lines)
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> > For the record, the convention is usually to use the upstream name,
> > *but that's not always reasonable*.
>
> I am very tempted to put rec-mode in the upstream-name package
> properties but I feel like that is not at all what that property is
> intended for.
You *can* actually use upstream-name if you use elpa as source. That
would have the effect of making `guix refresh' work as intended.

Toggle quote (3 lines)
> Thanks for being open to a name change but I'm starting to feel like
> maybe I'm just being stubborn and there would be very little benefit
> :P. Especially since you've raised some very good points.
Uhm, actually I'm just as stubborn in not wanting another deprecated-
package :P

Toggle quote (42 lines)
> gnu/packages/databases.scm | 49 +++++++++++++++++++++++++-----------
> --
> 1 file changed, 33 insertions(+), 16 deletions(-)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 7cff0f99c5..c0b714fc37 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -141,6 +141,7 @@ (define-module (gnu packages databases)
> #:use-module (gnu packages sqlite)
> #:use-module (gnu packages tcl)
> #:use-module (gnu packages terminals)
> + #:use-module (gnu packages texinfo)
> #:use-module (gnu packages textutils)
> #:use-module (gnu packages time)
> #:use-module (gnu packages tls)
> @@ -1384,24 +1385,40 @@ (define-public recutils
> (home-page "https://www.gnu.org/software/recutils/")))
>
> (define-public emacs-recutils
> - (package
> - (inherit recutils)
> - (name "emacs-recutils")
> - (build-system emacs-build-system)
> - (arguments
> - '(#:phases
> - (modify-phases %standard-phases
> - (add-after 'unpack 'change-directory
> - (lambda _
> - (chdir "etc")
> - #t)))))
> - (native-inputs '())
> - (inputs '())
> - (synopsis "Emacs mode for working with recutils database files")
> - (description "This package provides an Emacs major mode
> @code{rec-mode}
> + ;; Untagged release
> + (let ((commit "058dbe420e63bd460c0c8d09dd97ab55bc45533a")
> + (revision "0"))
> + (package
> + (name "emacs-recutils")
> + (version (git-version "1.8.2" revision commit))
Following the discussion over at rec-mode, it appears as though ELPA is
seen as some source of truth. That is a bit disappointing to us
Guixers, given the lz vs. uncompressed archive thing ELPA has, but I
think we can point to ELPA here while ensuring that we also push this
to SWH.
Toggle quote (23 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "
> https://git.savannah.gnu.org/git/recutils/rec-mode.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1qy8wrj14nzxzr6zvs4574v54jlhqszm1ybgq4a8pavkx2ay4
> c7r"))
> + (modules '((guix build utils)))
> + (snippet '(begin (delete-file "rec-mode.info")))))
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (add-before 'install 'make-info
> + (lambda _
> + (invoke "makeinfo" "--no-split"
> + "-o" "rec-mode.info" "rec-mode.texi"))))))
> + (native-inputs
> + `(("texinfo" ,texinfo)))
> + (build-system emacs-build-system)
It's always a good idea to put build-system before arguments.
Toggle quote (12 lines)
> + (synopsis "Emacs mode for working with recutils database
> files")
> + (description "This package provides an Emacs major mode
> @code{rec-mode}
> for working with GNU Recutils text-based, human-editable
> databases. It
> supports editing, navigation, and querying of recutils database
> files
> -including field and record folding.")))
> +including field and record folding.")
> + (license license:gpl3+))))
Otherwise LGTM. Again, I'll push this with adjustments to the above
soon™, but can't promise a fix date yet.

Cheers
Liliana Marie Prikler wrote 3 years ago
(address . Morgan.J.Smith@outlook.com)(address . 52439-done@debbugs.gnu.org)
788b066e2cadee3405f4bfdbf9c069f5bf6fb9ca.camel@gmail.com
Am Dienstag, den 14.12.2021, 20:36 +0100 schrieb Liliana Marie Prikler:
Toggle quote (7 lines)
> Hi,
>
> Note, that you don't need to clean any of this up; I'll do it myself
> before pushing. However, due to the recent c-u-f merge and the fact
> that I only have limited time per day to actually push things, I
> wanted to give some feedback ahead of time for the sake of
> transparency.
Sorry for the noise, it seems my pull finished quicker than expected.
I also followed up with the name change + deprecation, since handling
of upstream-name is not in the ELPA importer.

Thanks and enjoy Guix 1.4.0
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52439@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52439
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help