Add lifeograph

  • Open
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Nicolas Goaziou
  • Pradana Adrinusa AUMARS
Owner
unassigned
Submitted by
Pradana Adrinusa AUMARS
Severity
normal
P
P
Pradana Adrinusa AUMARS wrote on 11 Dec 2021 19:02
(address . guix-patches@gnu.org)
8f43f4093a94b958fe8d65ae731e4b0405e9a01f.camel@courrier.dev
From 324b8cd3c801ad7c106725aff59fa65d00b50341 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sat, 11 Dec 2021 18:58:51 +0100
Subject: [PATCH] gnu: Add lifeograph.

* gnu/packages/lifeograph.scm (lifeograph): New file.
---
gnu/packages/lifeograph.scm | 56 +++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
create mode 100644 gnu/packages/lifeograph.scm

Toggle diff (64 lines)
diff --git a/gnu/packages/lifeograph.scm b/gnu/packages/lifeograph.scm
new file mode 100644
index 0000000000..48d419e3b3
--- /dev/null
+++ b/gnu/packages/lifeograph.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>;.
+
+(define-module (gnu packages lifeograph)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system meson)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages enchant)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages pkg-config))
+
+(define-public rednotebook
+ (package
+ (name "lifeograph")
+ (version "2.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/" name "/trunk/" version
+ "/+download/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1sfr3fd07x995makdp5wx3lxf7kl156hilliw77d0vnjp8ri49xl"))))
+ (build-system meson-build-system)
+ (arguments `(#:build-type "release"))
+ (inputs
+ `(("gtkmm" ,gtkmm)
+ ("gtk+", gtk+ "bin")
+ ("enchant" ,enchant)
+ ("libgcrypt" ,libgcrypt)
+ ("libchamplain" ,libchamplain)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Off-line and private journal and note taking application")
+ (description "Lifeograph is a diary program to take personal notes on life.
+It has all the essential functionality expected in a diary program and strives
+to have a clean and streamlined user interface.")
+ (home-page "http://lifeograph.sourceforge.net/")
+ (license license:gpl3+)))
--
2.34.0
N
N
Nicolas Goaziou wrote on 17 Dec 2021 09:25
(name . Pradana Adrinusa AUMARS via Guix-patches via)(address . guix-patches@gnu.org)
87o85f63ks.fsf@nicolasgoaziou.fr
Hello,

Pradana Adrinusa AUMARS via Guix-patches via <guix-patches@gnu.org>
writes:

Toggle quote (5 lines)
> From 324b8cd3c801ad7c106725aff59fa65d00b50341 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sat, 11 Dec 2021 18:58:51 +0100
> Subject: [PATCH] gnu: Add lifeograph.

Thank you. Some comments follow.

Toggle quote (2 lines)
> * gnu/packages/lifeograph.scm (lifeograph): New file.

If you create a new file (is in necessary?), you need to also register
it in local.mk file.

Toggle quote (4 lines)
> +(define-public rednotebook
> + (package
> + (name "lifeograph")

There's a mismatch between the name of the variable and the package.

Toggle quote (3 lines)
> + (version "2.0.2")
> + (source (origin

Could you move origin below source?

Toggle quote (4 lines)
> + (method url-fetch)
> + (uri (string-append "https://launchpad.net/" name "/trunk/" version
> + "/+download/" name "-" version ".tar.xz"))

You can hard-code "name" above.

Toggle quote (4 lines)
> + (sha256
> + (base32
> + "1sfr3fd07x995makdp5wx3lxf7kl156hilliw77d0vnjp8ri49xl"))))

Hash string should go on the same line as base32.

Toggle quote (3 lines)
> + (build-system meson-build-system)
> + (arguments `(#:build-type "release"))

Could you explain in a comment why "release" is needed?

Toggle quote (7 lines)
> + (inputs
> + `(("gtkmm" ,gtkmm)
> + ("gtk+", gtk+ "bin")
> + ("enchant" ,enchant)
> + ("libgcrypt" ,libgcrypt)
> + ("libchamplain" ,libchamplain)))

Could you sort inputs alphabetically? Also could you use new inputs
style:

(inputs
(list enchant `(,gtk+ "bin") gtkmm ...))

Toggle quote (3 lines)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))

Ditto:

(native-inputs
(list pkg-config))

Toggle quote (7 lines)
> + (synopsis "Off-line and private journal and note taking application")
> + (description "Lifeograph is a diary program to take personal notes on life.
> +It has all the essential functionality expected in a diary program and strives
> +to have a clean and streamlined user interface.")
> + (home-page "http://lifeograph.sourceforge.net/")
> + (license license:gpl3+)))

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
J
J
Josselin Poiret wrote on 17 Dec 2021 10:13
87tuf7y4ps.fsf@jpoiret.xyz
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (3 lines)
> Could you sort inputs alphabetically? Also could you use new inputs
> style:

Just chiming in to say that the new input style is documented at
"(guix)package Reference" in the info manual, or at [1].


Best,
Josselin Poiret
P
P
Pradana Adrinusa AUMARS wrote on 21 Dec 2021 16:21
(address . 52437@debbugs.gnu.org)
c7e8197821fac78fa1880ef429b3525708e0aa96.camel@courrier.dev
Hello again,

I think it's better to first rename rednotebook.scm to journal.scm and
add the lifeograph package in that.

So I've written a new patch for that.


Thanks.
?