[PATCH] gnu: Add udpcast

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
871r2m7pld.fsf@gmail.com
Hello Guixers,

this patch adds udpcast. [1]

Unfortunately the official site seems to be not very reliable. So I
decided to use a mirror site to download the archive. [2]

Thanks,

- Artyom

From 15a0b78195c39efb337d161fac327d1e77f939db Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Tue, 7 Dec 2021 23:55:13 +0300
Subject: [PATCH] gnu: Add udpcast

* gnu/packages/admin.scm (udpcast): New variable.
---
gnu/packages/admin.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e640149a51..43f124df9b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,6 +117,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages m4)
#:use-module (gnu packages mail)
#:use-module (gnu packages man)
#:use-module (gnu packages mcrypt)
@@ -4815,3 +4817,42 @@ FIFO and UNIX interprocess communication.")
exit code reports successful or failed execution to
@url{https://healthchecks.io,https://healthchecks.io} or your private instance.")
(license license:bsd-0)))
+
+(define-public udpcast
+ (package
+ (name "udpcast")
+ (version "20200328")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (format #f
+ ;; XXX: Original server is at https://www.udpcast.linux.lu
+ ;; Unfortunately it's not very reliable:
+ ;; "https://www.udpcast.linux.lu/download/udpcast-~a.tar.gz"
+ ;; Here's an alternative URL for downloading the package:
+ ;; "https://fossies.org/linux/privat/udpcast-~a.tar.gz"
+ ;; "http://sources.buildroot.net/udpcast/udpcast-~a.tar.gz"
+ "http://sources.buildroot.net/udpcast/udpcast-~a.tar.gz"
+ version))
+ (sha256
+ (base32 "06pj86nbi9hx7abbb0z2c5ynhfq0rv89b7nmy0kq3xz2lsxfw6cw"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("m4" ,m4)
+ ("perl" ,perl)))
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (synopsis
+ "Multicast file transfer tool")
+ (description
+ "UDPcast is a file transfer tool that can send data simultaneously to
+many destinations on a LAN. This can for instance be used to install entire
+classrooms of PC's at once. The advantage of UDPcast over using other
+methods (nfs, ftp, whatever) is that UDPcast uses UDP's multicast abilities:
+it won't take longer to install 15 machines than it would to install just 2.")
+ (home-page "https://www.udpcast.linux.lu")
+ (license license:gpl2+)))
+
+
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGxI64ACgkQ6cWi2QiY
oC9ARAgAh5q0NP+9YBOf/zAAwR4rxj4I9Y8zs5JYYyHmTbeUIn/z/tdSNs7vcN4L
H5OlB7nNpQHwYd1vxXkr84Oc0puiAtzAAnE3QB4yNv90Qdp5jPDwYFPI97QebefO
/OLOzYrvJmdeDnFbViwMQXff4bwIOAcOV6q1+7I2oyJYqUWHBphO6/lCgTAEYFry
zoF780BIUGpUj4duUrWnCPdhVYX20UDL15UlOTbXfZ60fdWi3uprHq7zx2TBGGL5
y+k1cBJm+D3migLeRF9Y6j3/Sg+0BEkQbjXRf19w0fLUpyeexIEPvfM6OR2M46AJ
ISbmBPMkaLVl1uwOTQTAvShjuwgOdg==
=fw6L
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 52379-done@debbugs.gnu.org)
87tuf3ia1p.fsf@gnu.org
Hello,

poptsov.artyom@gmail.com (Artyom V. Poptsov) skribis:

Toggle quote (7 lines)
> From 15a0b78195c39efb337d161fac327d1e77f939db Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Tue, 7 Dec 2021 23:55:13 +0300
> Subject: [PATCH] gnu: Add udpcast
>
> * gnu/packages/admin.scm (udpcast): New variable.

Applied with the changes below.

Thanks!

Ludo’.
Toggle diff (46 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f62f7bd808..ee11120ce0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4829,27 +4829,24 @@ (define-public udpcast
(source
(origin
(method url-fetch)
- (uri (format #f
- ;; XXX: Original server is at https://www.udpcast.linux.lu
- ;; Unfortunately it's not very reliable:
- ;; "https://www.udpcast.linux.lu/download/udpcast-~a.tar.gz"
- ;; Here's an alternative URL for downloading the package:
- ;; "https://fossies.org/linux/privat/udpcast-~a.tar.gz"
- ;; "http://sources.buildroot.net/udpcast/udpcast-~a.tar.gz"
- "http://sources.buildroot.net/udpcast/udpcast-~a.tar.gz"
- version))
+ ;; XXX: Original server is at https://www.udpcast.linux.lu is not
+ ;; reliable.
+ (uri (list (string-append
+ "http://sources.buildroot.net/udpcast/udpcast-"
+ version ".tar.gz")
+ (string-append
+ "https://fossies.org/linux/privat/udpcast-"
+ version ".tar.gz")
+ (string-append
+ "https://www.udpcast.linux.lu/download/udpcast-"
+ version ".tar.gz")))
(sha256
(base32 "06pj86nbi9hx7abbb0z2c5ynhfq0rv89b7nmy0kq3xz2lsxfw6cw"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("m4" ,m4)
- ("perl" ,perl)))
- (arguments
- `(#:tests? #f)) ; no test suite
- (synopsis
- "Multicast file transfer tool")
+ (list autoconf automake m4 perl))
+ (arguments `(#:tests? #f)) ;no test suite
+ (synopsis "Multicast file transfer tool")
(description
"UDPcast is a file transfer tool that can send data simultaneously to
many destinations on a LAN. This can for instance be used to install entire
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52379@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52379
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help