[PATCH 0/2] Update tdlib and emacs-telega.

  • Done
  • quality assurance status badge
Details
4 participants
  • Andrew Tropin
  • Liliana Marie Prikler
  • Nicolas Goaziou
  • Evgeny Zajcev
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 8 Dec 2021 10:27
(address . guix-patches@gnu.org)(address . zevlg@yandex.ru)
875yrzh2ee.fsf@trop.in
tdlib version 1.7.0 is deprecated and doesn't work anymore, there is no
1.7.9 tag in upstream repo, but the version is present in source code.

emacs-telega 0.7.031 is inteded for tdlib 1.7.0, but because this tdlib
version doesn't work anymore, Evgeny (author of telega.el) suggest to
use telega version from master branch. I used 0.7.15 tag (closest tag
to the version in master branch I found) + revision + commit hash.

Without those updates tdlib and all clients based on it doesn't work,
it's quite unfortunate behavior from Telegram developers, IMHO of
course, but it's necessary to update to non-tagged versions to get it
work again.

Andrew Tropin (2):
gnu: tdlib: Update to 1.7.9-1.858078d.
gnu: emacs-telega: Update to 0.7.15-1.acf2d99.

gnu/packages/emacs-xyz.scm | 100 +++++++++---------
gnu/packages/messaging.scm | 80 +++++++-------
.../emacs-telega-path-placeholder.patch | 49 ++++-----
.../patches/emacs-telega-test-env.patch | 30 ++++--
4 files changed, 134 insertions(+), 125 deletions(-)

--
2.34.0
From 9a302410c4cc5ea09e656afdbce50e67127ddd9a Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Tue, 7 Dec 2021 14:15:32 +0300
Subject: [PATCH 1/2] gnu: tdlib: Update to 1.7.9-1.858078d.

* gnu/packages/messaging.scm (tdlib): Update to 1.7.9-1.858078d.
---
gnu/packages/messaging.scm | 80 +++++++++++++++++++-------------------
1 file changed, 41 insertions(+), 39 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4856df732e..3151ab0b3f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2648,48 +2648,50 @@ (define-public telegram-purple
(license license:gpl2+)))
(define-public tdlib
- (package
- (name "tdlib")
- (version "1.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tdlib/td")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "0dfir57ljcn98mkg061c5642qb93wh2lm1n4nngpl3na9vvfk75i"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #t
- #:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda _
- (substitute* "test/CMakeLists.txt"
- ;; The test cases are compiled into a distinct binary
- ;; which uses mtproto.cpp to attempt to connect to
- ;; a remote server. Removing this file from the sources
- ;; list disables those specific test cases.
- (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
- #t)))))
- (native-inputs
- `(("gperf" ,gperf)
- ("openssl" ,openssl)
- ("zlib" ,zlib)
- ("php" ,php)
- ("doxygen" ,doxygen)))
- (synopsis "Cross-platform library for building Telegram clients")
- (description "Tdlib is a cross-platform library for creating custom
+ (let ((commit "858078d89fcd2ad1d9860547e3f87c49d0f9abe9")
+ (revision "1"))
+ (package
+ (name "tdlib")
+ (version (git-version "1.7.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdlib/td")
+ (commit commit)))
+ (sha256
+ (base32
+ "1xwb2nb2ijdnz9q2v2mdaf7fsd2xzycxb3wmmf6dv63wl1h3hcwq"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #t
+ #:configure-flags
+ (list "-DCMAKE_BUILD_TYPE=Release"
+ "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda _
+ (substitute* "test/CMakeLists.txt"
+ ;; The test cases are compiled into a distinct binary
+ ;; which uses mtproto.cpp to attempt to connect to
+ ;; a remote server. Removing this file from the sources
+ ;; list disables those specific test cases.
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
+ #t)))))
+ (native-inputs
+ `(("gperf" ,gperf)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)
+ ("php" ,php)
+ ("doxygen" ,doxygen)))
+ (synopsis "Cross-platform library for building Telegram clients")
+ (description "Tdlib is a cross-platform library for creating custom
Telegram clients following the official Telegram API. It can be easily used
from almost any programming language with a C-FFI and features first-class
support for high performance Telegram Bot creation.")
- (home-page "https://core.telegram.org/tdlib")
- (license license:boost1.0)))
+ (home-page "https://core.telegram.org/tdlib")
+ (license license:boost1.0))))
(define-public purple-mm-sms
(package
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmGwepkPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wjIMQAJah1k1Xgd3fwqzWmXKAwMvXHElkdtP83Oj+
3Fs+u5aoZx32L3e56b6lbZ8KsmLybwAkUkHHe6fSA+4QL+uPm3rRsZbcILGVN5Ut
IUKklDz5r+gllP4Fiha2xM5FyYAMFv+VfJf+Ua61AwItjqhe45ApiqFGeyWaiU9L
7GCAnK17zJyMwwCWD+IVR4r0FN/QqbV0vBOs1qwOnTORj84Pdu9sd6KG1WjGOrbZ
TUU6LWLOc8xTVEXWpxdJ/h+luc2FGZtdT+Lt/aWRyu9kgLHU3qdsU8QhI8gEscX2
YSBokrCKSjdKhdRPVHeD/KyN5uGXUm2sHrLXj2fHA6erA4di2bwh50Yey+jjm6sn
Qnd9JEPUKuHgMQ26VsgUQXjGB3l2QJB51IVISWPu/FQ4y2frDK8BZOFuYL9Xj9J3
Jrt/ZEZ5Kvs1V5YHhRpk01RtF8OxR4uJSl+U+f66FRacDtlws6+mdp22dWJ0BLTV
8nOdrK104E9p3TqdzbGJJi/+pEypT0q7qlMkOo+7+9aaei96J2QxNFsHZ3nBqDNb
xdKdck/TgKkdOUNDizaJhYC8YvP955esEMo3ilcBwNKLu8mZBq6dyRy36WYgKNWd
TviKFVYzgnEr2PN5Sv8CYCmrhCyWRHVvPMChWOklj2RHUJX3n4+SS5vhDFv/2Sww
V7XKJzk0
=hjtw
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 9 Dec 2021 09:27
(name . Andrew Tropin)(address . andrew@trop.in)
87bl1qtc7y.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (14 lines)
> tdlib version 1.7.0 is deprecated and doesn't work anymore, there is no
> 1.7.9 tag in upstream repo, but the version is present in source code.
> https://github.com/tdlib/td/blob/858078d89fcd2ad1d9860547e3f87c49d0f9abe9/CMakeLists.txt#L9
>
> emacs-telega 0.7.031 is inteded for tdlib 1.7.0, but because this tdlib
> version doesn't work anymore, Evgeny (author of telega.el) suggest to
> use telega version from master branch. I used 0.7.15 tag (closest tag
> to the version in master branch I found) + revision + commit hash.
>
> Without those updates tdlib and all clients based on it doesn't work,
> it's quite unfortunate behavior from Telegram developers, IMHO of
> course, but it's necessary to update to non-tagged versions to get it
> work again.

Thank you.

Could you use commit a53cb30e99f937cfd64e0266fa558785a184a553 for tdlib.
It corresponds to release 0.7.10 so you don't have to use revision and
commit binding.

Also, could you send this in two separate patches, and provide a proper
commit message, specifying new patch files and registering them in
local.mk?

Also, you can remove trailing #t from phases.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
E
E
Evgeny Zajcev wrote on 9 Dec 2021 09:43
(address . mail@nicolasgoaziou.fr)
CAO=W_Zp_T0oKe0agkT4Ro5d4bcvSKV+9hDrjiWgm5e+4byc9mg@mail.gmail.com
??, 9 ???. 2021 ?. ? 11:27, Nicolas Goaziou <mail@nicolasgoaziou.fr>:

Toggle quote (26 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
> > tdlib version 1.7.0 is deprecated and doesn't work anymore, there is no
> > 1.7.9 tag in upstream repo, but the version is present in source code.
> >
> https://github.com/tdlib/td/blob/858078d89fcd2ad1d9860547e3f87c49d0f9abe9/CMakeLists.txt#L9
> >
> > emacs-telega 0.7.031 is inteded for tdlib 1.7.0, but because this tdlib
> > version doesn't work anymore, Evgeny (author of telega.el) suggest to
> > use telega version from master branch. I used 0.7.15 tag (closest tag
> > to the version in master branch I found) + revision + commit hash.
> >
> > Without those updates tdlib and all clients based on it doesn't work,
> > it's quite unfortunate behavior from Telegram developers, IMHO of
> > course, but it's necessary to update to non-tagged versions to get it
> > work again.
>
> Thank you.
>
> Could you use commit a53cb30e99f937cfd64e0266fa558785a184a553 for tdlib.
> It corresponds to release 0.7.10 so you don't have to use revision and
> commit binding.
>

If TDLib 1.7.10 will be used, then use 3dfa0f0 for telega.el, this commit
adds initial support for TDLib 1.7.10

TDLib 1.7.10 is not compatible with TDLib 1.7.9, and it won't work with
telega without TDLib 1.7.10 support.

--
lg
Attachment: file
A
A
Andrew Tropin wrote on 9 Dec 2021 12:43
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87lf0udmvo.fsf@trop.in
On 2021-12-09 09:27, Nicolas Goaziou wrote:

Toggle quote (24 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> tdlib version 1.7.0 is deprecated and doesn't work anymore, there is no
>> 1.7.9 tag in upstream repo, but the version is present in source code.
>> https://github.com/tdlib/td/blob/858078d89fcd2ad1d9860547e3f87c49d0f9abe9/CMakeLists.txt#L9
>>
>> emacs-telega 0.7.031 is inteded for tdlib 1.7.0, but because this tdlib
>> version doesn't work anymore, Evgeny (author of telega.el) suggest to
>> use telega version from master branch. I used 0.7.15 tag (closest tag
>> to the version in master branch I found) + revision + commit hash.
>>
>> Without those updates tdlib and all clients based on it doesn't work,
>> it's quite unfortunate behavior from Telegram developers, IMHO of
>> course, but it's necessary to update to non-tagged versions to get it
>> work again.
>
> Thank you.
>
> Could you use commit a53cb30e99f937cfd64e0266fa558785a184a553 for tdlib.
> It corresponds to release 1.7.10 so you don't have to use revision and
> commit binding.

Will do.

Toggle quote (5 lines)
>
> Also, could you send this in two separate patches, and provide a proper
> commit message, specifying new patch files and registering them in
> local.mk?

Not sure what you mean, there are already two inline patches with proper
commit messages (at least I hope it's proper :).

The patches for telegram.el are not new, so they already registered in
local.mk, I just updated the content to match current source code.

Toggle quote (7 lines)
>
> Also, you can remove trailing #t from phases.
>
> Could you send an updated patch?
>
> Regards,

Yep.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmGx6+sPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6w3DsP/0KgLsrPgytkW3exF5hSFQpGPXiFOpdDjbr0
fwI84WwZ2kRoFRJX2a61TZgbBoF13bvVgQ2Dv5KXqHbkC0jKFyWymPAMUe+KFAAa
KKmMCh4eBFmhnPpKwA6gg5Z7yW9Joi+vknq2d7hm0/z4QJLP4Vbjc28aQocuGtbJ
nsv1p09NXzIY6XvBb9QJTa29AqUTcB5jahVkuMjr8jnG1vO44WJQ3N1DUhpYzVv7
FwcGyYFj6Bxbu6DPiTKM0qGp5Q4C2z/axIgugzuu1J+BqYr1cDntvbO4b9kc8cex
pGRHDg2uuKfT+aNAm5QxYYd+620G1yhUgEZI06oKKWvgbJ4uDnWIm9xrXLqYCnmM
iW51BwENzRZ3s/E47ZzA2E2UEwDOLpUGe403sWeHR+xvRFezRJ7MXsWpppW5S4xX
2GO9E1wevIJJLA/ks+vmSfCoZUwWFAQfWcKI/8uxtSqB22xDEY4dFeZAZ5nYW7XN
mVI+Qgw27o+N5KRG3V/tlQcGSJy+XFkcqichv4mCMFq4ek6odI35WFiU6TrpNlr+
S72eFqI35LVYdWkasJWYZRJLglsuGue5Ca/4+vAPOmgBGmIpNHlYuzAtGGKXs0Dp
GAgocX7rlu7xmp/QmAawKXI8RezOCHc8cCKdG5m5bwx+fAe/bQkqLhLcq+7yk2CC
Fx8lHlyc
=lKfP
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 9 Dec 2021 16:34
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87k0gdg5b9.fsf@trop.in
On 2021-12-09 09:27, Nicolas Goaziou wrote:

Toggle quote (24 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> tdlib version 1.7.0 is deprecated and doesn't work anymore, there is no
>> 1.7.9 tag in upstream repo, but the version is present in source code.
>> https://github.com/tdlib/td/blob/858078d89fcd2ad1d9860547e3f87c49d0f9abe9/CMakeLists.txt#L9
>>
>> emacs-telega 0.7.031 is inteded for tdlib 1.7.0, but because this tdlib
>> version doesn't work anymore, Evgeny (author of telega.el) suggest to
>> use telega version from master branch. I used 0.7.15 tag (closest tag
>> to the version in master branch I found) + revision + commit hash.
>>
>> Without those updates tdlib and all clients based on it doesn't work,
>> it's quite unfortunate behavior from Telegram developers, IMHO of
>> course, but it's necessary to update to non-tagged versions to get it
>> work again.
>
> Thank you.
>
> Could you use commit a53cb30e99f937cfd64e0266fa558785a184a553 for tdlib.
> It corresponds to release 0.7.10 so you don't have to use revision and
> commit binding.

Updated tdlib and telega.

Toggle quote (7 lines)
>
> Also, could you send this in two separate patches, and provide a proper
> commit message, specifying new patch files and registering them in
> local.mk?
>
> Also, you can remove trailing #t from phases.

Removed.

Toggle quote (5 lines)
>
> Could you send an updated patch?
>
> Regards,

Attaching two patches.
From 2fdb921a278558bab3076805951d8131c7a2e780 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Tue, 7 Dec 2021 14:15:32 +0300
Subject: [PATCH 1/2] gnu: tdlib: Update to 1.7.10.

* gnu/packages/messaging.scm (tdlib): Update to 1.7.10.
---
gnu/packages/messaging.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4856df732e..9f90dc94d0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2650,15 +2650,15 @@ (define-public telegram-purple
(define-public tdlib
(package
(name "tdlib")
- (version "1.7.0")
+ (version "1.7.10")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tdlib/td")
- (commit (string-append "v" version))))
+ (commit "34ba9b21f365b8d3bdc36808c2d665ca5cd128f6")))
(sha256
(base32
- "0dfir57ljcn98mkg061c5642qb93wh2lm1n4nngpl3na9vvfk75i"))
+ "06fbdh1jypz0p1rf6xbpias4kx7xplq9xjd9vz177vwj9icq3wki"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
--
2.34.0
--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmGyIhsPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wzvQQAJN66vdX00smBxK9zsNc8zgVXvdnzqCghAoy
GXzJaq+JO4HTFbQZW4PUPXTm//iUXvoxy+lt/xcDR287hgKBUkh0xYYePv3g47Ia
8eO7m2vXFfIvEsZ6JFCTd20tBJeeDrTI9tbY697SCdfzTv2/YbnTtFc83exjhgjF
7999uRdgKZBO1v5L3QpJOqnUPUPNqUAPx9mALdpXKsrME+ldSaUC8JEaC/67dthj
uWmbZV0XNpKSMRVZdT9jGpBrlc2Y05cdnRwto2UPNtxM3ipiySC/whGnnrZE01kE
YQ3h9U11jLvmUjkiHs4+5pQU2F1mEsNqUpZwduB4kYrJIVquXrCL2lr1CRPoBRZx
1M2Gxx69mqgJs6TkjQO8aPGiONT/36ktGHJiM/M6pJlIYYuWP3/NUhSqoJcnzQ7R
iqWuIiZuN2+edJm/kWWTGqDycDoVPzDnrcMcda5BiD7O73fAVD+BmsouyouNjUGf
TIWW2u0hexQPT5gvBjVP1G0w8nSYjG7z+mBir3c/uyxR7XK0XHVF6MTP/PVFpFgb
JQ+fGmG+hT0C2CYghD5uGLw6dP6hnzM/DyKAWloN7qKo5URo+zjEQAPz2ft8N+6+
lYcRD7J3+TguOLhEcLFmCjxgVIeholP3iOZfK7ZN9D1/gBQygnUX2xIDmOmLKQio
PFJz/M7M
=cgd3
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 9 Dec 2021 20:39
6dfdd2d52bf2b52aa5022c4a085015ac535fccd6.camel@gmail.com
Hi,

note to self: I'm not trying to build tdlib again. Last build was not
finished after almost a day and power went out so I don't even know
whether it succeeded after I went to work or not.

Anyway,

Toggle quote (2 lines)
> +-(defcustom telega-server-command "telega-server"
> ++(defcustom telega-server-command "@TELEGA_SERVER_BIN@"
[...]
Toggle quote (7 lines)
> - (substitute* "telega-server.el"
> + (substitute* "telega-customize.el"
> (("@TELEGA_SERVER_BIN@")
> (string-append (assoc-ref inputs "emacs-telega-
> server")
> "/bin/telega-server")))
>
I know this has existed before your patch, but I'm pretty sure we have
emacs-based routines that could make this substitution in one go. If
you're interested in further janitor work, you could do this either on
master, or you could do something in terms of (search-input-file) on c-
u-f.

Other than that LGTM on a quick glance.
Cheers
A
A
Andrew Tropin wrote on 10 Dec 2021 08:40
878rwsj4bb.fsf@trop.in
On 2021-12-09 20:39, Liliana Marie Prikler wrote:

Toggle quote (6 lines)
> Hi,
>
> note to self: I'm not trying to build tdlib again. Last build was not
> finished after almost a day and power went out so I don't even know
> whether it succeeded after I went to work or not.

Ouch, IIRC it took a few dozens of minutes for my laptop. Do you use
underpowered hardware or something was wrong with compilation process?

Toggle quote (16 lines)
>
> Anyway,
>
>> +-(defcustom telega-server-command "telega-server"
>> ++(defcustom telega-server-command "@TELEGA_SERVER_BIN@"
> [...]
>> - (substitute* "telega-server.el"
>> + (substitute* "telega-customize.el"
>> (("@TELEGA_SERVER_BIN@")
>> (string-append (assoc-ref inputs "emacs-telega-
>> server")
>> "/bin/telega-server")))
>>
> I know this has existed before your patch, but I'm pretty sure we have
> emacs-based routines that could make this substitution in one go.

Do you mean emacs-substitute-sexps from (guix build emacs-utils) ?

Toggle quote (8 lines)
> If you're interested in further janitor work, you could do this either
> on master, or you could do something in terms of (search-input-file)
> on c- u-f.
>
> Other than that LGTM on a quick glance.
> Cheers
>

Let's keep it as it is right now, probably I'll be updating this package
later again and will refactor it.

Also, I'll need to update emacs-telega package to include add-pkg-file
phase if the patch will be merged, so I'll cleanup the other stuff
around it.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmGzBGgPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wwBYQAIvxweNrhAOhSMhdvkPoFGdMrryNJ5+rxR0c
ohebTfxFcZCdiEBvDjgGhbH5jtU9bAuPYdKHG7VO8ltwTrxVwP74Wwwa+U6G/my3
jmQqdgdqgRKmGwkkcfNR0MphkMj53URlzlLHmA869X+oVujicYyF/KcFnCrzM8b3
8vNXhInfJwm3rDupJo+cBC/e4Himzd7Y7Gfq41T5xqcDgGy+T8hwPyl2+5ncmAbJ
DKY+7YxbYh4AVQl2jyP3JrYG6fDG4U+Pug8+vT2iWWdbgLj5ACOVcjDkGBAA5Miu
b/PqwwLR0PYLGqLBu/buWFrdRNAZj2/RMEW+c92ssQkbxDlc+Z1XFEIf6kbWJ7oD
iGziiPH9+PRWbyp6Tkpq6bafw0dY0GTetxGgtFEtJX7tGa+eAR7JDotoe0+pKmaE
pJZKkIdRtUneLqzSDQg5PIPbgTB9v7jRWQx4SwJJZw0uvwlLPwKCYbW6xkciytov
GCTSmt6pS2A/eC9wLAEjAKsmqYVnTbH1j/kNGZP1sSwu1fDtxKgA63xV6sRtZnyE
ucmkNlVykwbPo+JsDpAyzTu5WjZzljyMYRFeGmwlIrctnLY1V0KEvM73DgbMH8pk
cGjJ/LJNHqn4tl2tQ+8cjoazPgHb41CkVTPRHrdwy6GZFYxHqP7TgJPARFbLGun9
lIGtqZWT
=mSpL
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 10 Dec 2021 20:31
ec59192cc33e667d812cbd75fc9e7f78d739b9d4.camel@gmail.com
Am Freitag, den 10.12.2021, 10:40 +0300 schrieb Andrew Tropin:
Toggle quote (11 lines)
> On 2021-12-09 20:39, Liliana Marie Prikler wrote:
>
> > Hi,
> >
> > note to self: I'm not trying to build tdlib again. Last build was
> > not finished after almost a day and power went out so I don't even
> > know whether it succeeded after I went to work or not.
>
> Ouch, IIRC it took a few dozens of minutes for my laptop. Do you use
> underpowered hardware or something was wrong with compilation
> process?
It's the check phase that's killing me, but that doesn't really rule
out weak hardware. I'm not touching staging or core-updates for that
very reason.

Toggle quote (17 lines)
> > Anyway,
> >
> > > +-(defcustom telega-server-command "telega-server"
> > > ++(defcustom telega-server-command "@TELEGA_SERVER_BIN@"
> > [...]
> > > - (substitute* "telega-server.el"
> > > + (substitute* "telega-customize.el"
> > > (("@TELEGA_SERVER_BIN@")
> > > (string-append (assoc-ref inputs "emacs-telega-
> > > server")
> > > "/bin/telega-server")))
> > >
> > I know this has existed before your patch, but I'm pretty sure we
> > have
> > emacs-based routines that could make this substitution in one go.
>
> Do you mean emacs-substitute-sexps from (guix build emacs-utils) ?
I think emacs-substitute-variables is the "correcter" option here, but
both are fine.

Toggle quote (14 lines)
> > If you're interested in further janitor work, you could do this
> > either on master, or you could do something in terms of (search-
> > input-file) on c-u-f.
> >
> > Other than that LGTM on a quick glance.
> > Cheers
> >
>
> Let's keep it as it is right now, probably I'll be updating this
> package later again and will refactor it.
>
> Also, I'll need to update emacs-telega package to include add-pkg-
> file phase if the patch will be merged, so I'll cleanup the other
> stuff around it.
Very well, you do you. I'll leave the final call to Nicolas then.

Thanks for your work and happy hacking :)
N
N
Nicolas Goaziou wrote on 11 Dec 2021 16:13
(name . Andrew Tropin)(address . andrew@trop.in)
878rwrqinw.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (7 lines)
> Let's keep it as it is right now, probably I'll be updating this package
> later again and will refactor it.
>
> Also, I'll need to update emacs-telega package to include add-pkg-file
> phase if the patch will be merged, so I'll cleanup the other stuff
> around it.

OK. Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52371@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52371
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch