(address . guix-patches@gnu.org)(address . zevlg@yandex.ru)
tdlib version 1.7.0 is deprecated and doesn't work anymore, there is no
1.7.9 tag in upstream repo, but the version is present in source code.
emacs-telega 0.7.031 is inteded for tdlib 1.7.0, but because this tdlib
version doesn't work anymore, Evgeny (author of telega.el) suggest to
use telega version from master branch. I used 0.7.15 tag (closest tag
to the version in master branch I found) + revision + commit hash.
Without those updates tdlib and all clients based on it doesn't work,
it's quite unfortunate behavior from Telegram developers, IMHO of
course, but it's necessary to update to non-tagged versions to get it
work again.
Andrew Tropin (2):
gnu: tdlib: Update to 1.7.9-1.858078d.
gnu: emacs-telega: Update to 0.7.15-1.acf2d99.
gnu/packages/emacs-xyz.scm | 100 +++++++++---------
gnu/packages/messaging.scm | 80 +++++++-------
.../emacs-telega-path-placeholder.patch | 49 ++++-----
.../patches/emacs-telega-test-env.patch | 30 ++++--
4 files changed, 134 insertions(+), 125 deletions(-)
--
2.34.0
From 9a302410c4cc5ea09e656afdbce50e67127ddd9a Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Tue, 7 Dec 2021 14:15:32 +0300
Subject: [PATCH 1/2] gnu: tdlib: Update to 1.7.9-1.858078d.
* gnu/packages/messaging.scm (tdlib): Update to 1.7.9-1.858078d.
---
gnu/packages/messaging.scm | 80 +++++++++++++++++++-------------------
1 file changed, 41 insertions(+), 39 deletions(-)
Toggle diff (96 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4856df732e..3151ab0b3f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2648,48 +2648,50 @@ (define-public telegram-purple
(license license:gpl2+)))
(define-public tdlib
- (package
- (name "tdlib")
- (version "1.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tdlib/td")
- (commit (string-append "v" version))))
- (sha256
- (base32
- "0dfir57ljcn98mkg061c5642qb93wh2lm1n4nngpl3na9vvfk75i"))
- (file-name (git-file-name name version))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #t
- #:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda _
- (substitute* "test/CMakeLists.txt"
- ;; The test cases are compiled into a distinct binary
- ;; which uses mtproto.cpp to attempt to connect to
- ;; a remote server. Removing this file from the sources
- ;; list disables those specific test cases.
- (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
- #t)))))
- (native-inputs
- `(("gperf" ,gperf)
- ("openssl" ,openssl)
- ("zlib" ,zlib)
- ("php" ,php)
- ("doxygen" ,doxygen)))
- (synopsis "Cross-platform library for building Telegram clients")
- (description "Tdlib is a cross-platform library for creating custom
+ (let ((commit "858078d89fcd2ad1d9860547e3f87c49d0f9abe9")
+ (revision "1"))
+ (package
+ (name "tdlib")
+ (version (git-version "1.7.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdlib/td")
+ (commit commit)))
+ (sha256
+ (base32
+ "1xwb2nb2ijdnz9q2v2mdaf7fsd2xzycxb3wmmf6dv63wl1h3hcwq"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #t
+ #:configure-flags
+ (list "-DCMAKE_BUILD_TYPE=Release"
+ "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda _
+ (substitute* "test/CMakeLists.txt"
+ ;; The test cases are compiled into a distinct binary
+ ;; which uses mtproto.cpp to attempt to connect to
+ ;; a remote server. Removing this file from the sources
+ ;; list disables those specific test cases.
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
+ #t)))))
+ (native-inputs
+ `(("gperf" ,gperf)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)
+ ("php" ,php)
+ ("doxygen" ,doxygen)))
+ (synopsis "Cross-platform library for building Telegram clients")
+ (description "Tdlib is a cross-platform library for creating custom
Telegram clients following the official Telegram API. It can be easily used
from almost any programming language with a C-FFI and features first-class
support for high performance Telegram Bot creation.")
- (home-page "https://core.telegram.org/tdlib")
- (license license:boost1.0)))
+ (home-page "https://core.telegram.org/tdlib")
+ (license license:boost1.0))))
(define-public purple-mm-sms
(package
--
2.34.0
-----BEGIN PGP SIGNATURE-----
iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmGwepkPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wjIMQAJah1k1Xgd3fwqzWmXKAwMvXHElkdtP83Oj+
3Fs+u5aoZx32L3e56b6lbZ8KsmLybwAkUkHHe6fSA+4QL+uPm3rRsZbcILGVN5Ut
IUKklDz5r+gllP4Fiha2xM5FyYAMFv+VfJf+Ua61AwItjqhe45ApiqFGeyWaiU9L
7GCAnK17zJyMwwCWD+IVR4r0FN/QqbV0vBOs1qwOnTORj84Pdu9sd6KG1WjGOrbZ
TUU6LWLOc8xTVEXWpxdJ/h+luc2FGZtdT+Lt/aWRyu9kgLHU3qdsU8QhI8gEscX2
YSBokrCKSjdKhdRPVHeD/KyN5uGXUm2sHrLXj2fHA6erA4di2bwh50Yey+jjm6sn
Qnd9JEPUKuHgMQ26VsgUQXjGB3l2QJB51IVISWPu/FQ4y2frDK8BZOFuYL9Xj9J3
Jrt/ZEZ5Kvs1V5YHhRpk01RtF8OxR4uJSl+U+f66FRacDtlws6+mdp22dWJ0BLTV
8nOdrK104E9p3TqdzbGJJi/+pEypT0q7qlMkOo+7+9aaei96J2QxNFsHZ3nBqDNb
xdKdck/TgKkdOUNDizaJhYC8YvP955esEMo3ilcBwNKLu8mZBq6dyRy36WYgKNWd
TviKFVYzgnEr2PN5Sv8CYCmrhCyWRHVvPMChWOklj2RHUJX3n4+SS5vhDFv/2Sww
V7XKJzk0
=hjtw
-----END PGP SIGNATURE-----