[PATCH] gnu: Add guile-ini

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87h7bn79yk.fsf@gmail.com
Hello Guixers,

this patch adds Guile-INI -- an INI format[1] parser for GNU Guile.

Guile-INI depends on the recently added Guile-SMC. [2]

Thanks,

- Artyom

References:
From 490dd30bfb6636818dc60759423e2ee52591682f Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 5 Dec 2021 11:00:14 +0300
Subject: [PATCH] gnu: Add guile-ini

* gnu/packages/guile-xyz.scm (guile-ini): New variable.
---
gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 508b4b44d5..67474e4d30 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4944,3 +4944,38 @@ compiler itself. It produces a Scheme code for an FSM from the PlantUML
format. This tool is meant to be called on a PlantUML file when a program
with a FSM is being built (for example, from a Makefile.)")
(license license:gpl3)))
+
+(define-public guile-ini
+ (package
+ (name "guile-ini")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-ini")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0injn60530valhx3gsmdp72g6z886yf0n08hscky21h3dafm14kc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("bash" ,bash-minimal)
+ ("guile" ,guile-3.0)
+ ("guile-smc" ,guile-smc)
+ ("guile-lib" ,guile-lib)))
+ (home-page "https://github.com/artyom-poptsov/guile-ini")
+ (synopsis "Guile interface to GitLab")
+ (description
+ "This package provides bindings to the GitLab Community Edition REST API
+as well as the @samp{gitlab-cli} command line tool for interacting with a
+GitLab instance.")
+ (license license:gpl3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGsctMACgkQ6cWi2QiY
oC9WSgf/Yl4AUVcLfS9G5URBAG7DEePIa6SBVwHAtTG23miIfJycM/yFpKvQ7csX
+9lnqH/9In+IbXRJX4xPySvwCQUzrD3aTcrcWbYC0Es2TxKcsGMXJak6FdrMMK7W
Y8bQuXzjAgd3VoNn6rj05IFrhF1Jf7jOrcnKBGktefDOs1NR258AXd0V89bu6PWY
fDkw3A89araXW9KxSuDn5wOiGGaTpasBVWX1D4QkUQBDxpiq0d1bO/bKFDxDc4sw
qdTRNBE94i1NOikB24xUrZfp00wcnUSqtHhcHNmIl6kGmnjamsu7k8hl4CHY7pSc
cmok9lxa1WfYIaNInt80p9vPom8+Bg==
=iPFG
-----END PGP SIGNATURE-----

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87bl1v7993.fsf@gmail.com
Oh, it seems that I fell victim of the copy-paste fewer.

Taking this opportunity, I also ran 'guile lint' on the Guile-INI
package.

Here's the fixed patch.

- Artyom
From 9d01c2f1a737c9b1995cba99eb56fee8fb99c030 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 5 Dec 2021 11:00:14 +0300
Subject: [PATCH] gnu: Add guile-ini

* gnu/packages/guile-xyz.scm (guile-ini): New variable.
---
gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 508b4b44d5..d022ae738f 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4944,3 +4944,38 @@ compiler itself. It produces a Scheme code for an FSM from the PlantUML
format. This tool is meant to be called on a PlantUML file when a program
with a FSM is being built (for example, from a Makefile.)")
(license license:gpl3)))
+
+(define-public guile-ini
+ (package
+ (name "guile-ini")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-ini")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0injn60530valhx3gsmdp72g6z886yf0n08hscky21h3dafm14kc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("bash" ,bash-minimal)
+ ("guile" ,guile-3.0)
+ ("guile-smc" ,guile-smc)
+ ("guile-lib" ,guile-lib)))
+ (home-page "https://github.com/artyom-poptsov/guile-ini")
+ (synopsis "GNU Guile library for working with INI format")
+ (description
+ "A GNU Guile library for working with
+@url{https://en.wikipedia.org/wiki/INI_file, INI format}. The library
+provides API for reading and writing INI data.")
+ (license license:gpl3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGsdmgACgkQ6cWi2QiY
oC8Gigf/X0Qw8P1/8VVWhQRz3zaLNb2EUj4mZkgT9XM5raW3twMG9U5m8CYINOjF
jPrEpPfr2RqQ0Jp0qnGR+4UMIngyEdAMLKKF7EvUL5rMtsCNg7X+2WAULtjfSySS
tSYoP8XAr6CJvQfhBDG5yTatMiTcXTf3PmgoCKofd3k1b2Jjro5KM3kHzDtGCBn4
Rzpa6wczvCiP006NfIhWC/sqm/5uc2Rsi9wu5JQcNJoqBTzEl4rf7D4+eB8IdsIj
e0x/8dbEmKrjeiUEl4MiGoJbEpsb4iLkO4YRXGqG29PoIG7+dgsQDhRaNIVclGIu
dm5kfTqFg3h4OfmOqxbGIHlwGXj3cg==
=+WvC
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
Re: [bug#52299] [PATCH] gnu: Add guile-ini
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 52299@debbugs.gnu.org)
878rwz1m5z.fsf@gnu.org
Hello Artyom,

Toggle quote (6 lines)
> + (synopsis "Guile interface to GitLab")
> + (description
> + "This package provides bindings to the GitLab Community Edition REST API
> +as well as the @samp{gitlab-cli} command line tool for interacting with a
> +GitLab instance.")

Looks like you forget to update those fields :).

Mathieu
Mathieu Othacehe wrote 3 years ago
Re: bug#52299: [PATCH] gnu: Add guile-ini
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 52299-done@debbugs.gnu.org)
875ys31lan.fsf_-_@gnu.org
Toggle quote (5 lines)
> Taking this opportunity, I also ran 'guile lint' on the Guile-INI
> package.
>
> Here's the fixed patch.

I added guile-smc to the propagated-inputs to fix the following error:

Toggle snippet (7 lines)
mathieu@meije ~/guix [env]$ make -j8 && ./pre-inst-env guix shell guile-ini guile
mathieu@meije ~/guix [env]$ guile -q
scheme@(guile-user)> ,use (ini)
While executing meta-command:
no code for module (smc fsm)

and pushed as 030d9b261fc81cf8047cc8f4dfd1f8e59e1fd3b7.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52299@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52299
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help