[PATCH] gnu: tinmop: Update to 0.9.2

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal
C
(address . guix-patches@gnu.org)
YapfC4SiPUU7BYom@kurosawa.casa.net
---
gnu/packages/web-browsers.scm | 34 ++++++++++++++++++++++++----------
1 file changed, 24 insertions(+), 10 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 908455a75b..db387f1b35 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -816,7 +816,7 @@ (define-public bombadillo
(define-public tinmop
(package
(name "tinmop")
- (version "0.8.3")
+ (version "0.9.2")
(source
(origin
(method git-fetch)
@@ -825,13 +825,17 @@ (define-public tinmop
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "117p1wxi5swmqw429qrswxz2zvp1dcaw2145gk6zxlgwln48qxl8"))))
+ (base32 "1cgx2g2kryfmcwqzzjzcpbdc6zzj10xc52gz0cj2dx5ylc0yg7k3"))))
(build-system gnu-build-system)
(native-inputs
- `(("curl" ,curl)
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf)
("gettext" ,gnu-gettext)
- ("gnupg" ,gnupg)
- ("sbcl" ,sbcl)))
+ ("mandoc" , mandoc)
+ ("nano" ,nano)
+ ("openssl" ,openssl)
+ ("sbcl" ,sbcl)
+ ("xdg-utils" ,xdg-utils)))
(inputs
`(("access" ,sbcl-access)
("alexandria" ,sbcl-alexandria)
@@ -854,8 +858,6 @@ (define-public tinmop
("local-time" ,sbcl-local-time)
("log4cl" ,sbcl-log4cl)
("marshal" ,sbcl-marshal)
- ("nano" ,nano)
- ("openssl" ,openssl)
("osicat" ,sbcl-osicat)
("parse-number" ,sbcl-parse-number)
("percent-encoding" ,sbcl-percent-encoding)
@@ -863,8 +865,7 @@ (define-public tinmop
("sxql-composer" ,sbcl-sxql-composer)
("tooter" ,sbcl-tooter)
("unix-opts" ,sbcl-unix-opts)
- ("usocket" ,sbcl-usocket)
- ("xdg-utils" ,xdg-utils)))
+ ("usocket" ,sbcl-usocket)))
(arguments
`(#:tests? #f
#:strip-binaries? #f
@@ -874,11 +875,24 @@ (define-public tinmop
(lambda _
(setenv "HOME" "/tmp")
#t))
+ (add-after 'unpack 'fix-configure.ac
+ (lambda _
+ (delete-file "configure")
+ (substitute* "configure.ac"
+ (("AC_PATH_PROG.+CURL")
+ "dnl")
+ (("AC_PATH_PROGS.+GIT")
+ "dnl")
+ (("AC_PATH_PROG.+GPG")
+ "dnl"))
+ #t))
(add-after 'configure 'fix-asdf
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile.in"
(("LISP_COMPILER) ")
- "LISP_COMPILER) --eval \"(require 'asdf)\" --eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))
+ (string-concatenate
+ '("LISP_COMPILER) --eval \"(require 'asdf)\" "
+ "--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
#t)))))
(synopsis "Gemini and pleroma client with a terminal interface")
(description
--
2.33.0
G
G
Guillaume Le Vaillant wrote on 4 Dec 2021 13:52
(name . cage)(address . cage-dev@twistfold.it)(address . 52262-done@debbugs.gnu.org)
875ys4zg2v.fsf@kitej
Patch pushed as 612fe425b413c914844f3d282a9d527c7609b5f7 with a complete
commit message.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYatk2A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j98vwD+Jo+oGl2zrWg+EXVB1Nt/hxSE0K+lKLE3eAeR
xeL7i+0A/AwPUn14RP4qQ2SOslauycMIRZzsRUAxNkLL2eG2lv2r
=v/ZM
-----END PGP SIGNATURE-----

Closed
C
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
YatoqpcJPgjjs9kp@kurosawa.casa.net
On Sat, Dec 04, 2021 at 12:52:55PM +0000, Guillaume Le Vaillant wrote:
Toggle quote (4 lines)
> Patch pushed as 612fe425b413c914844f3d282a9d527c7609b5f7 with a complete
> commit message.
> Thanks.

Thanks so much!
Bye!
C.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52262@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52262
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch