[PATCH] gnu: bullet: Update to 3.17

  • Done
  • quality assurance status badge
Details
4 participants
  • Andy Tai
  • Leo Famulari
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 3 years ago
(address . guix-patches@gnu.org)
CAJsg1E_hFQsFZu4xjjXp2hEhQcjDAzWFB=cRMkhiAEgxp+4YRw@mail.gmail.com
* gnu/packages/game-development.scm (bullet): Update to 3.17
---
gnu/packages/game-development.scm | 16 +++++++++++-----
1 file changed, 11 insertions(+), 5 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/game-development.scm
b/gnu/packages/game-development.scm
index 55bbad30e6..1b802d662f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,7 +113,7 @@ (define-module (gnu packages game-development)
(define-public bullet
(package
(name "bullet")
- (version "2.89")
+ (version "3.17")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -121,7 +122,7 @@ (define-public bullet
(file-name (git-file-name name version))
(sha256
(base32
- "10ncf2z474jnv7p5lv01ak2mk2hib3rj5rz1zr8v2v5pnciqbijl"))
+ "0x1ghxbkvqr910sp01sjf4hlfy4sdgn2jx2qf0dsi697bzq1f3mr"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -131,9 +132,7 @@ (define-public bullet
'("Gwen" "clsocket" "enet" "glad" "imgui"
"lua-5.2.3" "midi" "minizip" "openvr"
"optionalX11" "serial" "zlib")))
- ;; These need files from ThirdPartyLibs.
- (substitute* "Extras/CMakeLists.txt"
- (("BulletRobotics") ""))
+
;; Tests fail on linking, cannot find -lBussIK.
(substitute* "test/CMakeLists.txt"
((" InverseDynamics")
@@ -146,6 +145,13 @@ (define-public bullet
"-DBUILD_CPU_DEMOS=OFF"
"-DBUILD_OPENGL3_DEMOS=OFF"
"-DBUILD_BULLET2_DEMOS=OFF"
+
+ ;; Extras/BulletRoboticsGUI needs
files from ThirdPartyLibs
+ "-DBUILD_BULLET_ROBOTICS_GUI_EXTRA=OFF"
+
+ ;; Extras/BulletRobotics needs files
from ThirdPartyLibs
+ "-DBUILD_BULLET_ROBOTICS_EXTRA=OFF"
+
(string-append "-DCMAKE_CXX_FLAGS=-fPIC "
(or (getenv "CXXFLAGS") "")))
#:phases
--
2.34.0
Nicolas Goaziou wrote 3 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 52215@debbugs.gnu.org)
87wnkoxr88.fsf@nicolasgoaziou.fr
Hello,

Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> * gnu/packages/game-development.scm (bullet): Update to 3.17

Nitpick: you need to add periods at the end of the two lines in the
commit message.

But more importantly, I cannot apply your patch cleany on top of master
branch. Could you try rebasing your change and send the patch again?

Thanks!

Regards,
--
Nicolas Goaziou
Andy Tai wrote 3 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 52215@debbugs.gnu.org)
CAJsg1E_RjWDeZCDV8cesk22tr5gL2tKmFpd4JdUvgndi5=_B9Q@mail.gmail.com
OK, will do the rebase and re-send

On Wed, Dec 1, 2021 at 7:46 AM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (21 lines)
>
> Hello,
>
> Andy Tai <atai@atai.org> writes:
>
> > * gnu/packages/game-development.scm (bullet): Update to 3.17
>
> Nitpick: you need to add periods at the end of the two lines in the
> commit message.
>
> But more importantly, I cannot apply your patch cleany on top of master
> branch. Could you try rebasing your change and send the patch again?
>
> Thanks!
>
> Regards,
> --
> Nicolas Goaziou



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2021 民國110年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Andy Tai wrote 3 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 52215@debbugs.gnu.org)
CAJsg1E-CBU2NSvpOMxsSU71iiCXgJp5rOTUd8ePic5sDpzThrA@mail.gmail.com
rebased on top of master tip
From 5d4f4b200596e75ef3e59476d3f3f96f9cbbf72b Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Tue, 30 Nov 2021 21:18:09 -0800
Subject: [PATCH] gnu: bullet: Update to 3.17.
To: guix-patches@gnu.org

* gnu/packages/game-development.scm (bullet): Update to 3.17.
---
gnu/packages/game-development.scm | 16 +++++++++++-----
1 file changed, 11 insertions(+), 5 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 55bbad30e6..1b802d662f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,7 +113,7 @@ (define-module (gnu packages game-development)
(define-public bullet
(package
(name "bullet")
- (version "2.89")
+ (version "3.17")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -121,7 +122,7 @@ (define-public bullet
(file-name (git-file-name name version))
(sha256
(base32
- "10ncf2z474jnv7p5lv01ak2mk2hib3rj5rz1zr8v2v5pnciqbijl"))
+ "0x1ghxbkvqr910sp01sjf4hlfy4sdgn2jx2qf0dsi697bzq1f3mr"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -131,9 +132,7 @@ (define-public bullet
'("Gwen" "clsocket" "enet" "glad" "imgui"
"lua-5.2.3" "midi" "minizip" "openvr"
"optionalX11" "serial" "zlib")))
- ;; These need files from ThirdPartyLibs.
- (substitute* "Extras/CMakeLists.txt"
- (("BulletRobotics") ""))
+
;; Tests fail on linking, cannot find -lBussIK.
(substitute* "test/CMakeLists.txt"
((" InverseDynamics")
@@ -146,6 +145,13 @@ (define-public bullet
"-DBUILD_CPU_DEMOS=OFF"
"-DBUILD_OPENGL3_DEMOS=OFF"
"-DBUILD_BULLET2_DEMOS=OFF"
+
+ ;; Extras/BulletRoboticsGUI needs files from ThirdPartyLibs
+ "-DBUILD_BULLET_ROBOTICS_GUI_EXTRA=OFF"
+
+ ;; Extras/BulletRobotics needs files from ThirdPartyLibs
+ "-DBUILD_BULLET_ROBOTICS_EXTRA=OFF"
+
(string-append "-DCMAKE_CXX_FLAGS=-fPIC "
(or (getenv "CXXFLAGS") "")))
#:phases
--
2.34.0
Nicolas Goaziou wrote 3 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 52215-done@debbugs.gnu.org)
87y254vyct.fsf@nicolasgoaziou.fr
Hello,

Andy Tai <atai@atai.org> writes:

Toggle quote (2 lines)
> rebased on top of master tip

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
Leo Famulari wrote 3 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
YahEdyxcWLU0FSAC@jasmine.lan
On Wed, Dec 01, 2021 at 04:46:47PM +0100, Nicolas Goaziou wrote:
Toggle quote (3 lines)
> But more importantly, I cannot apply your patch cleany on top of master
> branch. Could you try rebasing your change and send the patch again?

When generating the patches with `git format-patch` or `git send-email`,
you can add the argument '--base=auto', which adds a note to the patch
about what commit the patch is based on.

That helps reviewers figure out how to apply the patch.

There's a note about this in the manual section Submitting Patches, but
it's not totally clear. I'll think about improving it.
zimoun wrote 3 years ago
(name . Leo Famulari)(address . leo@famulari.name)
CAJ3okZ0v+3iMrZJz1Rw=XgrU48sCRSJJ4SZw_cC=DUf_Gky8Vg@mail.gmail.com
Hi Leo,

On Thu, 2 Dec 2021 at 04:59, Leo Famulari <leo@famulari.name> wrote:

Toggle quote (4 lines)
> When generating the patches with `git format-patch` or `git send-email`,
> you can add the argument '--base=auto', which adds a note to the patch
> about what commit the patch is based on.

The argument 'auto' often breaks for me. I mean, I am not sure the
manual should have:

We recommend to use the command 'git format-patch --base=auto'
to include the commit where your patch applies.

but 'auto' should only be an advice or a recommendation as suggested
parameter for the otpion '--base'. IMHO.


Toggle quote (3 lines)
> There's a note about this in the manual section Submitting Patches, but
> it's not totally clear. I'll think about improving it.

Cool! :-)

Thanks,
Cheers,
Leo Famulari wrote 3 years ago
(name . zimoun)(address . zimon.toutoune@gmail.com)
YakfP5V0r23xQ9Om@jasmine.lan
On Thu, Dec 02, 2021 at 09:40:12AM +0100, zimoun wrote:
Toggle quote (9 lines)
> The argument 'auto' often breaks for me. I mean, I am not sure the
> manual should have:
>
> We recommend to use the command 'git format-patch --base=auto'
> to include the commit where your patch applies.
>
> but 'auto' should only be an advice or a recommendation as suggested
> parameter for the otpion '--base'. IMHO.

Okay, I took your advice and pushed my change to the manual as
f697fc267c317e98e4bba8009452b9d64e76b30a

I hope it helps!
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52215@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52215
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help