[PATCH 1/5] gnu: python-daemon: Update to 2.3.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Attila Lendvai
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 30 Nov 2021 21:37
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211130203722.14545-1-attila@lendvai.name
---

this patchset updates trezor support to current latest. it eliminates
the argv[0] patch that was introduced in https://issues.guix.gnu.org/50751
because upstream stopped using argv[0].

issue 50751 just got pushed recently, sorry for the unfortunate timing.
i was just about to send the new set of patches, but here they are.

gnu/packages/python-xyz.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ffd39860d8..2f95f272c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4103,14 +4103,14 @@ (define-public python2-joblib
(define-public python-daemon
(package
(name "python-daemon")
- (version "2.2.3")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-daemon" version))
(sha256
(base32
- "09fcjdjzk9ywmpnrj62iyxqgcygzdafsz41qlrk2dknzbagcmzmg"))))
+ "1bxfn2bq56sd4w0nm9mqy8y0905m7fc8vmhnjxlrf49vcbqr7adx"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4125,9 +4125,11 @@ (define-public python-daemon
(propagated-inputs
`(("python-lockfile" ,python-lockfile)))
(native-inputs
- `(("python-unittest2" ,python-unittest2)
+ `(("python-coverage" ,python-coverage)
+ ("python-unittest2" ,python-unittest2)
("python-testtools" ,python-testtools)
("python-testscenarios" ,python-testscenarios)
+ ("python-twine" ,python-twine)
("python-mock" ,python-mock)
("python-docutils" ,python-docutils)))
(home-page "https://pagure.io/python-daemon/")
--
2.33.0
A
A
Attila Lendvai wrote on 30 Nov 2021 21:44
[PATCH 2/5] gnu: python-trezor-agent: Update to 0.14.4.
(address . 52207@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211130204432.16295-2-attila@lendvai.name
* gnu/packages/patches/python-trezor-agent-fix-argv0.patch: Deleted.
---
gnu/local.mk | 1 -
gnu/packages/finance.scm | 8 +++---
.../python-trezor-agent-fix-argv0.patch | 27 -------------------
3 files changed, 4 insertions(+), 32 deletions(-)
delete mode 100644 gnu/packages/patches/python-trezor-agent-fix-argv0.patch

Toggle diff (80 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index a5c0486c94..b26907a211 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1681,7 +1681,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pytorch-system-libraries.patch \
%D%/packages/patches/python-robotframework-source-date-epoch.patch \
%D%/packages/patches/python-seaborn-kde-test.patch \
- %D%/packages/patches/python-trezor-agent-fix-argv0.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 60ed9fc4e3..91fde909ec 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -837,7 +837,7 @@ (define-public python-trezor-agent
;; the toplevel app called trezor-agent.
(package
(name "python-trezor-agent")
- (version "0.14.2")
+ (version "0.14.4")
(source
(origin
(method git-fetch)
@@ -846,8 +846,7 @@ (define-public python-trezor-agent
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0nl44ldfw9s2v3p7g5bldfw3ds2hz9r28j42bpnp8bj0v5na3ivk"))
- (patches (search-patches "python-trezor-agent-fix-argv0.patch"))))
+ (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -866,7 +865,8 @@ (define-public python-trezor-agent
(add-installed-pythonpath inputs outputs)
(invoke "py.test"))))))
(propagated-inputs
- `(("python-configargparse" ,python-configargparse)
+ `(("python-pynacl" ,python-pynacl)
+ ("python-configargparse" ,python-configargparse)
("python-daemon" ,python-daemon)
("python-docutils" ,python-docutils)
("python-ecdsa" ,python-ecdsa)
diff --git a/gnu/packages/patches/python-trezor-agent-fix-argv0.patch b/gnu/packages/patches/python-trezor-agent-fix-argv0.patch
deleted file mode 100644
index 9462067cd5..0000000000
--- a/gnu/packages/patches/python-trezor-agent-fix-argv0.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/libagent/gpg/__init__.py b/libagent/gpg/__init__.py
-index 3711bc8..67085de 100644
---- a/libagent/gpg/__init__.py
-+++ b/libagent/gpg/__init__.py
-@@ -122,15 +122,19 @@ def run_init(device_type, args):
- verify_gpg_version()
-
- # Prepare new GPG home directory for hardware-based identity
-- device_name = os.path.basename(sys.argv[0]).rsplit('-', 1)[0]
-- log.info('device name: %s', device_name)
-+ exe_name = os.path.basename(sys.argv[0])
-+ # drop the Guix wrapper's dot prefix from the name
-+ if exe_name[0] == '.' and exe_name.endswith('-real'):
-+ exe_name = exe_name[1:-5:]
-+ device_name = exe_name.rsplit('-', 1)[0]
-+ log.info('exe name: %s, device name: %s', exe_name, device_name)
- homedir = args.homedir
- if not homedir:
- homedir = os.path.expanduser('~/.gnupg/{}'.format(device_name))
-
- log.info('GPG home directory: %s', homedir)
-
-- if os.path.exists(homedir):
-+ if os.path.exists(homedir) and not args.subkey:
- log.error('GPG home directory %s exists, '
- 'remove it manually if required', homedir)
- sys.exit(1)
--
2.33.0
A
A
Attila Lendvai wrote on 30 Nov 2021 21:44
[PATCH 3/5] gnu: python-mnemonic: Update to 0.20.
(address . 52207@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211130204432.16295-3-attila@lendvai.name
---
gnu/packages/finance.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 91fde909ec..b468229849 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -918,13 +918,13 @@ (define-public trezor-gpg-pinentry-tk
(define-public python-mnemonic
(package
(name "python-mnemonic")
- (version "0.19")
+ (version "0.20")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mnemonic" version))
(sha256
- (base32 "0cd9prmdj8wzdmc7lxbf9lz0xrlkvak5ignag406mmfbn81fndsf"))))
+ (base32 "1xi5qvj2rvi5almf9c89rl7hz1z4ms04d53pg818i4vpkmivavvw"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pbkdf2" ,python-pbkdf2)))
--
2.33.0
A
A
Attila Lendvai wrote on 30 Nov 2021 21:44
[PATCH 4/5] gnu: python-trezor: Update to 0.12.4.
(address . 52207@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211130204432.16295-4-attila@lendvai.name
---
gnu/packages/finance.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index b468229849..9b98eafcd4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -992,7 +992,7 @@ (define-public python-btchip-python
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.12.3")
+ (version "0.12.4")
(source
(origin
(method git-fetch)
@@ -1001,7 +1001,7 @@ (define-public python-trezor
(commit (string-append "python/v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wdm1y5zli6w09zbpjqc6rbcs1b4hjq007mbh7xdr17prbnqprac"))
+ (base32 "1k0zk94jnkhr4iyngjfhfvff5mibx265q81v8jhvhd3m4clzgc45"))
(modules
'((guix build utils)
(srfi srfi-26)
@@ -1019,7 +1019,8 @@ (define-public python-trezor
(string-append "./" file-name)))
(scandir "./python/"
(negate (cut member <> '("." "..") string=))))
- (delete-file-recursively "./python")))))
+ (delete-file-recursively "./python")
+ #t))))
(build-system python-build-system)
(propagated-inputs
`(("python-attrs" ,python-attrs)
--
2.33.0
A
A
Attila Lendvai wrote on 30 Nov 2021 21:44
[PATCH 5/5] gnu: trezor-agent: Update to 0.11.0-1, aka git tag v0.14.4.
(address . 52207@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211130204432.16295-5-attila@lendvai.name
---
gnu/packages/finance.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9b98eafcd4..68549520c2 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1103,7 +1103,7 @@ (define-public ledger-agent
(define-public trezor-agent
(package
(name "trezor-agent")
- (version "0.11.0")
+ (version "0.11.0-1")
(source
(origin
(method git-fetch)
@@ -1114,9 +1114,10 @@ (define-public trezor-agent
;; different versions. The git tag seems to track libagent,
;; i.e. python-trezor-agent in the Guix namespace.
;; See e.g. ./agents/trezor/setup.py
- (commit "v0.14.2")))
+ (commit "v0.14.4")))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0nl44ldfw9s2v3p7g5bldfw3ds2hz9r28j42bpnp8bj0v5na3ivk"))
+ (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))
(modules
'((guix build utils)
(ice-9 ftw)
@@ -1135,7 +1136,8 @@ (define-public trezor-agent
(string-append "./" file-name)))
(scandir "./agents/trezor/"
(negate (cut member <> '("." "..") string=))))
- (delete-file-recursively "./agents")))))
+ (delete-file-recursively "./agents")
+ #t))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1152,14 +1154,14 @@ (define-public trezor-agent
(delete-file (string-append out "/bin/.trezor_agent.py-real"))
;; Overwrite the wrapped one with the real thing.
(install-file "./trezor_agent.py"
- (string-append out "/bin"))
- #t))))))
+ (string-append out "/bin")))
+ #t)))))
(build-system python-build-system)
(inputs
`(("python-trezor" ,python-trezor)
("python-trezor-agent" ,python-trezor-agent)))
(native-inputs
- `(("python-attrs" ,python-attrs)))
+ `(("python-attrs" ,python-attrs))) ; for the tests
(home-page "https://github.com/romanz/trezor-agent")
(synopsis "Using Trezor as hardware SSH/GPG agent")
(description "This package allows using Trezor as a hardware SSH/GPG
--
2.33.0
A
A
Attila Lendvai wrote on 1 Dec 2021 16:47
[PATCH 1/2] gnu: python-daemon: Update to 2.3.0.
(address . 52207@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211201154707.7865-1-attila@lendvai.name
---

as requested, resending the patchset in only two commits (rationale:
the packages are inter-dependent, and splitting the commit means that
the commits would leave the repo in a broken state; thinking of
git bisect, etc).

gnu/packages/python-xyz.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ffd39860d8..2f95f272c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4103,14 +4103,14 @@ (define-public python2-joblib
(define-public python-daemon
(package
(name "python-daemon")
- (version "2.2.3")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-daemon" version))
(sha256
(base32
- "09fcjdjzk9ywmpnrj62iyxqgcygzdafsz41qlrk2dknzbagcmzmg"))))
+ "1bxfn2bq56sd4w0nm9mqy8y0905m7fc8vmhnjxlrf49vcbqr7adx"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4125,9 +4125,11 @@ (define-public python-daemon
(propagated-inputs
`(("python-lockfile" ,python-lockfile)))
(native-inputs
- `(("python-unittest2" ,python-unittest2)
+ `(("python-coverage" ,python-coverage)
+ ("python-unittest2" ,python-unittest2)
("python-testtools" ,python-testtools)
("python-testscenarios" ,python-testscenarios)
+ ("python-twine" ,python-twine)
("python-mock" ,python-mock)
("python-docutils" ,python-docutils)))
(home-page "https://pagure.io/python-daemon/")
--
2.33.0
A
A
Attila Lendvai wrote on 1 Dec 2021 16:47
[PATCH 2/2] gnu: Update Trezor support.
(address . 52207@debbugs.gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20211201154707.7865-2-attila@lendvai.name
gnu: python-trezor-agent: Update to 0.14.4.
gnu: python-mnemonic: Update to 0.20.
gnu: python-trezor: Update to 0.12.4.
gnu: trezor-agent: Update to 0.11.0-1, aka git tag v0.14.4.

* gnu/packages/patches/python-trezor-agent-fix-argv0.patch: Deleted.
---
gnu/local.mk | 1 -
gnu/packages/finance.scm | 35 ++++++++++---------
.../python-trezor-agent-fix-argv0.patch | 27 --------------
3 files changed, 19 insertions(+), 44 deletions(-)
delete mode 100644 gnu/packages/patches/python-trezor-agent-fix-argv0.patch

Toggle diff (174 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index a5c0486c94..b26907a211 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1681,7 +1681,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-pytorch-system-libraries.patch \
%D%/packages/patches/python-robotframework-source-date-epoch.patch \
%D%/packages/patches/python-seaborn-kde-test.patch \
- %D%/packages/patches/python-trezor-agent-fix-argv0.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 60ed9fc4e3..68549520c2 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -837,7 +837,7 @@ (define-public python-trezor-agent
;; the toplevel app called trezor-agent.
(package
(name "python-trezor-agent")
- (version "0.14.2")
+ (version "0.14.4")
(source
(origin
(method git-fetch)
@@ -846,8 +846,7 @@ (define-public python-trezor-agent
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0nl44ldfw9s2v3p7g5bldfw3ds2hz9r28j42bpnp8bj0v5na3ivk"))
- (patches (search-patches "python-trezor-agent-fix-argv0.patch"))))
+ (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -866,7 +865,8 @@ (define-public python-trezor-agent
(add-installed-pythonpath inputs outputs)
(invoke "py.test"))))))
(propagated-inputs
- `(("python-configargparse" ,python-configargparse)
+ `(("python-pynacl" ,python-pynacl)
+ ("python-configargparse" ,python-configargparse)
("python-daemon" ,python-daemon)
("python-docutils" ,python-docutils)
("python-ecdsa" ,python-ecdsa)
@@ -918,13 +918,13 @@ (define-public trezor-gpg-pinentry-tk
(define-public python-mnemonic
(package
(name "python-mnemonic")
- (version "0.19")
+ (version "0.20")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mnemonic" version))
(sha256
- (base32 "0cd9prmdj8wzdmc7lxbf9lz0xrlkvak5ignag406mmfbn81fndsf"))))
+ (base32 "1xi5qvj2rvi5almf9c89rl7hz1z4ms04d53pg818i4vpkmivavvw"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pbkdf2" ,python-pbkdf2)))
@@ -992,7 +992,7 @@ (define-public python-btchip-python
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.12.3")
+ (version "0.12.4")
(source
(origin
(method git-fetch)
@@ -1001,7 +1001,7 @@ (define-public python-trezor
(commit (string-append "python/v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wdm1y5zli6w09zbpjqc6rbcs1b4hjq007mbh7xdr17prbnqprac"))
+ (base32 "1k0zk94jnkhr4iyngjfhfvff5mibx265q81v8jhvhd3m4clzgc45"))
(modules
'((guix build utils)
(srfi srfi-26)
@@ -1019,7 +1019,8 @@ (define-public python-trezor
(string-append "./" file-name)))
(scandir "./python/"
(negate (cut member <> '("." "..") string=))))
- (delete-file-recursively "./python")))))
+ (delete-file-recursively "./python")
+ #t))))
(build-system python-build-system)
(propagated-inputs
`(("python-attrs" ,python-attrs)
@@ -1102,7 +1103,7 @@ (define-public ledger-agent
(define-public trezor-agent
(package
(name "trezor-agent")
- (version "0.11.0")
+ (version "0.11.0-1")
(source
(origin
(method git-fetch)
@@ -1113,9 +1114,10 @@ (define-public trezor-agent
;; different versions. The git tag seems to track libagent,
;; i.e. python-trezor-agent in the Guix namespace.
;; See e.g. ./agents/trezor/setup.py
- (commit "v0.14.2")))
+ (commit "v0.14.4")))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0nl44ldfw9s2v3p7g5bldfw3ds2hz9r28j42bpnp8bj0v5na3ivk"))
+ (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))
(modules
'((guix build utils)
(ice-9 ftw)
@@ -1134,7 +1136,8 @@ (define-public trezor-agent
(string-append "./" file-name)))
(scandir "./agents/trezor/"
(negate (cut member <> '("." "..") string=))))
- (delete-file-recursively "./agents")))))
+ (delete-file-recursively "./agents")
+ #t))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1151,14 +1154,14 @@ (define-public trezor-agent
(delete-file (string-append out "/bin/.trezor_agent.py-real"))
;; Overwrite the wrapped one with the real thing.
(install-file "./trezor_agent.py"
- (string-append out "/bin"))
- #t))))))
+ (string-append out "/bin")))
+ #t)))))
(build-system python-build-system)
(inputs
`(("python-trezor" ,python-trezor)
("python-trezor-agent" ,python-trezor-agent)))
(native-inputs
- `(("python-attrs" ,python-attrs)))
+ `(("python-attrs" ,python-attrs))) ; for the tests
(home-page "https://github.com/romanz/trezor-agent")
(synopsis "Using Trezor as hardware SSH/GPG agent")
(description "This package allows using Trezor as a hardware SSH/GPG
diff --git a/gnu/packages/patches/python-trezor-agent-fix-argv0.patch b/gnu/packages/patches/python-trezor-agent-fix-argv0.patch
deleted file mode 100644
index 9462067cd5..0000000000
--- a/gnu/packages/patches/python-trezor-agent-fix-argv0.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/libagent/gpg/__init__.py b/libagent/gpg/__init__.py
-index 3711bc8..67085de 100644
---- a/libagent/gpg/__init__.py
-+++ b/libagent/gpg/__init__.py
-@@ -122,15 +122,19 @@ def run_init(device_type, args):
- verify_gpg_version()
-
- # Prepare new GPG home directory for hardware-based identity
-- device_name = os.path.basename(sys.argv[0]).rsplit('-', 1)[0]
-- log.info('device name: %s', device_name)
-+ exe_name = os.path.basename(sys.argv[0])
-+ # drop the Guix wrapper's dot prefix from the name
-+ if exe_name[0] == '.' and exe_name.endswith('-real'):
-+ exe_name = exe_name[1:-5:]
-+ device_name = exe_name.rsplit('-', 1)[0]
-+ log.info('exe name: %s, device name: %s', exe_name, device_name)
- homedir = args.homedir
- if not homedir:
- homedir = os.path.expanduser('~/.gnupg/{}'.format(device_name))
-
- log.info('GPG home directory: %s', homedir)
-
-- if os.path.exists(homedir):
-+ if os.path.exists(homedir) and not args.subkey:
- log.error('GPG home directory %s exists, '
- 'remove it manually if required', homedir)
- sys.exit(1)
--
2.33.0
N
N
Nicolas Goaziou wrote on 1 Dec 2021 18:40
Re: [bug#52207] [PATCH 1/2] gnu: python-daemon: Update to 2.3.0.
(name . Attila Lendvai)(address . attila@lendvai.name)(address . 52207-done@debbugs.gnu.org)
8735ncxlyu.fsf@nicolasgoaziou.fr
Hello,

Attila Lendvai <attila@lendvai.name> writes:

Toggle quote (5 lines)
> as requested, resending the patchset in only two commits (rationale:
> the packages are inter-dependent, and splitting the commit means that
> the commits would leave the repo in a broken state; thinking of
> git bisect, etc).

I applied the patches, thank you.

I tweaked the last one because it was based on a previous patch, not the
current state of the repository. I also fixed commit messages. You may
want to look at them.

Regards,
--
Nicolas Goaziou
Closed
?