[core-updates-frozen] [PATCH] gnu: ghc: Fix build on i686-linux.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 30 Nov 2021 12:14
[PATCH] gnu: ghc: Fix build on i686-linux.
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211130111427.3199918-1-zimon.toutoune@gmail.com
* gnu/packages/haskell.scm (ghc-8.10)[arguments]<#:phases>: Fix failing test.
---
gnu/packages/haskell.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 69a806e635..d3db023f08 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -711,12 +712,18 @@ (define-public ghc-8.10
(("\\]\\), " all)
(string-append all "expect_broken(0)], ")))))
;; TODO: Turn this into an undconditional patch on the next rebuild.
- ,@(if (string=? "i686-linux" (%current-system))
+ ,@(if (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))
'((add-after 'skip-more-tests 'skip-failing-tests-i686
(lambda _
(substitute* '("testsuite/tests/codeGen/should_compile/all.T")
(("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
- (string-append before "when(arch('i386'), skip)"))))))
+ (string-append before "when(arch('i386'), skip)")))
+ ;; Unexpected failures:
+ ;; quasiquotation/T14028.run T14028 [bad stderr] (dyn)
+ (substitute* '("testsuite/tests/quasiquotation/all.T")
+ (("unless\\(config.have_ext_interp, skip\\),")
+ "unless(config.have_ext_interp, skip), when(arch('i386'), skip),")))))
'())))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")

base-commit: f22dfba53032c59fb260173143abf0e4e9a4f1e1
--
2.33.1
Z
Z
zimoun wrote on 30 Nov 2021 12:22
control message for bug #52198
(address . control@debbugs.gnu.org)
87pmqhrip9.fsf@gmail.com
retitle 52198 [core-updates-frozen] [PATCH] gnu: ghc: Fix build on i686-linux.
quit
L
L
Lars-Dominik Braun wrote on 30 Nov 2021 16:57
Re: [bug#52198] [PATCH] gnu: ghc: Fix build on i686-linux.
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 52198-done@debbugs.gnu.org)
YaZJ4r740RT4uJiB@noor.fritz.box
Hi zimoun,

I locally built ghc@8.10 and this test indeed fails without/succeeds
with the patch. There’s also an issue over at the GHC tracker
about this failure, so I’m assuming it’s safe to skip:

I pushed this patch to core-updates-frozen as
afc4945d44aeb6750b980abddbfda66f6ccb6b18. Thank you!

Cheers,
Lars
Closed
Z
Z
zimoun wrote on 30 Nov 2021 17:02
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 52198-done@debbugs.gnu.org)
CAJ3okZ27gWrp-WebcyjY-jm7Ji6P8CCnF=D0fxWqpXVFxrnkqQ@mail.gmail.com
Hi Lars,

On Tue, 30 Nov 2021 at 16:57, Lars-Dominik Braun <lars@6xq.net> wrote:

Toggle quote (5 lines)
> I locally built ghc@8.10 and this test indeed fails without/succeeds
> with the patch. There’s also an issue over at the GHC tracker
> about this failure, so I’m assuming it’s safe to skip:
> https://gitlab.haskell.org/ghc/ghc/-/issues/17300

I have compiled some ghc-* packages for i686 in order to check and
until now, everything is ok. Let the CI rebuild everything and then
fix case per case; hoping this failing test about 'quasiquotation'
would not lead to reveal breakage of leaves.


Toggle quote (3 lines)
> I pushed this patch to core-updates-frozen as
> afc4945d44aeb6750b980abddbfda66f6ccb6b18. Thank you!

Thanks.

Cheers,
simon
Closed
?