[PATCH] [core-updates-frozen] Fix gnome-builder.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 30 Nov 2021 00:19
(address . guix-patches@gnu.org)
87czmi7dov.fsf@planete-kraus.eu
Dear guix,

GNOME builder is not ready yet for libsoup 3, so I suggest that we add a
libsoup 2 variant for devhelp, and use libsoup 2 everywhere for
builder. What do you think?

Best regards,

Vivien
From 3d579f6a778f92db432b9de4065295cd510f712d Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Tue, 30 Nov 2021 00:03:07 +0100
Subject: [PATCH 1/2] gnu: devhelp: Add a libsoup 2 variant.

* gnu/packages/gnome.scm (devhelp-with-libsoup2): New variable.
---
gnu/packages/gnome.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8e0e750180..ccb99ca8ec 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5854,6 +5854,22 @@ (define-public devhelp
throughout GNOME for API documentation).")
(license license:gpl2+)))
+(define-public devhelp-with-libsoup2
+ (package/inherit devhelp
+ (arguments
+ (substitute-keyword-arguments (package-arguments devhelp)
+ ((#:phases phases '%standard-phases)
+ `(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))))))))
+ (inputs
+ `(("amtk" ,amtk)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("webkitgtk" ,webkitgtk-with-libsoup2)))))
+
(define-public cogl
(package
(name "cogl")
--
2.34.0
From 6c896768d191f1fbc129b2c5b1d7bcd8a88aa93c Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Tue, 30 Nov 2021 00:05:18 +0100
Subject: [PATCH 2/2] gnu: gnome-builder: Use libsoup 2.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/gnome.scm (gnome-builder) [phase 'patch-meson]: Don’t search
for webkit2gtk-4.1.
[inputs]: Replace devhelp with devhelp-with-libsoup2 and
webkit with webkit-with-libsoup2.
---
gnu/packages/gnome.scm | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ccb99ca8ec..5f99616571 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12486,10 +12486,7 @@ (define-public gnome-builder
(substitute* "src/libide/meson.build"
(("/usr/lib")
(string-append (assoc-ref inputs "python-pygobject")
- "/lib")))
- (substitute* "meson.build"
- (("webkit2gtk-4.0") "webkit2gtk-4.1"))
- #t))
+ "/lib")))))
(add-after 'configure 'fix-ninja
(lambda _
;; #43296: meson(?) incorrectly assumes we want to link
@@ -12505,7 +12502,7 @@ (define-public gnome-builder
(inputs
`(("cmark" ,cmark)
("clang" ,clang)
- ("devhelp" ,devhelp)
+ ("devhelp" ,devhelp-with-libsoup2)
("glade" ,glade3)
("gspell" ,gspell)
("gtk+" ,gtk+)
@@ -12521,7 +12518,7 @@ (define-public gnome-builder
("sysprof" ,sysprof)
("template-glib" ,template-glib)
("vte" ,vte)
- ("webkitgtk" ,webkitgtk)))
+ ("webkitgtk" ,webkitgtk-with-libsoup2)))
(propagated-inputs
`(("gtksourceview" ,gtksourceview))) ;needed for settings
(native-inputs
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCAAdFiEEq4yIHjMvkliPpwQnO7C8EjLYuCwFAmGlX/AACgkQO7C8EjLY
uCwSfwwAsCIY+rlOO/hru+CdzCboqQVUQDL1LNa+RPxFcvtQBrGGkPeKpAg1CaTQ
tZppS8nB6zDD4+MJngzDT+2rvQhhI2adf6GVPbkSB1wrjklSqsKq+bcKErbRmUs4
tUFIMFbbrkSTRdNQ3l2x2QrkNg5aKS4e3ojN7oQYYLBzhAmFoWqSF6m+/sYZN8gv
GGOtg+qYgWh+39gg2FCrVLW6Eu0Xk1rSG/zXoHboolSTX7YLUdE+SRTkPUtSNd6H
5dtlGaFzNqlj2QtasqieH/3fU43hBwl3KAUCsmJWhc+NGqloaImdYmqDPXTQA+Uq
fwOXrFOu6GsNmVek7ctCwqDOPauO1tMz3vmOL4fR9wy9EDUymPLTI45sRjxU66Fn
nMcB+i8HtArnSKFrF4iCBcHlP5XWqMZhOK6Z5aZNKMYxKKCpYEkYwvp3REkOWBwh
deBIvFmh7o3NW9UJw6Zc4OMPUrsqWICP+f1FI3+1roZartKQjU1nOjm2GMZUH3Re
C/fQ4vsf
=EvpA
-----END PGP SIGNATURE-----

M
M
Mathieu Othacehe wrote on 1 Dec 2021 10:09
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 52188-done@debbugs.gnu.org)
87sfvc4rps.fsf@gnu.org
Hello Vivien,

Toggle quote (4 lines)
> GNOME builder is not ready yet for libsoup 3, so I suggest that we add a
> libsoup 2 variant for devhelp, and use libsoup 2 everywhere for
> builder. What do you think?

Seems fair, pushed both patches to c-u-f. I noticed the following
warnings at Gnome-Builder start:

Toggle snippet (5 lines)
10:07:16.8272 ide-application-plugins[ 19073]: CRITICAL: Cannot enable Python 3 plugins: Typelib file for namespace 'GtkSource', version '4' not found
10:07:16.8319 libpeas[ 19073]: WARNING: The 'python3' plugin loader has not been enabled
10:07:16.8320 libpeas[ 19073]: WARNING: The 'python3' plugin loader has not been enabled

Something we would like to fix?

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52188@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52188
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch