[PATCH] Add kalgebra.

  • Open
  • quality assurance status badge
Details
5 participants
  • Leo Famulari
  • Ludovic Courtès
  • Maxim Cournoyer
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 28 Nov 2021 17:54
[PATCH core-updates-frozen 0/2] Add KAlgebra.
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211128165432.263822-1-monego@posteo.net
Vinicius Monego (2):
gnu: Add analitza.
gnu: Add kalgebra.

gnu/packages/kde.scm | 69 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)


base-commit: 612e38bd29a42409cd6030d745ead844509e8c6e
--
2.30.2
V
V
Vinicius Monego wrote on 28 Nov 2021 17:55
[PATCH core-updates-frozen 1/2] gnu: Add analitza.
(address . 52165@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211128165546.263952-1-monego@posteo.net
* gnu/packages/kde.scm (analitza): New variable.
---
gnu/packages/kde.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b5c2357cb4..94e46af99f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1054,6 +1054,35 @@ Python, PHP, and Perl.")
a variety of formats, including PDF, PostScript, DejaVu, and EPub.")
(license license:gpl2+)))
+(define-public analitza
+ (package
+ (name "analitza")
+ (version "21.08.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/education/analitza")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qqi3kk4lcf838w99ab4yxbiq6b70jbzm0b35rb189bzw38mxh79"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("eigen" ,eigen)
+ ("qtbase" ,qtbase-5)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://invent.kde.org/education/analitza")
+ (synopsis "Library to add mathematical features to a program")
+ (description "Analitza is a library to work with mathematical objects.
+It adds mathematical features to your program, such as symbolic computations
+and some numerical methods; for instance the library can parse mathematical
+expressions and let you evaluate and draw them.")
+ (license license:gpl2+)))
+
(define-public poxml
(package
(name "poxml")
--
2.30.2
V
V
Vinicius Monego wrote on 28 Nov 2021 17:55
[PATCH core-updates-frozen 2/2] gnu: Add kalgebra.
(address . 52165@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211128165546.263952-2-monego@posteo.net
* gnu/packages/kde.scm (kalgebra): New variable.
---
gnu/packages/kde.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 94e46af99f..2a78ed0b88 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -70,12 +70,14 @@
#:use-module (gnu packages llvm)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
@@ -1083,6 +1085,44 @@ and some numerical methods; for instance the library can parse mathematical
expressions and let you evaluate and draw them.")
(license license:gpl2+)))
+(define-public kalgebra
+ (package
+ (name "kalgebra")
+ (version "21.04.3") ; newer versions require ECM >= 5.83.0
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/education/kalgebra")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07vmw924pig35az4s35i9z5ypkzv4d29pplmgqwvz0ldwz3aq456"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("analitza" ,analitza)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdoctools" ,kdoctools)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("ncurses" ,ncurses)
+ ("qtbase" ,qtbase-5)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)
+ ("qtwebengine" ,qtwebengine)
+ ("qtwebchannel" ,qtwebchannel)
+ ("readline" ,readline)))
+ (home-page "https://edu.kde.org/kalgebra/")
+ (synopsis "Calculator and plotting tool")
+ (description "KAlgebra is a calculator that lets you plot different types
+of 2D and 3D functions and to calculate easy (and not so easy) calculations,
+such as addition, trigonometric functions or derivatives.")
+ (license license:gpl2+)))
+
(define-public poxml
(package
(name "poxml")
--
2.30.2
L
L
Leo Famulari wrote on 29 Nov 2021 03:55
Re: [bug#52165] [PATCH core-updates-frozen 0/2] Add KAlgebra.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 52165@debbugs.gnu.org)
YaRBNDtecZMlTyBa@jasmine.lan
On Sun, Nov 28, 2021 at 04:54:32PM +0000, Vinicius Monego wrote:
Toggle quote (4 lines)
> Vinicius Monego (2):
> gnu: Add analitza.
> gnu: Add kalgebra.

Thanks for the patches.

Will they work on the master branch or do they require something from
core-updates-frozen?
V
V
Vinicius Monego wrote on 29 Nov 2021 04:29
(name . Leo Famulari)(address . leo@famulari.name)(address . 52165@debbugs.gnu.org)
a5c669298cb2ca9ce42896b87d1e3fe25903f244.camel@posteo.net
Em dom, 2021-11-28 às 21:55 -0500, Leo Famulari escreveu:
Toggle quote (10 lines)
> On Sun, Nov 28, 2021 at 04:54:32PM +0000, Vinicius Monego wrote:
> > Vinicius Monego (2):
> >   gnu: Add analitza.
> >   gnu: Add kalgebra.
>
> Thanks for the patches.
>
> Will they work on the master branch or do they require something from
> core-updates-frozen?

They may work on the master branch but I only tested on core-updates-
frozen.
L
L
Leo Famulari wrote on 30 Nov 2021 19:03
(name . Vinicius Monego)(address . monego@posteo.net)(address . 52165@debbugs.gnu.org)
YaZnib+Ykw/ZlBZU@jasmine.lan
On Mon, Nov 29, 2021 at 03:29:30AM +0000, Vinicius Monego wrote:
Toggle quote (14 lines)
> Em dom, 2021-11-28 �s 21:55 -0500, Leo Famulari escreveu:
> > On Sun, Nov 28, 2021 at 04:54:32PM +0000, Vinicius Monego wrote:
> > > Vinicius Monego (2):
> > > � gnu: Add analitza.
> > > � gnu: Add kalgebra.
> >
> > Thanks for the patches.
> >
> > Will they work on the master branch or do they require something from
> > core-updates-frozen?
>
> They may work on the master branch but I only tested on core-updates-
> frozen.

The packages do build on the master branch. Unless they require
something that only exists on core-updates-frozen, we should introduce
new packages on the master branch.

I noticed that analitza doesn't keep a reference to eigen:

------
$ guix gc --references $(./pre-inst-env guix build --no-grafts analitza)
/gnu/store/01b4w3m6mp55y531kyi1g8shh722kwqm-gcc-7.5.0-lib
/gnu/store/a0dn3jlq6862mcngzyw0lkcks066pcam-qtsvg-5.15.2
/gnu/store/a2ngdffc2133m5a211f42pyhypcbr9qa-qtbase-5.15.2
/gnu/store/dk7l3sn0wchyddgl7r2ka80zzwzhfm02-qtdeclarative-5.15.2
/gnu/store/f98v0niqzjm0lfl3zpf7qi538j3kf76j-analitza-21.08.3
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31
------

Can you check if it is actually able to use the functionality provided
by eigen at run-time? Do we need to pass some flags to the linker or
something? Is eigen used only while building? Etc...

Similar question for kalgebra regarding kdoctools and ncurses. The built
package does not refer to these inputs.
L
L
Ludovic Courtès wrote on 5 Dec 2021 16:41
Re: bug#52165: [PATCH core-updates-frozen 0/2] Add KAlgebra.
(name . Leo Famulari)(address . leo@famulari.name)
87wnkjt5xd.fsf_-_@gnu.org
Hi,

Leo Famulari <leo@famulari.name> skribis:

Toggle quote (2 lines)
> I noticed that analitza doesn't keep a reference to eigen:

That’s expected because Eigen is a C++ “header-only” library: it doesn’t
provide a shared library.

HTH,
Ludo’.
L
L
Leo Famulari wrote on 6 Dec 2021 05:26
(name . Ludovic Courtès)(address . ludo@gnu.org)
Ya2RCkNow7nGskHD@jasmine.lan
On Sun, Dec 05, 2021 at 04:41:50PM +0100, Ludovic Courtès wrote:
Toggle quote (7 lines)
> Leo Famulari <leo@famulari.name> skribis:
>
> > I noticed that analitza doesn't keep a reference to eigen:
>
> That’s expected because Eigen is a C++ “header-only” library: it doesn’t
> provide a shared library.

Thanks for the clarification.

Toggle quote (3 lines)
> > Similar question for kalgebra regarding kdoctools and ncurses. The built
> > package does not refer to these inputs.

I'm guessing that kdoctools is used only while building. I submitted

So what do we think about ncurses?
L
L
Ludovic Courtès wrote on 6 Dec 2021 13:21
(name . Leo Famulari)(address . leo@famulari.name)
87v901oreg.fsf@gnu.org
Hi,

Leo Famulari <leo@famulari.name> skribis:

Toggle quote (3 lines)
>> > Similar question for kalgebra regarding kdoctools and ncurses. The built
>> > package does not refer to these inputs.

[...]

Toggle quote (2 lines)
> So what do we think about ncurses?

It’s likely that ncurses is not used if there’s no residual reference to it.

Ludo’.
M
M
Mathieu Othacehe wrote on 12 Dec 2021 20:05
(name . Vinicius Monego)(address . monego@posteo.net)(address . 52165@debbugs.gnu.org)
87y24pabk1.fsf_-_@gnu.org
Hello,

Toggle quote (2 lines)
> + (version "21.08.3")

The linter reports that the 21.12.0 revision is out there, for this
package as well as for the other one.

Thanks,

Mathieu
M
M
Maxim Cournoyer wrote on 20 Jan 21:45 +0100
control message for bug #52165
(address . control@debbugs.gnu.org)
875xznentq.fsf@gmail.com
retitle 52165 [PATCH] Add kalgebra.
quit
?