[PATCH] gnu: subversion: Add --enable-plaintext-password-storage flag

  • Open
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Philip Kaludercic
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Philip Kaludercic
Severity
normal
P
P
Philip Kaludercic wrote on 28 Nov 2021 16:41
(address . guix-patches@gnu.org)(name . Philip Kaludercic)(address . philipk@posteo.net)
20211128154110.25964-1-philipk@posteo.net
* version-control.scm (subversion): Enable plain text passwords while
compiling SVN, undoing the controversial move to disable them by the
maintainers. See also
---
gnu/packages/version-control.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 10487c6939..ff3dc61456 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1969,7 +1969,8 @@ (define-public subversion
(arguments
'(#:parallel-tests? #f ; TODO Seems to cause test failures on
; i686-linux
- #:configure-flags '("--enable-static=no")
+ #:configure-flags '("--enable-static=no"
+ "--enable-plaintext-password-storage")
#:phases
(modify-phases %standard-phases
(add-after 'configure 'patch-libtool-wrapper-ls
--
2.34.0
L
L
Leo Famulari wrote on 28 Nov 2021 23:08
(name . Philip Kaludercic)(address . philipk@posteo.net)(address . 52162@debbugs.gnu.org)
YaP90Y/GaCSnBIF0@jasmine.lan
On Sun, Nov 28, 2021 at 03:41:10PM +0000, Philip Kaludercic wrote:
Toggle quote (5 lines)
> * version-control.scm (subversion): Enable plain text passwords while
> compiling SVN, undoing the controversial move to disable them by the
> maintainers. See also
> https://lists.apache.org/thread/b6g2hx2m3s117wcmno08opl874ons3q8.

Thanks for the patch!

Toggle quote (4 lines)
> - #:configure-flags '("--enable-static=no")
> + #:configure-flags '("--enable-static=no"
> + "--enable-plaintext-password-storage")

In general, in Guix, we aim to distribute software as it was released by
upstream. We do make changes to fix bugs, but it's outside our normal
activity for us to change defaults from upstream.

This is partly a pragmatic choice (less work to maintain) and partly a
way in which we choose to be "good citizens" with respect to our role as
distributors. But also, because Guix makes it easier for users to
customize their packages compared to other systems like APT and RPM.

I would like to hear other peoples' opinions before we decide about this
patch.
R
R
Ricardo Wurmus wrote on 29 Nov 2021 09:15
[PATCH] gnu: subversion: Add --enable-plaintext-password-storage flag
(address . 52162@debbugs.gnu.org)
87lf17mkzj.fsf@elephly.net
I’ve read the discussion that ends with an email[1] by Nathan
Hartman expressing support for enabling the feature but disabling
it by default in configuration. Hence I think it would be
reasonable to wait for a new release addressing it. In the
meantime users can define their own package variant with this
configure flag added.

It doesn’t need to be changed in Guix itself, because this only
affects users of the package, not other packages that have
subversion as an input. So it’s enough to add a new leaf package.
As a compromise I think it would be acceptable to add a separate
subversion-plaintext (or whatever) package variant, which will be
superseded by the official subversion package as soon as a new
release is made.

[1]

--
Ricardo
P
P
Philip Kaludercic wrote on 23 Sep 2021 14:08
Re: bug#50297: 28.0.50; Aggregate project functions for project.el
(name . Dmitry Gutov)(address . dgutov@yandex.ru)(address . 50297-done@debbugs.gnu.org)
875yur7av5.fsf@posteo.net
Dmitry Gutov <dgutov@yandex.ru> writes:

Toggle quote (8 lines)
> On 23.09.2021 13:46, Philip Kaludercic wrote:
>> Sorry about that, forgot to byte-compile before preparing the
>> patch. This should fix the issues:
>
> Thanks. You can go ahead and install.
>
> Just add NEWS entries for the commands.

Done and pushed.

--
Philip Kaludercic
?