[PATCH 1/7] gnu: Add python-lsp-server.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
Merged with
J
[PATCH 1/7] gnu: python-parso: Update to 0.8.2.
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211128150855.31108-1-jgart@dismail.de
Hi Guixers,

Here is a patch set for updating the unmaintained python language server
that's in guix to use the new fork by the Spyder IDE team and community.

all best,

jgart

* gnu/packages/python-xyz.scm (python-parso): Update to 0.8.2.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ffd39860d8..de43be43b2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21320,13 +21320,13 @@ (define-public python-onetimepass
(define-public python-parso
(package
(name "python-parso")
- (version "0.7.1")
+ (version "0.8.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "parso" version))
(sha256
- (base32 "1f9fc99mjx0h2ad4mgsid728nnmw58hvnq3411g8ljlr9dr49fna"))))
+ (base32 "161k8771m7w60qakyvrwf9q62lvakmix7mpfylpy7713qs939f0j"))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(build-system python-build-system)
--
2.34.0
J
[PATCH 3/7] gnu: python-jedi: Update to 0.18.1.
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211128150855.31108-3-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.18.1.
[native-inputs]: Add python-django-2-2 and python-colorama.
---
gnu/packages/python-xyz.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b5ab2eaae..203af5865e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -141,6 +141,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages django)
#:use-module (gnu packages dbm)
#:use-module (gnu packages djvu)
#:use-module (gnu packages docker)
@@ -16249,13 +16250,13 @@ (define-public python2-prompt-toolkit-1
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.17.2")
+ (version "0.18.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
(sha256
- (base32 "080xyf97ifabdz7jp8clg00b8zv5g33fva1fb2xf80q6fndpvvc6"))))
+ (base32 "1as9v6kv49j11al2mzjh72dd5mxxnfcjv0z5dbmwi6aalqk7c4vl"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -16267,7 +16268,9 @@ (define-public python-jedi
(invoke "python" "-m" "pytest" "-vv"))
#t)))))
(native-inputs
- `(("python-pytest" ,python-pytest)
+ `(("python-colorama" ,python-colorama)
+ ("python-django" ,python-django-2.2)
+ ("python-pytest" ,python-pytest)
("python-docopt" ,python-docopt)))
(propagated-inputs
`(("python-parso" ,python-parso)))
--
2.34.0
J
[PATCH 5/7] gnu: python-lsp-jsonrpc: Add deprecated alias.
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211128150855.31108-5-jgart@dismail.de
Add deprecated alias for package removed in the parent commit.
* gnu/packages/python-xyz.scm (python-jsonrpc-server): New variable.
---
gnu/packages/python-xyz.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1383f9681d..942dae04f3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4894,6 +4894,9 @@ (define-public python-lsp-jsonrpc
"This package provides a JSON RPC 2.0 server library for Python.")
(license license:expat)))
+(define-public python-jsonrpc-server
+ (deprecated-package "python-jsonrpc-server" python-lsp-jsonrpc))
+
(define-public python-pydantic
(package
(name "python-pydantic")
--
2.34.0
J
[PATCH 2/7] gnu: python2-jedi: Remove package.
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211128150855.31108-2-jgart@dismail.de
* gnu/packages/python-xyz.scm (python2-jedi): Delete variable.
---
gnu/packages/python-xyz.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de43be43b2..5b5ab2eaae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16282,9 +16282,6 @@ (define-public python-jedi
well.")
(license license:expat)))
-(define-public python2-jedi
- (package-with-python2 python-jedi))
-
(define-public ptpython
(package
(name "ptpython")
--
2.34.0
J
[PATCH 7/7] gnu: python-language-server: Add deprecated alias.
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211128150855.31108-7-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-language-server): New variable.

Add deprecated alias for package removed in the parent commit.
---
gnu/packages/python-xyz.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4a0b811ed6..b7fff3cd89 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5028,6 +5028,9 @@ (define-public python-lsp-server
and integrated feature-set for programming Python effectively.")
(license license:expat)))
+(define-public python-language-server
+ (deprecated-package "python-language-server" python-lsp-server))
+
(define-public python-pathspec
(package
(name "python-pathspec")
--
2.34.0
J
[PATCH 6/7] gnu: Add python-lsp-server.
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211128150855.31108-6-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-language-server): Delete variable.
* gnu/packages/python-xyz.scm (python-lsp-server): New variable.

Removes deprecated python-language-server package and adds maintained
fork.
---
gnu/packages/python-xyz.scm | 28 +++++++++++-----------------
1 file changed, 11 insertions(+), 17 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 942dae04f3..4a0b811ed6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4972,29 +4972,23 @@ (define-public python-pydocstyle
Server (PLS).")
(license license:expat)))
-(define-public python-language-server
+(define-public python-lsp-server
(package
- (name "python-language-server")
- (version "0.36.2")
+ (name "python-lsp-server")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "python-language-server" version))
+ (uri (pypi-uri "python-lsp-server" version))
(sha256
(base32
- "1c0pnk2aibfhfaanrs0a5gkabkvz81gj20z7r0152b7fcx5ci14r"))))
+ "15075a5irjxh55wcdf25hllz9c42byxc4770cmwgb480k1dm8scq"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'relax-deps
- (lambda _
- (substitute* "setup.py" (("pycodestyle>=2.6.0,<2.7.0")
- "pycodestyle"))
- (substitute* "setup.py" (("pyflakes>=2.2.0,<2.3.0") "pyflakes"))
- #t))
(add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp") #t))
+ (lambda _ (setenv "HOME" "/tmp")))
(replace 'check
(lambda _
;; Disable failing test.
@@ -5007,7 +5001,7 @@ (define-public python-language-server
("python-flake8" ,python-flake8)
("python-future" ,python-future)
("python-jedi" ,python-jedi)
- ("python-jsonrpc-server" ,python-jsonrpc-server)
+ ("python-lsp-jsonrpc" ,python-lsp-jsonrpc)
("python-pluggy" ,python-pluggy)
("python-pycodestyle" ,python-pycodestyle)
("python-pyflakes" ,python-pyflakes)
@@ -5028,10 +5022,10 @@ (define-public python-language-server
(home-page "https://github.com/palantir/python-language-server")
(synopsis "Python implementation of the Language Server Protocol")
(description
- "The Python Language Server (pyls) is an implementation of the Python 3
-language specification for the Language Server Protocol (LSP). This tool is
-used in text editing environments to provide a complete and integrated
-feature-set for programming Python effectively.")
+"The Python Language Server @command{pylsp} is an implementation of the
+Python 3 language specification for the Language Server Protocol (LSP).
+This tool is used in text editing environments to provide a complete
+and integrated feature-set for programming Python effectively.")
(license license:expat)))
(define-public python-pathspec
--
2.34.0
J
merge 52160 52161
(address . control@debbugs.gnu.org)
20211128231851.GB25074@gac.attlocal.net
merge 52160 52161
J
(no subject)
(address . control@debbugs.gnu.org)
20211129002905.GB5094@gac.attlocal.net
retitle 52160 [PATCH 1/7] gnu: Add python-lsp-server.
N
N
Nicolas Goaziou wrote on 1 Dec 2021 17:15
Re: [bug#52160] [PATCH 1/7] gnu: python-parso: Update to 0.8.2.
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87k0goxpvo.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> Here is a patch set for updating the unmaintained python language server
> that's in guix to use the new fork by the Spyder IDE team and
> community.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
J
J
jgart wrote on 2 Dec 2021 00:18
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
20211201181812.GB13619@gac.attlocal.net
On Wed, 01 Dec 2021 17:15:55 +0100 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (10 lines)
> Hello,
>
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
>
> > Here is a patch set for updating the unmaintained python language server
> > that's in guix to use the new fork by the Spyder IDE team and
> > community.
>
> Applied. Thank you.

Thank you Nicolas!

all best,

jgart
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52160@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52160
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch