[PATCH v2] Fix mistakes, and update cargo

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • (unmatched-parenthesis
Owner
unassigned
Submitted by
(unmatched-parenthesis
Severity
normal
Merged with
(
(
(unmatched-parenthesis wrote on 27 Nov 2021 23:48
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20211127224841.32146-1-paren@disroot.org
Please disregard the original patch. This one updates cargo along with rustc.

---
gnu/packages/crates-io.scm | 89 ++++++++++++++++++++++++++++++++++++++
gnu/packages/rust.scm | 11 ++++-
2 files changed, 99 insertions(+), 1 deletion(-)
mode change 100644 => 100755 gnu/packages/rust.scm

Toggle diff (134 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b8c4c7bd39..d8c457182c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8134,6 +8134,95 @@ (define-public rust-caps-0.3
("rust-error-chain" ,rust-error-chain-0.12)
("rust-libc" ,rust-libc-0.2))))))
+(define-public rust-cargo-0.57
+ (package
+ (name "rust-cargo")
+ (version "0.57.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cargo" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12ns9v4dd8vnvsaqgd897h2zc19w00i5ii3slda653zbhfzm6zna"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(;; The test suite is disabled as the internal 'cargo-test-macro' and
+ ;; 'cargo-test-support' crates are not included in the release.
+ #:tests? #f
+ #:cargo-inputs
+ (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-atty" ,rust-atty-0.2)
+ ("rust-bytesize" ,rust-bytesize-1)
+ ("rust-cargo-platform" ,rust-cargo-platform-0.1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-core-foundation" ,rust-core-foundation-0.9)
+ ("rust-crates-io" ,rust-crates-io-0.33)
+ ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
+ ("rust-crypto-hash" ,rust-crypto-hash-0.3)
+ ("rust-curl" ,rust-curl-0.4)
+ ("rust-curl-sys" ,rust-curl-sys-0.4)
+ ("rust-env-logger" ,rust-env-logger-0.8)
+ ("rust-filetime" ,rust-filetime-0.2)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-fwdansi" ,rust-fwdansi-1)
+ ("rust-git2" ,rust-git2-0.13)
+ ("rust-git2-curl" ,rust-git2-curl-0.14)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-hex" ,rust-hex-0.4)
+ ("rust-home" ,rust-home-0.5)
+ ("rust-humantime" ,rust-humantime-2)
+ ("rust-ignore" ,rust-ignore-0.4)
+ ("rust-im-rc" ,rust-im-rc-15)
+ ("rust-jobserver" ,rust-jobserver-0.1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-lazycell" ,rust-lazycell-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-libgit2-sys" ,rust-libgit2-sys-0.12)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-miow" ,rust-miow-0.3)
+ ("rust-num-cpus" ,rust-num-cpus-1)
+ ("rust-opener" ,rust-opener-0.4)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-pretty-env-logger" ,rust-pretty-env-logger-0.4)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rustc-workspace-hack" ,rust-rustc-workspace-hack-1)
+ ("rust-rustfix" ,rust-rustfix-0.5)
+ ("rust-same-file" ,rust-same-file-1)
+ ("rust-semver" ,rust-semver-0.10)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-ignored" ,rust-serde-ignored-0.1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-shell-escape" ,rust-shell-escape-0.1)
+ ("rust-strip-ansi-escapes" ,rust-strip-ansi-escapes-0.1)
+ ("rust-tar" ,rust-tar-0.4)
+ ("rust-tar" ,rust-tar-0.4)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-toml" ,rust-toml-0.5)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
+ ("rust-unicode-xid" ,rust-unicode-xid-0.2)
+ ("rust-url" ,rust-url-2)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl)
+ ("libssh2" ,libssh2)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (home-page "https://crates.io")
+ (synopsis "Package manager for Rust")
+ (description "Cargo, a package manager for Rust. This package provides
+the library crate of Cargo.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-cargo-0.53
(package
(name "rust-cargo")
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
old mode 100644
new mode 100755
index f7f05851f1..a1f3d757cd
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -769,8 +770,16 @@ (define rust-1.54
`("procps" ,procps)
(package-native-inputs base-rust))))))
+(define rust-1.55
+ (rust-bootstrapped-package
+ rust-1.54 "1.55.0" "07l28f7grdmi65naq71pbmvdd61hwcpi40ry7kp7dy7m233rldxj"))
+
+(define rust-1.56
+ (rust-bootstrapped-package
+ rust-1.55 "1.56.1" "04cmqx7nn63hzz7z27b2b0dj2qx18rck9ifvip43s6dampx8v2f3"))
+
;;; Note: Only the latest versions of Rust are supported and tested. The
;;; intermediate rusts are built for bootstrapping purposes and should not
;;; be relied upon. This is to ease maintenance and reduce the time
;;; required to build the full Rust bootstrap chain.
-(define-public rust rust-1.54)
+(define-public rust rust-1.56)
--
2.34.0
L
L
Ludovic Courtès wrote on 8 Dec 2021 22:11
control message for bug #52149
(address . control@debbugs.gnu.org)
87lf0uhkex.fsf@gnu.org
merge 52149 52153
quit
P
P
Parenthesis wrote on 22 Dec 2021 11:41
This patch will not work
(address . 52153@debbugs.gnu.org)
U0JI4R.RXZ7QAAZ1NJ73@disroot.org
I made a mistake when sending the second version of the patch.
https://issues.guix.gnu.org/52149 is the correct patch. (v2 didn't
include certain dependency updates necessary for Cargo 0.56)
Attachment: file
(
Fwd: close obsolete patches
(address . control@debbugs.gnu.org)
CMTTMY8LGUOF.3F1ZPF6MVBQBX@guix-aspire
close 52153 53444 53472 54310 54357 56908
thanks

-- (
?