[PATCH] gnu: Add skippy-xd

  • Open
  • quality assurance status badge
Details
2 participants
  • Jaft
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Jaft
Severity
normal
J
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
DM6PR19MB2460C51947475A9F983712F499629@DM6PR19MB2460.namprd19.prod.outlook.com
* gnu/packages/xdisorg.scm (skippy-xd): Add skippy-xd
---
gnu/packages/xdisorg.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
Toggle diff (60 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bf82db5823..e5b7950ab1 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -50,6 +50,7 @@
 ;;; Copyright © 2021 Nikita Domnitskii <nikita@domnitskii.me>
 ;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3095,3 +3096,47 @@ (define-public wlsunset
 that support @samp{wlr-gamma-control-unstable-v1}.  It is also known as a blue
 light filter or night light.")
     (license license:expat)))
+
+(define-public skippy-xd
+  (let ((commit "397216ca67074c71314f5e9a6e3f1710ccabc29e")
+        (revision "0"))
+    (package
+      (name "skippy-xd")
+      (version (git-version "1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/richardgv/skippy-xd/")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256 (base32
+                         "0zcjacilmsv69rv85j6nfr6pxy8z36w1sjz0dbjg6s5m4kga1zl8"))
+                (modules '((guix build utils)))))
+      (build-system  gnu-build-system)
+      (arguments `(#:phases (modify-phases %standard-phases
+                              (delete 'configure)
+                              (delete 'check))
+                   #:make-flags (list "PREFIX=/"
+                                      (string-append "CC=" ,(cc-for-target))
+                                      (string-append "DESTDIR=" (assoc-ref
+                                                                  %outputs
+                                                                  "out")))))
+      (native-inputs `(("pkg-config" ,pkg-config)
+                       ("libx11" ,libx11)
+                       ("libxft" ,libxft)
+                       ("libxcomposite" ,libxcomposite)
+                       ("libxdamage" ,libxdamage)
+                       ("libxext" ,libxext)
+                       ("libxinerama" ,libxinerama)
+                       ("libjpeg-turbo" ,libjpeg-turbo)
+                       ("giflib" ,giflib)))
+      (home-page "https://github.com/richardgv/skippy-xd/")
+      (synopsis "Full-screen Exposé-style standalone task switcher for X11")
+      (description "Skippy-XD is a fullscreen composited task-switcher for X11.
+
+Skippy-XD is a program that provides Exposé-like features such as found on the
+MacOS X operating system.  It is a standalone application for providing a window
+picker with live previews (including live video) on Linux desktops that run an X
+server with compositing support.  Thus, it is not part of the window manager and
+the compositing is not being used all the time.")
+      (license license:gpl2))))
N
N
Nicolas Goaziou wrote on 15 Jan 2022 22:15
(name . Jaft)(address . jaft.r@outlook.com)(address . 52114@debbugs.gnu.org)
87wnj01z0i.fsf@nicolasgoaziou.fr
Hello,

Jaft <jaft.r@outlook.com> writes:

Toggle quote (2 lines)
> * gnu/packages/xdisorg.scm (skippy-xd): Add skippy-xd

Thank you for the patch.

I fixed a few issues with it (incorrect license, check phase deleted
instead of using #:tests? keyword, useless modules field, incorrect
version string, inputs as native-inputs, unordered inputs) and moved it
to new package style. I am attaching the result as a new patch.

Could you, or someone else, tell me if it's working properly. I couldn't
make it work for some reason.

Regards,
--
Nicolas Goaziou
From 8fb2644d64589e776c8142451ebf2dda164dbae0 Mon Sep 17 00:00:00 2001
Message-Id: <8fb2644d64589e776c8142451ebf2dda164dbae0.1642281003.git.mail@nicolasgoaziou.fr>
From: Jaft <jaft.r@outlook.com>
Date: Sat, 15 Jan 2022 22:09:25 +0100
Subject: [PATCH] gnu: Add skippy-xd.

* gnu/packages/xdisorg.scm (skippy-xd): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
---
gnu/packages/xdisorg.scm | 60 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (87 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 74a6ea38b8..828089b7c0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,6 +78,7 @@ (define-module (gnu packages xdisorg)
#:use-module (guix build-system python)
#:use-module (guix build-system scons)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix hg-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -2920,6 +2922,64 @@ (define-public jumpapp
(home-page "https://github.com/mkropat/jumpapp")
(license license:expat)))
+(define-public skippy-xd
+ ;; XXX: Upstream made no release so far. Using latest commit.
+ (let ((commit "397216ca67074c71314f5e9a6e3f1710ccabc29e")
+ (revision "1"))
+ (package
+ (name "skippy-xd")
+ ;; Version is extracted from Debian's "control" file.
+ (version (git-version "0.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/richardgv/skippy-xd")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zcjacilmsv69rv85j6nfr6pxy8z36w1sjz0dbjg6s5m4kga1zl8"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-after 'unpack 'set-version
+ ;; SKIPPYXD_VERSION is a git commit hash. Display our own, more
+ ;; informative (?) version string instead.
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\{SKIPPYXD_VERSION\\}") #$version)))))
+ #:make-flags
+ ;; XXX: Setting both PREFIX and DESTDIR is needed to work around
+ ;; a Makefile problem when moving files to "%output/etc/xdg".
+ #~(list (string-append "PREFIX=/")
+ (string-append "DESTDIR=" #$output)
+ #$(string-append "CC=" (cc-for-target)))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list giflib
+ libjpeg-turbo
+ libx11
+ libxcomposite
+ libxdamage
+ libxext
+ libxft
+ libxinerama))
+ (home-page "https://github.com/richardgv/skippy-xd/")
+ (synopsis "Full-screen Exposé-style standalone task switcher for X11")
+ (description "Skippy-XD is a program that provides Exposé-like features
+such as found on the MacOS X operating system. It is a standalone application
+for providing a window picker with live previews (including live video) on
+Linux desktops that run an X server with compositing support. Thus, it is not
+part of the window manager and the compositing is not being used all the
+time.")
+ (license license:gpl2+))))
+
(define-public xkbset
(package
(name "xkbset")
--
2.34.0
W
W
Wamm K. D wrote on 9 Mar 2022 23:48
[PATCH v2] * gnu/packages/xdisorg.scm (skippy-xd): New variable.
(address . 52114@debbugs.gnu.org)
DM5PR04MB37724DA0A278290ECB0BD325990A9@DM5PR04MB3772.namprd04.prod.outlook.com
---
Gah; I'm so sorry about the lapse in time, Nicolas. I completely missed that
there was any response. I tried it out and it runs pretty nicely, I'd say.
There's been quite a few changes and just applying the patch failed for me so
I'm just sending a new one, built after the lastest commits, in case this helps,
any. Thanks a ton!
gnu/packages/xdisorg.scm | 59 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6dc40f0910..b9e26f0511 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;;
@@ -2973,6 +2974,64 @@ (define-public jumpapp
(home-page "https://github.com/mkropat/jumpapp")
(license license:expat)))
+(define-public skippy-xd
+ ;; XXX: Upstream made no release so far. Using latest commit.
+ (let ((commit "397216ca67074c71314f5e9a6e3f1710ccabc29e")
+ (revision "1"))
+ (package
+ (name "skippy-xd")
+ ;; Version is extracted from Debian's "control" file.
+ (version (git-version "0.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/richardgv/skippy-xd")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zcjacilmsv69rv85j6nfr6pxy8z36w1sjz0dbjg6s5m4kga1zl8"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (add-after 'unpack 'set-version
+ ;; SKIPPYXD_VERSION is a git commit hash. Display our own, more
+ ;; informative (?) version string instead.
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\{SKIPPYXD_VERSION\\}") #$version)))))
+ #:make-flags
+ ;; XXX: Setting both PREFIX and DESTDIR is needed to work around
+ ;; a Makefile problem when moving files to "%output/etc/xdg".
+ #~(list (string-append "PREFIX=/")
+ (string-append "DESTDIR=" #$output)
+ #$(string-append "CC=" (cc-for-target)))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list giflib
+ libjpeg-turbo
+ libx11
+ libxcomposite
+ libxdamage
+ libxext
+ libxft
+ libxinerama))
+ (home-page "https://github.com/richardgv/skippy-xd/")
+ (synopsis "Full-screen Exposé-style standalone task switcher for X11")
+ (description "Skippy-XD is a program that provides Exposé-like features
+such as found on the MacOS X operating system. It is a standalone application
+for providing a window picker with live previews (including live video) on
+Linux desktops that run an X server with compositing support. Thus, it is not
+part of the window manager and the compositing is not being used all the
+time.")
+ (license license:gpl2+))))
+
(define-public xkbset
(package
(name "xkbset")
--
2.34.0
?