[patch] add gst-plugins-base-gl (with opengl support)

  • Open
  • quality assurance status badge
Details
2 participants
  • Dr. Arne Babenhauserheide
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Dr. Arne Babenhauserheide
Severity
normal
D
D
Dr. Arne Babenhauserheide wrote on 24 Nov 2021 02:00
(address . bug-guix@gnu.org)
87tug2e598.fsf@web.de
Hi,

The attached patch adds a derivative package of gst-plugins-base that
includes gl support and has mesa as input.

I needed that for an application.

Best wishes,
Arne
From a1435b89c6ff01c1644bea671628678eebf3dfc2 Mon Sep 17 00:00:00 2001
From: Arne Babenhauserheide <arne_bab@web.de>
Date: Wed, 24 Nov 2021 01:58:32 +0100
Subject: [PATCH] gnu: gst-plugins-base-gl: add package version that includes
opengl.

* gnu/packages/gstreamerr.scm (gst-plugins-base-gl): -Dgl=enabled, input: mesa
---
gnu/packages/gstreamer.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index bb991789da..324af10ee0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -581,6 +581,17 @@ (define-public gst-plugins-base
for the GStreamer multimedia library.")
(license license:lgpl2.0+)))
+(define-public gst-plugins-base-gl
+ (package (inherit gst-plugins-base)
+ (name "gst-plugins-base-gl")
+ (inputs
+ `(("mesa" ,mesa) ;; required for libgstgl
+ ,@(package-inputs gst-plugins-base)))
+ (arguments
+ `(,@(package-arguments gst-plugins-base)
+ #:tests? #f ;; check fails with gl
+ #:configure-flags '("-Dgl=enabled"))))) ;; requires mesa)
+
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
--
2.34.0
--
Unpolitisch sein
heißt politisch sein,
ohne es zu merken.
draketo.de
-----BEGIN PGP SIGNATURE-----

iQJEBAEBCAAuFiEE801qEjXQSQPNItXAE++NRSQDw+sFAmGdjuMQHGFybmVfYmFi
QHdlYi5kZQAKCRAT741FJAPD6xVmEACPq/qYQbvT4c7IvJDkGe9eBy1Ruw9ToPbY
XUD6y0JVuzOwh49bcbrmWGugC8hKWh8bHB85IpvLYPyzMa/APQ93FbFDdbTGUpCZ
v5FLtKq7HHq/rfngGL2YrI3Tl4xktt8cE2swvbN6tY4+9n9TI0xDA9h/w8bi0Tgz
R47jw3KRYwFJS5sCt4aFX+BPo1gbMyK6MixyEO0KtZAee6hIn846i9AoW3sj0RXU
7ak1WWtuTQamn5UxsC/eDheQuF/xTGRa2cInUQwskGF+EnWRuc3Gi+GJI6sYHci5
+0JZDT/dIeMqqiqq8Jcz+xVUpmWhETXu9QZXhyrxowjNRtVXxSKhE/vcRy2iniGK
uR+NOPLMh9I4ZpuwkBR/vESTLt3/5zrKm4/CEwtdLyabBMzsoxgrqICJg40U/2a9
3zJ4c2tBBade77tQeRdI9Sd733JZ1I9n0b9mIFTqC6mWqHMTq0d3OqocMukXKcy2
z49JbQbnau4NtEyVD86NAeoklW5iyc+9GpNidthF3qFJgreUDnY/Y1r9L/QQk/x1
iojMoese3P6Dz7I2OQg5PkT4DlVoUvWugGJvxGfuYzdzAv3PuzLjkiMgViXhQZ66
48tr9vNdIc8aspRgbuhtyFaGC9laR1YZ+B7yVRwwPQstD26AGHhtT3izIlN4NPl5
9S5BjD10eojEBAEBCAAuFiEE3Si95tmHXKvOSosd3M8NswvBBUgFAmGdjuMQHGFy
bmVfYmFiQHdlYi5kZQAKCRDczw2zC8EFSPTyA/0QYQNFdyt/0vV2OSBAyz/is/i7
nNqTMx+Yuv33AwT1ccC+x+Lta0XF/G2raF/0h5sm1JHzCIX1uUBpTPpbZOvvxNw3
W8GL8EQvxeyUNnZougGy+M+AoLXmoWQDUhRD9MvFJR1j7XwS7/3SmzVegvlCuTDp
N8+YyTgmssGYZ8CA7Q==
=7CPO
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 25 Nov 2021 05:43
(name . Dr. Arne Babenhauserheide)(address . arne_bab@web.de)(address . 52069@debbugs.gnu.org)
87lf1cc0aj.fsf@gmail.com
Hello,

"Dr. Arne Babenhauserheide" <arne_bab@web.de> writes:

Toggle quote (39 lines)
> Hi,
>
> The attached patch adds a derivative package of gst-plugins-base that
> includes gl support and has mesa as input.
>
> I needed that for an application.
>
> Best wishes,
> Arne
>
> From a1435b89c6ff01c1644bea671628678eebf3dfc2 Mon Sep 17 00:00:00 2001
> From: Arne Babenhauserheide <arne_bab@web.de>
> Date: Wed, 24 Nov 2021 01:58:32 +0100
> Subject: [PATCH] gnu: gst-plugins-base-gl: add package version that includes
> opengl.
>
> * gnu/packages/gstreamerr.scm (gst-plugins-base-gl): -Dgl=enabled, input: mesa
> ---
> gnu/packages/gstreamer.scm | 11 +++++++++++
> 1 file changed, 11 insertions(+)
>
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index bb991789da..324af10ee0 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -581,6 +581,17 @@ (define-public gst-plugins-base
> for the GStreamer multimedia library.")
> (license license:lgpl2.0+)))
>
> +(define-public gst-plugins-base-gl
> + (package (inherit gst-plugins-base)
> + (name "gst-plugins-base-gl")
> + (inputs
> + `(("mesa" ,mesa) ;; required for libgstgl
> + ,@(package-inputs gst-plugins-base)))
> + (arguments
> + `(,@(package-arguments gst-plugins-base)
> + #:tests? #f ;; check fails with gl

Disabling tests shouldn't be done lightly; considerable efforts have
probably gone in enabling them in the first place and they are one of
our best allies in assessing the negative impacts of an upgrade. Could
you please investigate what is at cause? Perhaps it's a matter of
adding an argument to the Xvfb invocation?

Thank you!

Maxim
?