[PATCH] [core-updates-frozen] gnu: libostree: Build with libsoup 2.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Maxim Cournoyer
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 24 Nov 2021 00:13
(name . Guix-patches)(address . guix-patches@gnu.org)
yM81l8J4NK-yvd77arnwGdIkxJ9K0tynt1ZQo0tXqSO-a416e_V06GMqM01w0Ble12pVX0TlmAwWMcfN64G4lQ88FtGW0bo6BxebaRflawU=@protonmail.com
Hello,

libostree should be built with libsoup-2 (doesn't support libsoup 3 currently) to have HTTP support. This was noticed due to Flatpak updates failing with "This version of ostree was built without libsoup or libcurl, and cannot fetch over HTTP". In the build log of ostree (eg https://ci.guix.gnu.org/build/1775196/log/raw) you can see that it will report no HTTP backend with libsoup 3, but properly shows libsoup when libsoup-2 is provided as an input as in this patch.

I've checked libostree builds and that Flatpak built with this version successfully can download over HTTP. Thanks to jackhill on IRC for spotting the configuration error of ostree when we both hit the Flatpak update bug.

(Also, I added my copyright line as I forgot it on earlier Flatpak updates around the p11-kit workaround and version updates.)

Happily running on core-updates-frozen,
John
From fc854d57513835493895c8030bfc131f36f72175 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Tue, 23 Nov 2021 18:04:17 -0500
Subject: [PATCH] gnu: libostree: Build with libsoup 2.

* gnu/packages/package-management.scm (libostree)[inputs]: Change
LIBSOUP to LIBSOUP-MINIMAL-2.
---
gnu/packages/package-management.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 163683ebdd..9d0d8d4670 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1567,7 +1568,7 @@ (define-public libostree
("glib" ,glib)
("gpgme" ,gpgme)
("libarchive" ,libarchive)
- ("libsoup" ,libsoup)
+ ("libsoup" ,libsoup-minimal-2) ; needs libsoup-2.4
("util-linux" ,util-linux)))
(home-page "https://ostree.readthedocs.io/en/latest/")
(synopsis "Operating system and container binary deployment and upgrades")
--
2.34.0
M
M
Maxim Cournoyer wrote on 24 Nov 2021 07:08
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 52068-done@debbugs.gnu.org)
87sfvmytkr.fsf@gmail.com
Hello John!

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (15 lines)
> Hello,
>
> libostree should be built with libsoup-2 (doesn't support libsoup 3
> currently) to have HTTP support. This was noticed due to Flatpak
> updates failing with "This version of ostree was built without libsoup
> or libcurl, and cannot fetch over HTTP". In the build log of ostree
> (eg https://ci.guix.gnu.org/build/1775196/log/raw ) you can see that
> it will report no HTTP backend with libsoup 3, but properly shows
> libsoup when libsoup-2 is provided as an input as in this patch.
>
> I've checked libostree builds and that Flatpak built with this version
> successfully can download over HTTP. Thanks to jackhill on IRC for
> spotting the configuration error of ostree when we both hit the
> Flatpak update bug.

Neat, thanks for taking care of it. Pushed as
93d1f8e5fc78bd82e8920d25b3e52a2d22528c17, and I updated libostree to
4d41c3beefa44d0ec30aa7108bc3979aa95c15e0 in the following commit.

Toggle quote (3 lines)
> (Also, I added my copyright line as I forgot it on earlier Flatpak
> updates around the p11-kit workaround and version updates.)

Perfect!

Happy hacking,

Maxim
Closed
J
J
John Kehayias wrote on 24 Nov 2021 07:25
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 52068-done@debbugs.gnu.org)
2GkeR1cROGYv48upSGy3wGS6Rmk8_jIjaNJw84O4ROqJ0sHkdyTm4OI_7maDSUMNTMPGL-KpUcK-8MPyvDPrn8JB2C1gVuopUjoGsu8fHtU=@protonmail.com
Hi Maxim!

??????? Original Message ???????

On Wednesday, November 24th, 2021 at 1:08 AM, Maxim Cournoyer wrote:

Toggle quote (23 lines)
> Hello John!
>
> John Kehayias john.kehayias@protonmail.com writes:
>
> > Hello,
> >
> > libostree should be built with libsoup-2 (doesn't support libsoup 3
> > currently) to have HTTP support. This was noticed due to Flatpak
> > updates failing with "This version of ostree was built without libsoup
> > or libcurl, and cannot fetch over HTTP". In the build log of ostree
> > (eg https://ci.guix.gnu.org/build/1775196/log/raw ) you can see that
> > it will report no HTTP backend with libsoup 3, but properly shows
> > libsoup when libsoup-2 is provided as an input as in this patch.
> >
> > I've checked libostree builds and that Flatpak built with this version
> > successfully can download over HTTP. Thanks to jackhill on IRC for
> > spotting the configuration error of ostree when we both hit the
> > Flatpak update bug.
>
> Neat, thanks for taking care of it. Pushed as
> 93d1f8e5fc78bd82e8920d25b3e52a2d22528c17, and I updated libostree to
> 4d41c3beefa44d0ec30aa7108bc3979aa95c15e0 in the following commit.
>
Great, and thanks for catching the update too!

Toggle quote (6 lines)
> > (Also, I added my copyright line as I forgot it on earlier Flatpak
> > updates around the p11-kit workaround and version updates.)
>
> Perfect!
>

Thanks! Looks like we are closing in on that big merge finally!

John
Closed
?