[PATCH] gnu: Add feather font

  • Done
  • quality assurance status badge
Details
2 participants
  • Jaft
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jaft
Severity
normal
J
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
DM6PR19MB246009FC1A233E37685B9112999F9@DM6PR19MB2460.namprd19.prod.outlook.com
* gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI

The foundry, AT-UI, has a hyphen but https://guix.gnu.org/manual/en/html_node/Fonts.html
seems to implicitly imply the foundry wouldn't have hyphens so I removed them,
for the package name (font-atui-feather).

---
gnu/packages/fonts.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
Toggle diff (32 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c3ad57f203..2a46e08d9d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -42,6 +42,7 @@
 ;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2285,3 +2286,19 @@ (define-public font-overpass
 Overpass includes proportional and monospace variants.")
     (license (list license:silofl1.1
                    license:lgpl2.1))))
+
+(define-public font-atui-feather
+  (package
+    (name "font-atui-feather")
+    (version "0")
+    (source (origin
+              (method url-fetch/zipbomb)
+              (uri "https://github.com/AT-UI/feather-font/archive/refs/heads/master.zip")
+              (sha256 (base32 "0lp1m1a47s56rj0q6nj8j5snkbw8jq3q7zwdzf86sbbglq170inh"))))
+    (build-system font-build-system)
+    (home-page "https://at-ui.github.io/feather-font/")
+    (synopsis "Iconfont version of Feather")
+    (description "Feather is a collection of simply beautiful open source icons.
+Each icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
+and readability.  This package bundles those icons into a font.")
+    (license license:expat)))
L
L
Ludovic Courtès wrote on 10 Dec 2021 15:28
(name . Jaft)(address . jaft.r@outlook.com)(address . 52030@debbugs.gnu.org)
87tufg7cvj.fsf_-_@gnu.org
Hi Jaft,

Jaft <jaft.r@outlook.com> skribis:

Toggle quote (6 lines)
> * gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI
>
> The foundry, AT-UI, has a hyphen but https://guix.gnu.org/manual/en/html_node/Fonts.html
> seems to implicitly imply the foundry wouldn't have hyphens so I removed them,
> for the package name (font-atui-feather).

I think it’s fine either way.

Toggle quote (7 lines)
> +    (name "font-atui-feather")
> +    (version "0")
> +    (source (origin
> +              (method url-fetch/zipbomb)
> +              (uri "https://github.com/AT-UI/feather-font/archive/refs/heads/master.zip")
> +              (sha256 (base32 "0lp1m1a47s56rj0q6nj8j5snkbw8jq3q7zwdzf86sbbglq170inh"))))

Note that ‘master.zip’ changes at each commit (and its content can also
change even if the HEAD commit is unchanged because it’s a generated
file.)

Could you instead change it to refer to a non-generated zip file, or use
‘git-fetch’ to obtain a checkout?

You may also need to adjust the version string.

Toggle quote (5 lines)
> +    (build-system font-build-system)
> +    (home-page "https://at-ui.github.io/feather-font/")
> +    (synopsis "Iconfont version of Feather")
> +    (description "Feather is a collection of simply beautiful open source icons.

Everything is free software/data in Guix, so you can remove “open
source”. :-)

Could you send an updated patch? Preferably as a attachment to make
sure it’s not mangled on its way.

Thanks in advance!

Ludo’.
J
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 52030@debbugs.gnu.org)(address . 52030@debbugs.gnu.org)
BN8PR19MB244907B206BEBE03E897488099779@BN8PR19MB2449.namprd19.prod.outlook.com
Toggle quote (24 lines)
> On Friday, December 10, 2021, 08:28:42 AM CST, Ludovic Courtès <ludo@gnu.org> wrote: 
>
>
>
>
>
> Hi Jaft,
>
> > +    (name "font-atui-feather")
> > +    (version "0")
> > +    (source (origin
> > +              (method url-fetch/zipbomb)
> > +              (uri "https://github.com/AT-UI/feather-font/archive/refs/heads/master.zip")
> > +              (sha256 (base32 "0lp1m1a47s56rj0q6nj8j5snkbw8jq3q7zwdzf86sbbglq170inh"))))
>
> Note that ‘master.zip’ changes at each commit (and its content can also
> change even if the HEAD commit is unchanged because it’s a generated
> file.)
>
> Could you instead change it to refer to a non-generated zip file, or use
> ‘git-fetch’ to obtain a checkout?
>
> You may also need to adjust the version string.

Huh; sorry about that. I knew that and yet completely missed it, when writing this up. The repo. doesn't have any tags or releases (maybe that's what my brain was thinking when it originally used master) so I've just pointed it to the latest commit they'd made, in the revision.

Toggle quote (8 lines)
> > +    (build-system font-build-system)
> > +    (home-page "https://at-ui.github.io/feather-font/")
> > +    (synopsis "Iconfont version of Feather")
> +    (description "Feather is a collection of simply beautiful open source icons.
>
> Everything is free software/data in Guix, so you can remove “open
> source”.  :-)

Haha; oh, right: fair point. Removed.

Toggle quote (7 lines)
> Could you send an updated patch?  Preferably as a attachment to make
> sure it’s not mangled on its way.
>
> Thanks in advance!
>
> Ludo’.

For some reason, I only remembered the part of the documentation that says you can submit the patch in the body of the E-mail but, double-checking my memory, it definitely also lists being able to send the patch as an attachment. I'll start doing that as others have mentioned mangling, as well.
* gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI
---
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 63d1240d5c..262ca3adfa 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2288,3 +2289,21 @@ (define-public font-overpass
Overpass includes proportional and monospace variants.")
(license (list license:silofl1.1
license:lgpl2.1))))
+
+(define-public font-atui-feather
+ (package
+ (name "font-atui-feather")
+ (version "0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")
+ (url "https://github.com/AT-UI/feather-font/")))
+ (sha256 (base32 "0hk12bjlsh0j6kd0sz3nwax259afdi6dxws4x88yz5ssxic1ng2j"))))
+ (build-system font-build-system)
+ (home-page "https://at-ui.github.io/feather-font/")
+ (synopsis "Iconfont version of Feather")
+ (description "Feather is a collection of simply beautiful icons.
+Each icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
+and readability. This package bundles those icons into a font.")
+ (license license:expat)))
J
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . 52030@debbugs.gnu.org)(address . 52030@debbugs.gnu.org)
DM5PR04MB37723F039FBF8A4E53EA00A399009@DM5PR04MB3772.namprd04.prod.outlook.com
I don't know if it's generally considered poor etiquette to do this but just bumping this E-mail thread, as I believe I've done the required changes and, theoretically, this patch should be all ready to just go.
L
L
Ludovic Courtès wrote on 27 Feb 2022 22:40
(name . Jaft)(address . jaft.r@outlook.com)(name . 52030@debbugs.gnu.org)(address . 52030-done@debbugs.gnu.org)
87k0dgt2cy.fsf_-_@gnu.org
Hi,

Jaft <jaft.r@outlook.com> skribis:

Toggle quote (4 lines)
> For some reason, I only remembered the part of the documentation that says you can submit the patch in the body of the E-mail but, double-checking my memory, it definitely also lists being able to send the patch as an attachment. I'll start doing that as others have mentioned mangling, as well.
>
> * gnu/packages/fonts.scm (feather): Add Feather iconfont by AT-UI

[...]

Toggle quote (18 lines)
> +(define-public font-atui-feather
> + (package
> + (name "font-atui-feather")
> + (version "0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")
> + (url "https://github.com/AT-UI/feather-font/")))
> + (sha256 (base32 "0hk12bjlsh0j6kd0sz3nwax259afdi6dxws4x88yz5ssxic1ng2j"))))
> + (build-system font-build-system)
> + (home-page "https://at-ui.github.io/feather-font/")
> + (synopsis "Iconfont version of Feather")
> + (description "Feather is a collection of simply beautiful icons.
> +Each icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
> +and readability. This package bundles those icons into a font.")
> + (license license:expat)))

I’ve (finally!) committed a tweaked version that includes a ‘version’
field following the guidelines in
also addressing another ‘guix lint’ warning about the origin.

Jaft <jaft.r@outlook.com> skribis:

Toggle quote (2 lines)
> I don't know if it's generally considered poor etiquette to do this but just bumping this E-mail thread, as I believe I've done the required changes and, theoretically, this patch should be all ready to just go.

No, you were right to ping me; apologies for missing your earlier email.

In the future, it’s even more convenient for us if you can send a patch
created with ‘git send-email’.

Thank you, and sorry for the delay!

Ludo’.
Closed
?