(name . Guix-patches)(address . guix-patches@gnu.org)
Hello,
After much time spent trying to fix/update python-nautilus failing on core-updates-frozen, I realized this is not actually a package needed by anything in Guix. Packages actually wanted nautilus-python for integration with the nautilus file manager, not this one: https://gitlab.gnome.org/GNOME/nautilus-python
Since the package is unused by other packages then, and dates from 2016 (perhaps inactive), I've gone ahead and removed it. This should fix (or help fix) the related builds failing on core-updates-frozen.
I've tested that one of the packages that have this as an input, syncthing-gtk, builds and runs without it. I have not tried the others but have checked upstream listed nautilus-python as what they wanted which is a different package.
I have a WIP patch that added some python packages that were needed to update python-nautilus, which I'll send as a bug report in case it is helpful to someone later.
Thanks,
John
From 701b723d9da070c7e1515463b3023b9638c9cef2 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sun, 21 Nov 2021 15:58:38 -0500
Subject: [PATCH] gnu: python-nautilus: Remove package.
This package dates from 2016 and looks inactive. The packages that used this
as an input actually wanted nautilus-python (not currently packaged),
for (optional) integration with the nautilus file manager.
* gnu/packages/python-xyz.scm (python-nautilus): Remove variable.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect)[inputs]: Remove
it.
* gnu/packages/sync.scm (nexcloud-client)[inputs]: Remove it.
* gnu/packages/syncthing.scm (syncthing-gtk)[inputs]: Remove it.
---
gnu/packages/gnome-xyz.scm | 1 -
gnu/packages/python-xyz.scm | 33 ---------------------------------
gnu/packages/sync.scm | 1 -
gnu/packages/syncthing.scm | 1 -
4 files changed, 36 deletions(-)
Toggle diff (82 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6ba9656cdd..087dd97f7d 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -437,7 +437,6 @@ (define-public gnome-shell-extension-gsconnect
("nautilus" ,nautilus)
("openssh" ,openssh)
("openssl" ,openssl)
- ("python-nautilus" ,python-nautilus)
("python-pygobject" ,python-pygobject)
("upower" ,upower)))
(native-inputs
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7189e0ddd..2e54bf7758 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16991,39 +16991,6 @@ (define-public python-graphene
with an associated set of resolve methods that know how to fetch data.")
(license license:expat)))
-(define-public python-nautilus
- (package
- (name "python-nautilus")
- (version "0.4.9")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "nautilus" version))
- (sha256
- (base32
- "01hwzjc1zshk4vvxrcghm398fpy4jls66dyz06g07mrwqif8878p"))))
- (build-system python-build-system)
- (arguments `(#:tests? #f)) ; fails to import test modules
- (propagated-inputs
- `(("python-bcrypt" ,python-bcrypt)
- ("python-click" ,python-click)
- ("python-consul" ,python-consul)
- ("python-graphene" ,python-graphene)
- ("python-jinja2" ,python-jinja2)
- ("python-peewee" ,python-peewee)
- ("python-pika" ,python-pika)
- ("python-tornado" ,python-tornado)
- ("python-wtforms" ,python-wtforms)))
- (native-inputs
- `(("python-nose2" ,python-nose2)))
- (home-page "https://github.com/AlecAivazis/nautilus")
- (synopsis "Library for creating microservice applications")
- (description
- "Nautilus is a framework for flux based microservices that looks to
-provide extendible implementations of common aspects of a cloud so that you can
-focus on building massively scalable web applications.")
- (license license:expat)))
-
(define-public python-random2
(package
(name "python-random2")
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index ad264a0fe3..946b64b452 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -190,7 +190,6 @@ (define-public nextcloud-client
("libcloudproviders" ,libcloudproviders)
("libzip" ,libzip)
("openssl" ,openssl)
- ("python-nautilus" ,python-nautilus)
("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4deb60bee2..8880801adb 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -191,7 +191,6 @@ (define-public syncthing-gtk
("python-dateutil" ,python-dateutil)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
- ("python-nautilus" ,python-nautilus)
("psmisc" ,psmisc)
("syncthing" ,syncthing)))
;; (native-inputs
--
2.34.0