[PATCH] gnu: Add gnome-shell-extension-customize-ibus.

  • Done
  • quality assurance status badge
Details
2 participants
  • Songlin Jiang
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Songlin Jiang
Severity
normal
S
S
Songlin Jiang wrote on 21 Nov 2021 07:10
(name . guix-patches)(address . guix-patches@gnu.org)(name . Hollow Man)(address . hollowman@hollowman.ml)
tencent_3118E14037C49D3E409819D7@qq.com
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-customize-ibus): New variable
---
gnu/packages/gnome-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6d8d02fb9c..51a746e143 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Ellis Kenyo <me@elken.dev>
;;; Copyright © 2020 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -990,3 +991,38 @@ palette.")
outputs notifications to STDOUT in order to allow the user to process
notifications any way they prefer.")
(license license:expat))))
+
+(define-public gnome-shell-extension-customize-ibus
+ (package
+ (name "gnome-shell-extension-customize-ibus")
+ (version "78")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openSUSE/Customize-IBus.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hnnsjriq7xaakk8biwz55mn077lnm9nsmi4wz5zk7clgxmasvq9"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("_build" "share/gnome-shell/extensions/customize-ibus@hollowman.ml"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'compile-everything
+ (lambda _
+ (with-directory-excursion "."
+ (invoke "make"
+ "_build"
+ "VERSION=78"))
+ #t)))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")))
+ (home-page "https://github.com/openSUSE/Customize-IBus")
+ (synopsis "GNOME Shell Extension for IBus Customization")
+ (description "Customize IBus provides full customization of appearance,
+behavior, system tray and input source indicator for IBus")
+ (license license:gpl3+)))
--
2.31.1
L
L
Liliana Marie Prikler wrote on 21 Nov 2021 15:17
9649cc317a8b07b423377320324388d0874363a5.camel@gmail.com
Hi,

I've applied this patch with the following changes.

Am Sonntag, den 21.11.2021, 14:10 +0800 schrieb Songlin Jiang:
Toggle quote (2 lines)
> * gnu/packages/gnome-xyz.scm (gnome-shell-extension-customize-ibus):
> New variable
Added missing period.
Toggle quote (2 lines)
> +
> +(define-public gnome-shell-extension-customize-ibus
Moved to the extensions, which unfortunately enough aren't currently
ordered alphabetically.
Toggle quote (14 lines)
> + (package
> + (name "gnome-shell-extension-customize-ibus")
> + (version "78")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/openSUSE/Customize-IBus.git")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> "1hnnsjriq7xaakk8biwz55mn077lnm9nsmi4wz5zk7clgxmasvq9"))))
> + (build-system copy-build-system)
Changed to gnu-build-system.
Toggle quote (4 lines)
> + (arguments
> + '(#:install-plan
> + '(("_build" "
> share/gnome-shell/extensions/customize-ibus@hollowman.ml"))
Added #:make-flags and #:tests? (with comment as to the "missing" test
phase).
Toggle quote (9 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (add-before 'install 'compile-everything
> + (lambda _
> + (with-directory-excursion "."
> + (invoke "make"
> + "_build"
> + "VERSION=78"))
> + #t)))))
Dropped in favor of simply deleting bootstrap and configure.
Toggle quote (8 lines)
> + (native-inputs
> + `(("gettext" ,gettext-minimal)
> + ("glib:bin" ,glib "bin")))
> + (home-page "https://github.com/openSUSE/Customize-IBus")
> + (synopsis "GNOME Shell Extension for IBus Customization")
> + (description "Customize IBus provides full customization of
> appearance,
> +behavior, system tray and input source indicator for IBus")
Added missing period.

Thanks
Closed
?