[PATCH] [core-updates-frozen] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with webkitgtk-with-libsoup2.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
John Kehayias
Severity
normal

Debbugs page

John Kehayias wrote 3 years ago
(name . Guix-patches)(address . guix-patches@gnu.org)
zVQzP9bHdO_a5VJMh0W_u5ceaECKyFowDlbeffRkMtgTrff9pKNHhsy09y0mKwrKoVMgn-mMqhaOLBh7gbmG7MqOLRxqFQj1gyRSBMVyUjM=@protonmail.com
Hello,

Emacs with xwidgets support needs webkit2gtk-4.0, which for us means the variant built with libsoup2 on core-updates-frozen. I've changed the inputs in the two affected Emacs packages and added to the comment about where webkitgtk-with-libsoup2 is used. Apologies if the formatting/style of the commit message is off, wasn't sure how best to do this.

John
From 17dd0a5748bc4a984393812e395e88c6060cbf55 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sat, 20 Nov 2021 14:03:08 -0500
Subject: [PATCH] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with
webkitgtk-with-libsoup2.

* gnu/packages/emacs.scm (emacs-xwidgets and emacs-next-pgtk)[inputs]: Replace
webkitgtk with webkitgtk-with-libsoup2.
* gnu/packages/webkit.scm (webkitgtk-with-libsoup2): Add further information
about where this package is used and upstream tracker for libsoup3.
---
gnu/packages/emacs.scm | 4 ++--
gnu/packages/webkit.scm | 3 +++
2 files changed, 5 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 734f3dfaa3..fbd9ff96f0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -354,7 +354,7 @@ (define-public emacs-next-pgtk
`(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("glib-networking" ,glib-networking)))
(inputs
- `(("webkitgtk" ,webkitgtk)
+ `(("webkitgtk" ,webkitgtk-with-libsoup2)
,@(package-inputs emacs-next)))
(home-page "https://github.com/masm11/emacs")
(synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
@@ -400,7 +400,7 @@ (define-public emacs-xwidgets
(delete 'restore-emacs-pdmp)
(delete 'strip-double-wrap)))))
(inputs
- `(("webkitgtk" ,webkitgtk)
+ `(("webkitgtk" ,webkitgtk-with-libsoup2)
("libxcomposite" ,libxcomposite)
,@(package-inputs emacs)))))
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 5230129158..f988bf0697 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -364,6 +364,9 @@ (define-public webkitgtk
;;; Required by gnome-online-accounts; as webkitgtk 2.34 propagates libsoup 3,
;;; which causes the build to fail.
+;;; Also required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other
+;;; Gnome packages for webkit2gtk-4.0. See also the upstream tracker for
+;;; libsoup 3: https://gitlab.gnome.org/GNOME/libsoup/-/issues/218
(define-public webkitgtk-with-libsoup2
(package/inherit webkitgtk
(name "webkitgtk-with-libsoup2")
--
2.34.0
John Kehayias wrote 3 years ago
(name . 52005@debbugs.gnu.org)(address . 52005@debbugs.gnu.org)
ss2l2W2jYaL4g0hbpoS1MO-7J9UQzfSE0LTkaOg-ujsgHi3nua_2XJO0qQS34ixwvcfIRPt0vV0WxPzQsz7bh0WlsYrQVqGCmUOa7Bh7ld8=@protonmail.com
Forgot copyright lines, if it is needed for either or both files. Updated patch to include them if necessary.
From 8816823847395556b0ffc161f2891ebfd118745b Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sat, 20 Nov 2021 14:03:08 -0500
Subject: [PATCH] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with
webkitgtk-with-libsoup2.

* gnu/packages/emacs.scm (emacs-xwidgets and emacs-next-pgtk)[inputs]: Replace
webkitgtk with webkitgtk-with-libsoup2.
* gnu/packages/webkit.scm (webkitgtk-with-libsoup2): Add further information
about where this package is used and upstream tracker for libsoup3.
---
gnu/packages/emacs.scm | 5 +++--
gnu/packages/webkit.scm | 4 ++++
2 files changed, 7 insertions(+), 2 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 734f3dfaa3..9168d2dde2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -354,7 +355,7 @@ (define-public emacs-next-pgtk
`(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("glib-networking" ,glib-networking)))
(inputs
- `(("webkitgtk" ,webkitgtk)
+ `(("webkitgtk" ,webkitgtk-with-libsoup2)
,@(package-inputs emacs-next)))
(home-page "https://github.com/masm11/emacs")
(synopsis "Emacs text editor with @code{pgtk} and @code{xwidgets} support")
@@ -400,7 +401,7 @@ (define-public emacs-xwidgets
(delete 'restore-emacs-pdmp)
(delete 'strip-double-wrap)))))
(inputs
- `(("webkitgtk" ,webkitgtk)
+ `(("webkitgtk" ,webkitgtk-with-libsoup2)
("libxcomposite" ,libxcomposite)
,@(package-inputs emacs)))))
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 5230129158..1fe662d4e2 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -364,6 +365,9 @@ (define-public webkitgtk
;;; Required by gnome-online-accounts; as webkitgtk 2.34 propagates libsoup 3,
;;; which causes the build to fail.
+;;; Also required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other
+;;; Gnome packages for webkit2gtk-4.0. See also the upstream tracker for
+;;; libsoup 3: https://gitlab.gnome.org/GNOME/libsoup/-/issues/218
(define-public webkitgtk-with-libsoup2
(package/inherit webkitgtk
(name "webkitgtk-with-libsoup2")
--
2.34.0
Tobias Geerinckx-Rice wrote 3 years ago
[PATCH] [core-updates-frozen] gnu: emacs-xwidgets/-next-pgtk: Replace webkitgtk with webkitgtk-with-libsoup2.
(address . 52005-done@debbugs.gnu.org)
87o86dik40.fsf@nckx
John,

Pushed with some minor changes as
85de88f1adcf5b91afe76bf671c05b8596821920:

- Removed copyright lines.
- Edited commit message a bit:
- Wrapped to 72 characters, the git (or Linux?) convention
- Shortened title as well: we often exceed the conventional 50
characters, but try to keep it short still
- Wrote ‘{,-next-pgtk}’: valid variable names like
‘foo-tools/static’ exist
- Wrote ‘(var1, var2)’ instead of ‘(var1 and var2)’.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYZpqrw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15dIUBAMOwsVlV0bfL16DkfcCnsS3R8nySWegCdPSCzQ2V
+sfTAP9JzEjHTK5oy9yrYXJacLBUQzl3jB9hkFOV0pHVNH7EBA==
=RyLd
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52005@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52005
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help