[PATCH] gnu: Add guile-gitlab

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 3 years ago
(address . guix-patches@gnu.org)
87ilwmzzi7.fsf@gmail.com
Hello Guixers,

here's my first patch for GNU Guix that adds Guile-GitLab[1] -- my Guile
module that allows to interact with GitLab Community Edition REST API
and provides a useful tool for that.

Thanks,

- avp

From 6702a25439e480b45432915f68b64f7177c53fa0 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 20 Nov 2021 15:32:10 +0300
Subject: [PATCH] gnu: Add guile-gitlab

* gnu/packages/guile-xyz.scm (guile-gitlab): Add new package.
---
gnu/packages/guile-xyz.scm | 47 ++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 628d81710a..65e30c2618 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4795,3 +4796,49 @@ It provides a generic library for writing implementations of a netlink
protocol, a low-level rtnetlink implementation that uses that library and a
high-level API for network management that uses rtnetlink.")
(license license:gpl3+)))
+
+(define-public guile-gitlab
+ (package
+ (name "guile-gitlab")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-gitlab.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1vpwwnxxglla8ci9mz6smm3nyqvdz2k082qyrp36ad14v9y70l86"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs `(("guile" ,guile-2.2)
+ ("guile-json" ,guile-json-1)
+ ("guile-gnutls" ,guile2.2-gnutls)))
+ (propagated-inputs `(("guile-lib" ,guile2.2-lib)))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-guilesitedir
+ (let ((files (find-files "." "Makefile.in")))
+ (lambda _
+ (substitute* files
+ (("^guilesitedir =.*$")
+ "guilesitedir = \
+$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
+ #t)))
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (home-page "https://github.com/artyom-poptsov/guile-gitlab")
+ (synopsis "GitLab module for Guile")
+ (description
+ "GNU Guile interface to GitLab Community Edition REST API.
+
+This package provides @samp{gitlab-cli} command line tool for interacting with
+a GitLab instance.")
+ (license license:gpl3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGZAoAACgkQ6cWi2QiY
oC+DyQf+KpCNakCe4P4vwStyEsnAYq9JAg2ZX0wcg/i0g9EtfMf++ZFhgbJl4Mj4
ztnTnO/0IVTbth7wvoS0Ii5YdbcLcXLo604C9gZ1BjQursc0LjGTTRO1Fgnpb82A
ZnDsPFKXQ5zlYBB5SOKynEUNuIqR00xX4XOAJuqsegJ66vQzQTV2EK9b/+HG3V05
Y6OyvxjcUIrBdQqIAm+uhzoCSgBuccr+K2uyvtVtb84i+pETlv+zX3vQcgqnqSvw
5cWuaGdLmWCdRqitbIXqkHERIxq8WZOMIp21SWVVjH6+TXlc4VZLt7ASaTRgr0p0
E8LXG8hJRiZ3+R2Tyq4q0B3Y0x/ttw==
=5Bqm
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 51998@debbugs.gnu.org)
87h7c0mq2s.fsf@gnu.org
Hello Artyom,

Thanks for this first contribution! I think that there is a small issue
with the library path. The gitlab.scm files is in:

Toggle snippet (3 lines)
/gnu/store/xn0bnrh23iscxy7xsvzqffyjy4wqy1q6-guile-gitlab-0.1.0/share/guile-gitlab/gitlab.scm

whereas it should be in:

Toggle snippet (3 lines)
/gnu/store/xn0bnrh23iscxy7xsvzqffyjy4wqy1q6-guile-gitlab-0.1.0/share/guile/site/2.2/gitlab.scm

I also have the following error when running gitlab-cli:

Toggle snippet (7 lines)
0 (scm-error misc-error #f "~A ~S" ("no code for modu…" …) …)

ERROR: In procedure scm-error:
no code for module (gitlab)

that should be solved by adjusting the library path.

Thanks,

Mathieu
Artyom V. Poptsov wrote 3 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 51998@debbugs.gnu.org)
87bl26k9la.fsf@gmail.com
Hello Mathieu,

thank you for the feedback.

I fixed my patch, please find the updated version attached.

- Artyom
From 2e53ae7cda8d704d38633636f6e602abe411498c Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 20 Nov 2021 15:32:10 +0300
Subject: [PATCH] gnu: Add guile-gitlab

* gnu/packages/guile-xyz.scm (guile-gitlab): Add new package.
---
gnu/packages/guile-xyz.scm | 69 ++++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)

Toggle diff (86 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 628d81710a..5aae47da1d 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4795,3 +4796,71 @@ It provides a generic library for writing implementations of a netlink
protocol, a low-level rtnetlink implementation that uses that library and a
high-level API for network management that uses rtnetlink.")
(license license:gpl3+)))
+
+(define-public guile-gitlab
+ (package
+ (name "guile-gitlab")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-gitlab")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1vpwwnxxglla8ci9mz6smm3nyqvdz2k082qyrp36ad14v9y70l86"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:modules (((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%gnu-build-system-modules)
+ #:imported-modules ((guix build guile-build-system)
+ ,@%gnu-build-system-modules)
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-guilesitedir
+ (lambda _
+ (substitute* (find-files "." "Makefile.in")
+ (("^guilesitedir = .*$")
+ "guilesitedir = \
+$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n")
+ (("guilemoduledir =.*guile/site" all)
+ (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile-lib (assoc-ref inputs "guile-lib"))
+ (version (target-guile-effective-version))
+ (scm (string-append "/share/guile/site/"
+ version))
+ (go (string-append "/lib/guile/"
+ version "/site-ccache")))
+ (wrap-program (string-append bin "/gitlab-cli")
+ `("GUILE_LOAD_PATH" prefix
+ (,(string-append out scm)
+ ,(string-append guile-lib scm)))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
+ (,(string-append out go)
+ ,(string-append guile-lib go)))))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs `(("guile" ,guile-2.2)
+ ("guile-json" ,guile-json-1)
+ ("guile-gnutls" ,guile2.2-gnutls)))
+ (propagated-inputs `(("guile-lib" ,guile2.2-lib)))
+ (home-page "https://github.com/artyom-poptsov/guile-gitlab")
+ (synopsis "GitLab module for Guile")
+ (description
+ "GNU Guile interface to GitLab Community Edition REST API.
+
+This package provides @samp{gitlab-cli} command line tool for interacting with
+a GitLab instance.")
+ (license license:gpl3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGhM3EACgkQ6cWi2QiY
oC8h5gf/Ue/4Naq+WkwoNzf6Qg/iZ3GUdF/p4zvuOVNwFNGgMeYXqlZZJUiuOCG0
dfETwYRCTxGmxFTl2F6kuTPFwNNcCraW0JIfcSdcqnSDYFWhFef8QfDV/+GAwSmS
MjukXikmMYRCet35P0esQivTxtxBCyGdHAiOPm4G//y0a+wPq2GIXGLAGg5OFs+8
5T7ZSofie5AoBLUrscSbj/komQG1ehzAQQgL+AlKmKZokYhaWJGjfgjANZaW00A9
uX3Qf8FAjp0NU3POjL5/EaAJWYaKIhiFKbdUpZgTd3F5CX0PlxqnQwvjidhhP9yH
c3sJGSjGq01qWgYtI+tG2YGPyKLHww==
=th0w
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 51998@debbugs.gnu.org)
8735nhq1xh.fsf@gnu.org
Привет Артём,

Спасибо за вторую версию.

Toggle quote (6 lines)
> + (substitute* (find-files "." "Makefile.in")
> + (("^guilesitedir = .*$")
> + "guilesitedir = \
> +$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n")
> + (("guilemoduledir =.*guile/site" all)

Any reason not to write this directly in the project Makefile.am? For
instance, in Guile-Parted Makefile.am, there is:

Toggle snippet (6 lines)
include guile.am

moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache

Thanks,

Mathieu
Artyom V. Poptsov wrote 3 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 51998@debbugs.gnu.org)
87zgppifrm.fsf@gmail.com
Hello Mathieu,
I just released Guile-GitLab 0.2.0[1] with fixed Autotools scripts. Thanks
for the hints, I appreciate it.
Could you please check if my package is OK?
- Artyom
P.S.
Toggle quote (1 lines)
> Спасибо за вторую версию.
Ты знаешь русский язык?
From 146fb0e85382ba58e324af99b4bef39a261c0da0 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 20 Nov 2021 15:32:10 +0300
Subject: [PATCH] gnu: Add guile-gitlab

* gnu/packages/guile-xyz.scm (guile-gitlab): Add new package.
---
gnu/packages/guile-xyz.scm | 61 ++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (78 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 628d81710a..841fd49f18 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4795,3 +4796,63 @@ It provides a generic library for writing implementations of a netlink
protocol, a low-level rtnetlink implementation that uses that library and a
high-level API for network management that uses rtnetlink.")
(license license:gpl3+)))
+
+(define-public guile-gitlab
+ (package
+ (name "guile-gitlab")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-gitlab")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1yq8w507vw9n7f626sbnsk8prsdk337d6acr7f9k3j500lhlvxj5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules (((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%gnu-build-system-modules)
+ #:imported-modules ((guix build guile-build-system)
+ ,@%gnu-build-system-modules)
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile-lib (assoc-ref inputs "guile-lib"))
+ (version (target-guile-effective-version))
+ (scm (string-append "/share/guile/site/"
+ version))
+ (go (string-append "/lib/guile/"
+ version "/site-ccache")))
+ (wrap-program (string-append bin "/gitlab-cli")
+ `("GUILE_LOAD_PATH" prefix
+ (,(string-append out scm)
+ ,(string-append guile-lib scm)))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
+ (,(string-append out go)
+ ,(string-append guile-lib go)))))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("guile-json" ,guile-json-1)
+ ("guile-gnutls" ,guile2.2-gnutls)))
+ (propagated-inputs
+ `(("guile-lib" ,guile2.2-lib)))
+ (home-page "https://github.com/artyom-poptsov/guile-gitlab")
+ (synopsis "GitLab module for Guile")
+ (description
+ "GNU Guile interface to GitLab Community Edition REST API.
+
+This package provides @samp{gitlab-cli} command line tool for interacting with
+a GitLab instance.")
+ (license license:gpl3)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGigK0ACgkQ6cWi2QiY
oC+mZwf/SEHpJxXfUqZGLszuYqXbGaanWmeTK1r5CAtZeQxn2oPEMbIqnj9UPN9t
R/QqXv7vHM0ZOE7dR3ndHyZebOKvLcF7fr+GswTTBcJo7DU4lgN20Ok9E6xQgh4g
GaLAD/fC4dhydu34EH/1aM5/PTFSWjtnFOM0u+Z91lfsqyHJEk96PK47irl1yAKA
y9uqkPLJ3vJsxQS4D5BXf2jSrn61Wmf9BB9nYoG0emottgMrobGyY+JJ7nf86JyQ
ihcqEIjs3OpNgFRx7es7jUXw1qeNXF5rVpqGcoZFGDyupTNu0rbVQMmd7HDt4jd2
EEsYFP4sPc52yapgo9F2QwED/D5+mQ==
=F6Sj
-----END PGP SIGNATURE-----

Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 51998-done@debbugs.gnu.org)
87mtlor3yq.fsf@gnu.org
Hello Artyom,

I edited a bit the package definition:

* Added bash-minimal to the inputs as suggested by "guix lint".
* Moved guile-lib to the inputs.
* Added json and tls to the wrap so that they can always be found.
* Wrapped a few lines.

and pushed as a0352562505cfced63ca415e2bb4cbce29f7fc35.

Note that I also have the following error on two different Gitlab
servers:

Toggle snippet (19 lines)
mathieu@meije ~/guix [env]$ gitlab-cli project list --token "xxx" --server "https://gitlab.com"
Backtrace:
4 (apply-smob/1 #<catch-closure 7fc671915920>)
In ice-9/boot-9.scm:
705:2 3 (call-with-prompt _ _ #<procedure default-prompt-handle?>)
In ice-9/eval.scm:
619:8 2 (_ #(#(#<directory (guile-user) 7fc6715ad140>)))
In gitlab/cli/project.scm:
116:19 1 (gitlab-cli-project/list _ _)
In gitlab/api/common.scm:
74:21 0 (api-get #<<session> 7fc6715e2cf0> "/api/v4/projects" # ?)

gitlab/api/common.scm:74:21: In procedure api-get:
In procedure vector-length: Wrong type argument in position 1 (expecting
vector): (#<hash-table 7fc67039eda0 91/113> #<hash-table 7fc67067e060
91/113> #<hash-table 7fc67032a8e0 91/113> #<hash-table 7fc670376e20
91/113> #<hash-table 7fc67039062 ...

Are you expecting a specific Gitlab revision or the error is elsewhere?

Thanks,

Mathieu
Closed
Artyom V. Poptsov wrote 3 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 51998-done@debbugs.gnu.org)
87r1b017ds.fsf@gmail.com
Hello Mathieu,

Toggle quote (9 lines)
> I edited a bit the package definition:

> * Added bash-minimal to the inputs as suggested by "guix lint".
> * Moved guile-lib to the inputs.
> * Added json and tls to the wrap so that they can always be found.
> * Wrapped a few lines.

> and pushed as a0352562505cfced63ca415e2bb4cbce29f7fc35.

Thanks for helping me with this package! I'm looking forward to package
other projects for GNU Guix in the near future.

Toggle quote (3 lines)
> Note that I also have the following error on two different Gitlab
> servers:

that's strange as I don's see this error; tested 'gitlab-cli' on two
servers as well -- one where I have admin rights and gitlab.com with a
regular non-admin token.

I think I need to investigate the problem further, but for now I fixed
another bug that lead to 'guile-cli' fails if a user passed non-existing
command (like "projects" instead of "project".)

So here's a patch attached that updates Guile-GitLab to 0.2.1 with this
bugfix.

- Artyom
From c932be626bdfc0c74d4d366fd0fe4a65de200a7f Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 28 Nov 2021 20:54:45 +0300
Subject: [PATCH] gnu: guile-gitlab: Update to 0.2.1

* gnu/packages/guile-xyz.scm (guile-gitlab): Update to 0.2.1.
---
gnu/packages/guile-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 841fd49f18..658f810be8 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4800,7 +4800,7 @@ high-level API for network management that uses rtnetlink.")
(define-public guile-gitlab
(package
(name "guile-gitlab")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method git-fetch)
@@ -4810,7 +4810,7 @@ high-level API for network management that uses rtnetlink.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1yq8w507vw9n7f626sbnsk8prsdk337d6acr7f9k3j500lhlvxj5"))))
+ "0srkmchd4kmfa7q65r6fdzwklhgdlck1ll0s7smzs8ddjdgz2lwm"))))
(build-system gnu-build-system)
(arguments
`(#:modules (((guix build guile-build-system)
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmGjxV8ACgkQ6cWi2QiY
oC/S1ggAiAE9qibowdVJ95/5E2dhXp6wn4v9azHfzKE775GeXD6pBCY/htXR23/p
0AdkSjw2e3pPlQtE8DJZ8q0yCedNayU6Bhq3q/WWy0l4MD5W7kzysGXyM1sqdHDx
vdloOOgCvxUMQ7tJzlHIxPPQ3yrvZaw31Wgoy0g1TJcfdmWDxJNmCex0QABZmoX3
FJ6bkCPh0OkloSoElrRFgdeegW/rRM2qZjN/Kw2iwVCzppiyM63agQQlhF41ag/g
SPBqsHeJIjecW7vb7KmIp87N8UReu2rAR7RvG8o/y9AUGGN0cu/k+VtPg12x8rcR
MYFVDmiiaD7Gr9rdWcWZ31Vne0HeLQ==
=C3Y1
-----END PGP SIGNATURE-----

Closed
Mathieu Othacehe wrote 3 years ago
(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)(address . 51998-done@debbugs.gnu.org)
87wnksj735.fsf@gnu.org
Hey,

Toggle quote (4 lines)
> I think I need to investigate the problem further, but for now I fixed
> another bug that lead to 'guile-cli' fails if a user passed non-existing
> command (like "projects" instead of "project".)

Nice, also experienced that issue. Regarding the issue I reported, this
is related to the Guile-Json version. Seems that you are assuming array
data to be represented as vectors whereas with Guile-Json 1 they are
represented as lists.

I took the liberty to switch to guile2.2-json package that uses Guile
Json 4.5.2 and applied your patch.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51998@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51998
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help