[PATCH core-updates-frozen] gnu: xfce-weather-plugin: Fix build by depending on libsoup2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kaelyn Takata
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 18 Nov 2021 22:33
[PATCH] gnu: xfce-weather-plugin: Fix build by depending on libsoup2.
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
EwabuyA7QX05DbWHyHrD2MRVwjkneJVbtUWLvtrsXRE@cp4-web-032.plabs.ch
* gnu/packages/xfce.scm (xfce-weather-plugin)[inputs]: Depend on
libsoup-minimal-2 as the current version only supports libsoup2.
---
gnu/packages/xfce.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c9efdc6efe..91b67d9a0d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2118,7 +2118,7 @@ (define-public xfce4-weather-plugin
("pkg-config" ,pkg-config)))
(inputs
`(("gtk+" ,gtk+)
- ("libsoup" ,libsoup)
+ ("libsoup" ,libsoup-minimal-2)
("libxfce4ui" ,libxfce4ui)
("libxml2" ,libxml2)
("xfce4-panel" ,xfce4-panel)))
--
2.33.1
K
K
Kaelyn wrote on 18 Nov 2021 22:50
(name . 51957@debbugs.gnu.org)(address . 51957@debbugs.gnu.org)
gPry_Mk_-uT-9q0K2oapYgsIe-XLaYRSI4qi-qe3FbCZ1cDeWxraOrLekPlHzaRCxE-RXavzyJ9tDvep7hlU5oizHRShAtWEf6VpT0XGbmE=@protonmail.com
I forgot to update the subject line before sending the email. This patch is based on core-updates-frozen, fixing a build issue I encountered:

checking pkg-config is at least version 0.9.0... yes
checking for libsoup-2.4 >= 2.42.0... not found
*** The required package libsoup-2.4 was not found on your system.
*** Please install libsoup-2.4 (atleast version 2.42.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
error: in phase 'configure': uncaught exception:
%exception #<&invoke-error program: "/gnu/store/vx6vfbmmazvfi7vp8xyjn2mcyylvw9gn-bash-minimal-5.1.8/bin/bash" arguments: ("./configure" "CONFIG_SHELL=/gnu/store/vx6vfbmmazvfi7vp8xyjn2mcyylvw9gn-bash-minimal-5.1.8/bin/bash" "SHELL=/gnu/store/vx6vfbmmazvfi7vp8xyjn2mcyylvw9gn-bash-minimal-5.1.8/bin/bash" "--prefix=/gnu/store/sf3l4yvm4hg2h1778kp10hzhmcbg4axq-xfce4-weather-plugin-0.11.0" "--enable-fast-install" "--build=x86_64-unknown-linux-gnu") exit-status: 1 term-signal: #f stop-signal: #f>
phase `configure' failed after 1.3 seconds
K
K
Kaelyn wrote on 20 Nov 2021 18:18
(name . control@debbugs.gnu.org)(address . control@debbugs.gnu.org)
n0XVi_4etoSVZ6tN86Z_Ljht-u4zZv7bCSk5a8okOO-P4BM-VlIzzfCM5LIndAUubFI6-MdNwKScK26S-wbzSdZ7ipzTicol2pBV5DKrlWU=@protonmail.com
retitle 51957 [PATCH core-updates-frozen] gnu: xfce-weather-plugin: Fix build by depending on libsoup2.
thank you


The patch is relevant only to core-updates-frozen where both libsoup2 and libsoup3 are present (and the variable "libsoup" refers to libsoup3).
R
R
Ricardo Wurmus wrote on 21 Nov 2021 09:05
[PATCH core-updates-frozen] gnu: xfce-weather-plugin: Fix build by depending on libsoup2.
(address . 51957-done@debbugs.gnu.org)
87h7c6gc8u.fsf@elephly.net
Thank you, I applied the patch to core-updates-frozen.

--
Ricardo
Closed
?