[PATCH] On core-updates-frozen, geary is criminally outdated

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 3 years ago
(address . guix-patches@gnu.org)
87h7c99sft.fsf@planete-kraus.eu
Dear guix,

I finally managed to upgrade geary. The latest release lacks the GMime
3.0 vapi, and that’s not something we can generate easily (there’s
custom metadata and custom code), so I had to install it with gmime.

What do you think?

Best regards,

Vivien
From 65c6544aca89c3a8797de22861f06a3f7bb831bf Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Thu, 18 Nov 2021 19:44:03 +0100
Subject: [PATCH 1/2] gnu: gmime: Install the vapi file.

* gnu/packages/mail.scm (gmime)[configure flags]: Build the vapi file.
[native-inputs]: Add vala.
---
gnu/packages/mail.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c92ec14c04..c3be5330f3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -727,13 +727,14 @@ (define-public gmime
(native-inputs
`(("pkg-config" ,pkg-config)
("gnupg" ,gnupg) ; for tests only
- ("gobject-introspection" ,gobject-introspection)))
+ ("gobject-introspection" ,gobject-introspection)
+ ("vala" ,vala)))
(inputs `(("glib" ,glib)
("gpgme" ,gpgme)
("zlib" ,zlib)))
(arguments
`(#:configure-flags
- (list "--enable-introspection=yes")
+ (list "--enable-introspection=yes" "--enable-vapigen=yes")
#:phases
(modify-phases %standard-phases
(add-after
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCAAdFiEEq4yIHjMvkliPpwQnO7C8EjLYuCwFAmGWqMcACgkQO7C8EjLY
uCwcewwAhsWymQQy+qCcysOT8CpeX+lw8bYqrKev0WYesHoeXX2QeevmBlEy+AB1
EKp1AG6C14onC+HOi28Hum6NzixdZ8xeEogA9cuuSbh8vzSf5kAJasAdutTPWYA3
mlYT9V2lUzfRx5+suqLBRaJMRxR3YDCKztdb5S1Q5qu5thTrRCObMcuuJVuXeSZm
VgZ0mfPl5fLErMz3Iz0AMstjwlXilk2t1kNumTfNrj+PHwtCpaImJ+fn9KdNxrnE
Aflpy/enuY+FoRIwqHZazsxUH+YP/sAkCi+1iX9jqetSlr1BlwcvPIHw9TNW+nx/
lv2rjvRZ+zYpPEDcw1WIwhiM/skm02r6S8SexVQlaWSoIo1Sc5MGzrzUV3My7cHs
eQuZrQ7Z9fzzy7x9dSNi6aI5lNrJmpDdKybvDxE7cQJzbWYd+btt1znnenzKyix5
WaDVVQz6IKZMunRUFPuck0i7YvUbQ37VFG3cdZ/kum0GyDmkQujqnDq5zKW7FgNk
Rmein6Eg
=mcFJ
-----END PGP SIGNATURE-----

Vivien Kraus wrote 3 years ago
Re: bug#51956: Acknowledgement ([PATCH] On core-updates-frozen, geary is criminally outdated)
(address . 51956@debbugs.gnu.org)
87czmx9phh.fsf@planete-kraus.eu
If we enable experimental support for gmime 3.0 in pan, we can get rid
of gmime 2.6. Is it worth it?

Vivien
From 11b027d7b34a2ac2e8591d4db2bb9a2d8086024e Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Thu, 18 Nov 2021 19:44:03 +0100
Subject: [PATCH 1/3] gnu: gmime: Install the vapi file.

* gnu/packages/mail.scm (gmime)[configure flags]: Build the vapi file.
[native-inputs]: Add vala.
---
gnu/packages/mail.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c92ec14c04..c3be5330f3 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -727,13 +727,14 @@ (define-public gmime
(native-inputs
`(("pkg-config" ,pkg-config)
("gnupg" ,gnupg) ; for tests only
- ("gobject-introspection" ,gobject-introspection)))
+ ("gobject-introspection" ,gobject-introspection)
+ ("vala" ,vala)))
(inputs `(("glib" ,glib)
("gpgme" ,gpgme)
("zlib" ,zlib)))
(arguments
`(#:configure-flags
- (list "--enable-introspection=yes")
+ (list "--enable-introspection=yes" "--enable-vapigen=yes")
#:phases
(modify-phases %standard-phases
(add-after
--
2.34.0
From 48e6b0dd3bb67e2a62788a5f075f6afecd33db89 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Thu, 18 Nov 2021 21:26:58 +0100
Subject: [PATCH 3/3] gnu: pan: Use gmime 3.0.

* gnu/packages/mail.scm (pan) [configure-flags]: Enable gmime 3.0.
[inputs]: Use gmime 3.0.
* gnu/packages/mail.scm (gmime-2.6): Remove it.
---
gnu/packages/mail.scm | 17 ++---------------
1 file changed, 2 insertions(+), 15 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c3be5330f3..53ee69ae0f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -760,20 +760,6 @@ (define-public gmime
Extension (MIME).")
(license (list license:lgpl2.1+ license:gpl2+ license:gpl3+))))
-;; Some packages are not ready for GMime 3 yet.
-(define-public gmime-2.6
- (package
- (inherit gmime)
- (version "2.6.23")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/gmime/"
- (version-major+minor version)
- "/gmime-" version ".tar.xz"))
- (sha256
- (base32
- "0slzlzcr3h8jikpz5a5amqd0csqh2m40gdk910ws2hnaf5m6hjbi"))))))
-
(define-public altermime
(package
(name "altermime")
@@ -3875,6 +3861,7 @@ (define-public pan
(base32 "0960siaf0r6m18kv0d8aqpf36x2xbsfcvk07kswlany7jbxrhylr"))))
(arguments
`(#:configure-flags '("--with-gtk3" "--with-gtkspell" "--with-gnutls"
+ "--with-gmime30"
"--enable-libnotify" "--enable-manual"
"--enable-gkr")
#:phases
@@ -3887,7 +3874,7 @@ (define-public pan
"/bin/gpg\"")))
#t)))))
(inputs
- `(("gmime" ,gmime-2.6)
+ `(("gmime" ,gmime)
("gnupg" ,gnupg)
("gnutls" ,gnutls)
("gtk+" ,gtk+)
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCAAdFiEEq4yIHjMvkliPpwQnO7C8EjLYuCwFAmGWt7oACgkQO7C8EjLY
uCx8Zgv/WWxbfS+3EVhGKNCpgThj/HxSyZDi9ydGBJsVtXF2zvz1yC4nHTbwDt4X
F7/nVKS4qYpGSal9Jyt+WLQrB84THdwgsEcUeFjO1a/aFRy/43izBLSQUIrnw+8b
R86RxknEzs6OOvPAkRPnCJu1cZ9BQOVI95gMXj8CQqazacZa1mcXYGZsoscqtKxC
rKfqY7y0QjRsuYCtMPOxlIcQN1bTBm3aJ/gF1Fm7hipd3ejMkyZpctVn2UXP6mRq
dPzMAUsjebtEZtYzzlFTgG6NvIjvLD8dn51L3CuUwy7tn5fzfehCBTnP3jujB05w
cljWTvQzjKbn+an0xdkBR0Bxhh67Hrl9O2QPVPixUJiUwXZ5md56/+O54vySuSSk
ITf6fM/3VleDrvKfw1JoUvvmjIWzUp5QTZLuvtuB69jJFLDsvaVLArccE791NEvS
3+K6+dD4VSpa6OE0RuWpKCUgMI261OP5gQ9M5bDXYxaeNPyvw+Gjdr2ivNXGZlu5
QNsAaxZ/
=JHdE
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
Re: bug#51956: [PATCH] On core-updates-frozen, geary is criminally outdated
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 51956-done@debbugs.gnu.org)
87r1bcl1sv.fsf@gnu.org
Hi!

Vivien Kraus <vivien@planete-kraus.eu> skribis:

Toggle quote (6 lines)
> I finally managed to upgrade geary. The latest release lacks the GMime
> 3.0 vapi, and that’s not something we can generate easily (there’s
> custom metadata and custom code), so I had to install it with gmime.
>
> What do you think?

No strong opinion, LGTM.

Toggle quote (8 lines)
> From 65c6544aca89c3a8797de22861f06a3f7bb831bf Mon Sep 17 00:00:00 2001
> From: Vivien Kraus <vivien@planete-kraus.eu>
> Date: Thu, 18 Nov 2021 19:44:03 +0100
> Subject: [PATCH 1/2] gnu: gmime: Install the vapi file.
>
> * gnu/packages/mail.scm (gmime)[configure flags]: Build the vapi file.
> [native-inputs]: Add vala.

[...]

Toggle quote (7 lines)
> From cf80e70f47532fa5057755b6e08cc6ea1a346a1f Mon Sep 17 00:00:00 2001
> From: Vivien Kraus <vivien@planete-kraus.eu>
> Date: Wed, 10 Nov 2021 20:18:46 +0000
> Subject: [PATCH 2/2] gnu: geary: Upgrade to 40.0
>
> * gnu/packages/gnome.scm (geary): Upgrade to 40.0.

Applied!

Let’s discuss the possibility of getting rid of gmime 2.6 separately.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51956@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51956
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help