[PATCH] gnu: Add cl-binascii.

  • Done
  • quality assurance status badge
Details
3 participants
  • Foo Chuan Wei
  • Guillaume Le Vaillant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 17 Nov 2021 06:40
(address . guix-patches@gnu.org)
PU1PR01MB21552C6186FA4DD41C92E7428D9A9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/lisp-xyz.scm (cl-binascii, ecl-binascii, sbcl-binascii):
New variables.
---
gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 4b17c173c9..39325d2f6b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17879,6 +17879,40 @@ RSS feeds data via HTTP. Currently, it supports RSS versions 0.90,
(define-public cl-rss
(sbcl-package->cl-source-package sbcl-rss))
+(define-public sbcl-binascii
+ (let ((commit "0fb0a9e5773148fd04d50efef08c1cc10f6fc487")
+ (revision "1"))
+ (package
+ (name "sbcl-binascii")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/froydnj/binascii")
+ (commit commit)))
+ (file-name (git-file-name "cl-binascii" version))
+ (sha256
+ (base32 "000rcdl8qshr7n48zq9bzrc4lkjx4ylb3r3w9x9syhiwfla9j4b7"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/froydnj/binascii")
+ (synopsis "Common Lisp library of ASCII encoding schemes for binary data")
+ (description
+ "@code{binascii} is a Common Lisp library for converting binary data
+to ASCII text of some kind. Such conversions are common in email protocols
+(for encoding attachments to support old non-8-bit clean transports) or
+encoding binary data in HTTP and XML applications. @code{binascii} supports
+the encodings described in RFC 4648: base64, base32, base16, and variants.
+It also supports base85, used in Adobe's PostScript and PDF document formats,
+and a variant called ascii85, used by git for binary diff files.")
+ (license license:bsd-3))))
+
+(define-public cl-binascii
+ (sbcl-package->cl-source-package sbcl-binascii))
+
+(define-public ecl-binascii
+ (sbcl-package->ecl-package sbcl-binascii))
+
(define-public sbcl-trivial-with-current-source-form
(let ((commit "9e343e043a77a5478c1f77bb626db22335fbbfb8")
(revision "1"))

base-commit: 02a67810e566e8402e0b927c81ae39391762767d
--
2.25.1
F
F
Foo Chuan Wei wrote on 18 Nov 2021 07:04
(address . 51913@debbugs.gnu.org)
PU1PR01MB21559F014C3BB2F0B27DB9368D9B9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
There are a few problems with this patch:
* Tests are failing on ECL.
* It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
instead).
G
G
Guillaume Le Vaillant wrote on 20 Nov 2021 15:02
Re: [bug#51913] [PATCH] gnu: Add cl-binascii.
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51913@debbugs.gnu.org)
8735nq9axm.fsf@kitej
Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (5 lines)
> There are a few problems with this patch:
> * Tests are failing on ECL.
> * It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
> instead).

Concerning rt, I thing adding a snippet deleting "tests/rt.lisp" and
modifying the definition of "binascii-tests" in "binascii.asd" (removing
the references to the rt file and adding the rt system in the
"depends-on" list) should work.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYZkBZQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9LhAD8DaGxaBW8I2Kwq6LgkfCY0bqzGa64mrKwflsg
A1KrCxcBAJkHeLbcHqplaKYpS5sz8v+LcjV9pdFagB/bwLKGzhiq
=04FU
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 10 Dec 2021 15:20
Re: bug#51913: [PATCH] gnu: Add cl-binascii.
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
877dcc8rtr.fsf_-_@gnu.org
Ping! :-)

Guillaume Le Vaillant <glv@posteo.net> skribis:

Toggle quote (11 lines)
> Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:
>
>> There are a few problems with this patch:
>> * Tests are failing on ECL.
>> * It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
>> instead).
>
> Concerning rt, I thing adding a snippet deleting "tests/rt.lisp" and
> modifying the definition of "binascii-tests" in "binascii.asd" (removing
> the references to the rt file and adding the rt system in the
> "depends-on" list) should work.
G
G
Guillaume Le Vaillant wrote on 5 Sep 2022 14:09
(address . 51913-done@debbugs.gnu.org)
87tu5m9g09.fsf@kitej
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (16 lines)
> Ping! :-)
>
> Guillaume Le Vaillant <glv@posteo.net> skribis:
>
>> Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:
>>
>>> There are a few problems with this patch:
>>> * Tests are failing on ECL.
>>> * It bundles rt.lisp, which should be unbundled (use Guix's cl-rt
>>> instead).
>>
>> Concerning rt, I thing adding a snippet deleting "tests/rt.lisp" and
>> modifying the definition of "binascii-tests" in "binascii.asd" (removing
>> the references to the rt file and adding the rt system in the
>> "depends-on" list) should work.

I unbundled RT and pushed as 0f88acb9fa8f7bbdfb2a647907fe63b1974ab824
without the ecl-binascii variant, as it looks like the library doesn't
work with ECL.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYxXntg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8XPgD9Fy81y8UFoSx70DC5JYdPWextqkmXihU3OvlH
mDJNx7AA/2PlNlRM6aztmH2A3AojoJS2HqGOKfWYZMZrWMbJHBnE
=WMlE
-----END PGP SIGNATURE-----

Closed
?