[PATCH] Devhelp: On core-updates-frozen, upgrade to 41.2 to use webkit2 4.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 3 years ago
(address . bug-guix@gnu.org)
87mtm8jq4h.fsf@planete-kraus.eu
Dear guix,

devhelp 41 gained support for building against webkit2 4.1. I think we
should upgrade, right?

Vivien
From fadbf75a7667cfb9e2a25024913373a53310d06c Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Sat, 13 Nov 2021 10:35:26 +0000
Subject: [PATCH] gnu: devhelp: Upgrade to 41.2.

* gnu/packages/gnome.scm (devhelp): Upgrade to 41.2 to upgrade the webkit
dependency to 4.1.
* gnu/packages/gnome.scm (devhelp) [arguments]: Use meson 0.59.
* gnu/packages/gnome.scm (devhelp) [phase skip-gtk-update-icon-cache]: the
post install script has been moved from meson_post_install.py to
build-aux/meson/.
* gnu/packages/gnome.scm (devhelp) [phase fix-devhelp-gir-inputs]: the devhelp
GIR still mentions webkit 4.0, use 4.1 instead.
---
gnu/packages/gnome.scm | 16 +++++++++++-----
1 file changed, 11 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d097495b1e..3f1eada0c0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5775,7 +5775,7 @@ (define-public amtk
(define-public devhelp
(package
(name "devhelp")
- (version "40.1")
+ (version "41.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5783,17 +5783,23 @@ (define-public devhelp
name "-" version ".tar.xz"))
(sha256
(base32
- "1fvb69l1nyxdrs95ar95rmpfs8nfkpys4x74r8ilid44hhzdk2iy"))))
+ "1lk0gycjvs6gibhy0zs3ffkrkzrkyl5nkp7n60hgpa6syjq91apc"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
+ #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true")))))))
+ (substitute* "build-aux/meson/meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))))
+ (add-after 'unpack 'fix-devhelp-gir-inputs
+ ;; It still mentions webkitgtk 4.0
+ (lambda _
+ (substitute* "devhelp/meson.build"
+ (("'WebKit2-4.0'") "'WebKit2-4.1'")))))))
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)
--
2.33.1
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCAAdFiEEq4yIHjMvkliPpwQnO7C8EjLYuCwFAmGPlf4ACgkQO7C8EjLY
uCyyOAv+JOjCWQPCbKWop1twDAxAIMqRwKek3dBEsbvESGui+5pgmWJ8+d3SfCih
Jy4OhHbJuTJ+43GWt4YWRKuGuEAKv+oUJQYZCeaWTnkx23/2mMxVjs4kEYcKMQ0r
I1EE1ANk9LSLc5JO67SjbYbv66THrCHz+KrQX1JlCcSq3MiuDRyduXXqEYVo+wk5
kF3879J6MdCKS8+e7u0EmK9Q5mAlED1WBA7ek4dMfpQX+C62d7ubzTOuneFn/ISP
j9bm2EGKrdRLRVwPmEcSz1fXD2BFUq5DZQ9Y1KJySkZBw00A8eS/DxxJOv9Q4mNR
dweFA9+We5VY2WXP4khaknbpVHGJbQVXxFeeBaGLzB8D0zYiyuvlhbiHwdRN4SS/
SM5JTP8VqODCyOfVOFx71U2BqerQQHGIG8Vzlz6U2Opz1dDZBuRBn+3A8huaEhbq
xATw8hWM6A/LKvb042Er401NgSegw8d5uyPCZEG9eFdoU0x8hVjmwu9oxW2U+paj
aD+DoPPX
=vjFm
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 3 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 51808-done@debbugs.gnu.org)
87pmr1653e.fsf@gnu.org
Vivien Kraus <vivien@planete-kraus.eu> skribis:

Toggle quote (17 lines)
> From fadbf75a7667cfb9e2a25024913373a53310d06c Mon Sep 17 00:00:00 2001
> From: Vivien Kraus <vivien@planete-kraus.eu>
> Date: Sat, 13 Nov 2021 10:35:26 +0000
> Subject: [PATCH] gnu: devhelp: Upgrade to 41.2.
>
> * gnu/packages/gnome.scm (devhelp): Upgrade to 41.2 to upgrade the webkit
> dependency to 4.1.
> * gnu/packages/gnome.scm (devhelp) [arguments]: Use meson 0.59.
> * gnu/packages/gnome.scm (devhelp) [phase skip-gtk-update-icon-cache]: the
> post install script has been moved from meson_post_install.py to
> build-aux/meson/.
> * gnu/packages/gnome.scm (devhelp) [phase fix-devhelp-gir-inputs]: the devhelp
> GIR still mentions webkit 4.0, use 4.1 instead.
> ---
> gnu/packages/gnome.scm | 16 +++++++++++-----
> 1 file changed, 11 insertions(+), 5 deletions(-)

I tweaked the commit log and applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51808@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51808
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help