[PATCH] Add phonesim 1.21

  • Done
  • quality assurance status badge
Details
4 participants
  • Demis Balbach
  • Josselin Poiret
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Demis Balbach
Severity
normal

Debbugs page

Demis Balbach wrote 3 years ago
(address . guix-patches@gnu.org)(name . Demis Balbach)(address . db@minikn.xyz)
20211111221457.6025-1-db@minikn.xyz
---
gnu/packages/telephony.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a2765ee99f..77914fb4d7 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,6 +95,35 @@ (define-module (gnu packages telephony)
#:use-module (guix build-system gnu)
#:use-module (guix build-system qt))
+(define-public phonesim
+ (package
+ (name "phonesim")
+ (version "1.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+ (commit "a7c844d45b047b2dae5b0877816c346fce4c47b9")))
+ (sha256
+ (base32
+ "0rc1c2vr03dmi1dr3skj57v77ga9c22g29xs1qiphqms4isby9cq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-maintainer-mode"
+ "CC=gcc")))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase-5)
+ ("qtdeclarative" ,qtdeclarative)))
+ (synopsis "Phone Simulator for modem testing")
+ (description "Phone Simulator for modem testing")
+ (home-page "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+ (license license:gpl2+)))
+
(define-public libilbc
(package
(name "libilbc")
--
2.33.0
Tobias Geerinckx-Rice wrote 3 years ago
(name . Demis Balbach)(address . db@minikn.xyz)(address . 51779@debbugs.gnu.org)
edb6cf8cfa247f21082c2ed48e62aea1@tobias.gr
Demis,

Thanks for the patch! Here are a few low-hanging thoughts (not a full
review):

Check the git log for commits adding new packages for the expected
'change-log-style' commit message.

On 2021-11-11 23:14, Demis Balbach wrote:
Toggle quote (3 lines)
> + `(#:configure-flags
> + (list "--enable-maintainer-mode"

This is unusual enough to require a comment explaining why it's here.

Toggle quote (2 lines)
> + "CC=gcc")))

This breaks cross-compilation: the cross GCC is called something like
'x86_64-blah-bloo-gcc', not 'gcc'. There's a helper in (guix utils)
IIRC that returns the right cc for the target:

(string-append "CC=" ,(cc-for-target))

Toggle quote (2 lines)
> + (description "Phone Simulator for modem testing")

This should be at least several lines of complete sentences ("Phonesim
simulates blah...").

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
db wrote 3 years ago
[PATCH] Add phonesim 1.21
(address . 51779@debbugs.gnu.org)
006401d7d7fa$27f236e0$77d6a4a0$@minikn.xyz
Hello Tobias,

thank you for your input. This is my first attempt at submitting a patch
through a mailing list. I expected some mistakes. On top of that, my
guile is bad as well (I'm just starting with it).

Toggle quote (3 lines)
> Check the git log for commits adding new packages for the expected
> 'change-log-style' commit message.

Thanks. I think it should have been `[PATCH] gnu: Add phonesim'. How can
I change that?

Toggle quote (2 lines)
> This is unusual enough to require a comment explaining why it's here.

The short answer is - I don't know. I copied it from the source:

figure

I should also mention that I do not have any experience with the
application. I never used it nor do I really understand what it does. I
just submitted a patch because it is part of what needs to be done in
order to get bluetooth headsets fully working in Guix (with microphone),
see

eAudio

This is beside the point, but I'm mentioning it to give a little
background why I may not be able to give insight on why things are done
a certain way.

That being said, here is the new patch version:

---
gnu/packages/telephony.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a2765ee99f..6e3c69ce91 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -20,6 +20,7 @@
;;; Copyright C 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright C 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright C 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright C 2021 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,6 +88,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -94,6 +96,37 @@ (define-module (gnu packages telephony)
#:use-module (guix build-system gnu)
#:use-module (guix build-system qt))

+(define-public phonesim
+ (package
+ (name "phonesim")
+ (version "1.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
"https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+ (commit "a7c844d45b047b2dae5b0877816c346fce4c47b9")))
+ (sha256
+ (base32
+ "0rc1c2vr03dmi1dr3skj57v77ga9c22g29xs1qiphqms4isby9cq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-maintainer-mode"
+ "CC=" ,(cc-for-target))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase-5)
+ ("qtdeclarative" ,qtdeclarative)))
+ (synopsis "Phone Simulator for modem testing")
+ (description "Phonesim is a modem emulator that oFono uses for
development
+and testing. This allows oFono to be used by any host without requiring
special
+GSM (or other) hardware.")
+ (home-page "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+ (license license:gpl2+)))
+
(define-public libilbc
(package
(name "libilbc")
--
2.33.0

Greetings,

Demis.
Josselin Poiret wrote 3 years ago
(address . dev@jpoiret.xyz)
87r1bk9xxl.fsf@jpoiret.xyz
Hello Demis,

About the ChangeLog style, it is documented at [1], and it mostly
concerns the contents of the commit message. In the case of this patch,
I think it should be

Toggle snippet (5 lines)
gnu: Add phonesim.

* gnu/packages/telephony.scm (phonesim): Add new variable.

You can take a look at the complete commit messages in the git log to
get a feel for what needs to be included in them.

As for the patch, it looks good to me, but I'm no expert yet. Glad to
see your first contribution though!


Best,
Josselin Poiret
Demis Balbach wrote 3 years ago
[PATCH] Add phonesim 1.21
(address . 51779@debbugs.gnu.org)
87lf1era4g.fsf@minikn.xyz
Toggle quote (3 lines)
> You can take a look at the complete commit messages in the git log to
> get a feel for what needs to be included in them.

Thank you Josselin.

I'm still quite unfamiliar with patches through mailing lists: Do I have
to change anything in this patch for it to get merged, or should I just
keep the naming convention in mind for future patches?

Greetings,

Demis.
Demis Balbach wrote 3 years ago
(address . 51779@debbugs.gnu.org)
87ilwibt2e.fsf@minikn.xyz
This is the new patch after changing the commit message.

* gnu/packages/telephony.scm (phonesim): Add new variable.
---
gnu/packages/telephony.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a2765ee99f..6e3c69ce91 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,6 +88,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -94,6 +96,37 @@ (define-module (gnu packages telephony)
#:use-module (guix build-system gnu)
#:use-module (guix build-system qt))

+(define-public phonesim
+ (package
+ (name "phonesim")
+ (version "1.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+ (commit "a7c844d45b047b2dae5b0877816c346fce4c47b9")))
+ (sha256
+ (base32
+ "0rc1c2vr03dmi1dr3skj57v77ga9c22g29xs1qiphqms4isby9cq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-maintainer-mode"
+ "CC=" ,(cc-for-target))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase-5)
+ ("qtdeclarative" ,qtdeclarative)))
+ (synopsis "Phone Simulator for modem testing")
+ (description "Phonesim is a modem emulator that oFono uses for development
+and testing. This allows oFono to be used by any host without requiring special
+GSM (or other) hardware.")
+ (home-page "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+ (license license:gpl2+)))
+
(define-public libilbc
(package
(name "libilbc")
--
2.34.0

Cheers,

Demis.
Nicolas Goaziou wrote 3 years ago
(name . Demis Balbach)(address . db@minikn.xyz)(address . 51779-done@debbugs.gnu.org)
87ilw2ahxf.fsf@nicolasgoaziou.fr
Hello,

Demis Balbach <db@minikn.xyz> writes:

Toggle quote (2 lines)
> * gnu/packages/telephony.scm (phonesim): Add new variable.

I fixed the commit message and applied your patch. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51779@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51779
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help