(name . Guix Patches)(address . guix-patches@gnu.org)
Hi,
this patch should add support for waydroid which requires certain options in the kernel enabled.
In order to enable the features the lambda-match has to be extended to support numbers and strings.
However, the kernel compiles and I can reconfigure the system, + reboot. But I do not see /dev/binder device. Details are in the last mail.
Petr
* gnu/packages/linux.scm: Match numbers and strings in options.
Toggle diff (17 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f386139638..ffbaed0c57 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -729,7 +729,11 @@ (define (config->string options)
((option . #t)
(string-append option "=y"))
((option . #f)
- (string-append option "=n")))
+ (string-append option "=n"))
+ ((option . number)
+ (string-append option "=" number))
+ ((option . string)
+ (string-append option "=\"" string "\"")))
options)
"\n"))
--
2.33.0