[PATCH v2 1/2] gnu: Add emacs-plz.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 10 Nov 2021 14:21
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
JJ0i2LE3-mBE-5_rLHQdGeGr4MKKfENoxZo4liQnRDWs84_gpIMEKt9sv2wjOaCB-rwW6k8qzfto6Azn_5cUdM4skusa5xLIikCRkFiMmXk=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-plz): New variable.

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c87c8694d..88f0dd7f2f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15072,6 +15072,31 @@ (define-public emacs-emamux
multiplexer.")
(license license:gpl3+)))

+(define-public emacs-plz
+ (let ((commit "7e456638a651bab3a814e3ea81742dd917509cbb")
+ (revision "1"))
+ (package
+ (name "emacs-plz")
+ (version (git-version "0.1-pre" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/plz.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
+ (build-system emacs-build-system)
+ (inputs `(("curl" ,curl)))
+ (home-page "https://github.com/alphapapa/plz.el")
+ (synopsis "HTTP library for Emacs")
+ (description "This package provides HTTP library for Emacs. It uses curl
+as a backend, which avoids some of the issues with using Emacs’s built-in
+url library.")
+ (license license:gpl3+))))
+
(define-public emacs-rpm-spec-mode
(package
(name "emacs-rpm-spec-mode")
--
2.33.1
N
N
Nicolas Goaziou wrote on 10 Nov 2021 15:00
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87czn8kt4n.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-plz): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51750@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51750
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch