[PATCH]: gnu: nix: Update to 2.4.
(address . guix-patches@gnu.org)
-----BEGIN PGP SIGNATURE-----
iIsEARYIADMWIQTUepyLKuOQW1Y9kTW+QrNSqfaCHwUCYYu8yRUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQvkKzUqn2gh+VNQD+Mrga/R7+dhV1gEPnF4VhRZgqYG4S
th6FkmqX+k2AqjUA/iBREkIaRWxSrDXMtsPfhMGIPSerKQmQN6J3hl6Z+z8L
=F8Cz
-----END PGP SIGNATURE-----
From 935afdd36fee52fe3930991245ac67e48c0a00ff Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Wed, 10 Nov 2021 19:21:45 +0800
Subject: [PATCH 1/3] gnu: Add lowdown.
* gnu/packages/markup.scm(lowdown): New variables.
---
gnu/packages/markup.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (58 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 368976bfde..4ec606f892 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@ (define-module (gnu packages markup)
#:use-module (guix utils)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -324,3 +326,35 @@ (define-public python-mistletoe
swap out renderers for different output formats, without touching any of the
core components.")
(license expat)))
+
+(define-public lowdown
+ (package
+ (name "lowdown")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "15v2kk4ffqw3n6y6n9plch4qcib3ynnhw0ih8wn2v9qgn4jssp5p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;No test
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "./configure"
+ (string-append "PREFIX=" out)
+ (string-append "MANDIR=" out "/share/man"))))))
+ ;; the shared library of nix is linked with lowdown.
+ #:make-flags '("CFLAGS=-fPIC")))
+ (native-inputs
+ `(("which" ,which)))
+ (home-page "https://kristaps.bsd.lv/lowdown")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
+roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license isc)))
--
2.33.1
From d38e131913a006d47d611ce6ebabfb1823d804b8 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Wed, 10 Nov 2021 19:31:28 +0800
Subject: [PATCH 2/3] gnu: Add libcpuid.
gnu/packages/hardware.scm(libcpuid): New variable.
---
gnu/packages/hardware.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 2bf3576d5a..df7fb4b716 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -834,3 +835,22 @@ (define-public tpm2-tss
libtss2-esys, libtss2-sys, libtss2-mu, libtss2-tcti-device, libtss2-tcti-swtpm
and libtss2-tcti-mssim.")
(license license:bsd-2)))
+
+(define-public libcpuid
+ (package
+ (name "libcpuid")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/anrieff/libcpuid/releases/download/v"
+ version "/libcpuid-" version ".tar.gz"))
+ (sha256
+ (base32 "1nksdqk2w1c56lkrjcvh3nss9vq454j81j3yq14lwdn4x8bvmwfr"))))
+ (build-system gnu-build-system)
+ (supported-systems '("x86_64-linux" "i686-linux"))
+ (home-page "https://libcpuid.sourceforge.net/")
+ (synopsis "A small library for x86 CPU detection and feature extraction")
+ (description "Libcpuid is a small C library to get vendor, model, branding
+string, code name and other information from x86 CPU.")
+ (license license:bsd-2)))
--
2.33.1
--
Retrieve my PGP public key:
gpg --recv-keys D47A9C8B2AE3905B563D9135BE42B352A9F6821F
Zihao