(name . Guix Patches)(address . guix-patches@gnu.org)
Hi,
here's a set of 2 patches to add Matrix client support to Emacs.
However, there is one warning about images:
Warning (ement): This Emacs was not built with ImageMagick support, nor does it support Cairo/XRender scaling, so images can't be displayed in Ement
Emacs inputs don't list imagemagick. However, it's deleted from a list in emacs-no-x.
So should we patch Emacs as the magickimage is missing by mistake or is there a reason?
Petr
* gnu/packages/emacs-xyz.scm (emacs-plz): Add variable.
---8<--------cut here------------------<8---
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 543ce6303a..c7e5c05030 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15033,6 +15033,31 @@ (define-public emacs-emamux
multiplexer.")
(license license:gpl3+)))
+(define-public emacs-plz
+ (let ((commit "7e456638a651bab3a814e3ea81742dd917509cbb")
+ (revision "1"))
+ (package
+ (name "emacs-plz")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/plz.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
+ (build-system emacs-build-system)
+ (inputs `(("curl" ,curl)))
+ (home-page "https://github.com/alphapapa/plz.el")
+ (synopsis "HTTP library for Emacs")
+ (description "This package provides HTTP library for Emacs. It uses curl
+as a backend, which avoids some of the issues with using Emacs’s built-in
+url.")
+ (license license:gpl3+))))
+
(define-public emacs-rpm-spec-mode
(package
(name "emacs-rpm-spec-mode")
--
2.33.1