[PATCH 1/2] gnu: Add emacs-plz.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 8 Nov 2021 12:11
(name . Guix Patches)(address . guix-patches@gnu.org)
OcKRlfxfxnbSKU5afQU3l0_4SkILPtrd0ed5RktBJBRMVKIUB2UDPT0uMVLp_uZJgZ_saQf3t0bfoK73E6ciOOi1oWQVQZKDO1PCQrxa-lw=@protonmail.com
Hi,

here's a set of 2 patches to add Matrix client support to Emacs.

However, there is one warning about images:

Warning (ement): This Emacs was not built with ImageMagick support, nor does it support Cairo/XRender scaling, so images can't be displayed in Ement

Emacs inputs don't list imagemagick. However, it's deleted from a list in emacs-no-x.

So should we patch Emacs as the magickimage is missing by mistake or is there a reason?

Petr

* gnu/packages/emacs-xyz.scm (emacs-plz): Add variable.

---8<--------cut here------------------<8---
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 543ce6303a..c7e5c05030 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15033,6 +15033,31 @@ (define-public emacs-emamux
multiplexer.")
(license license:gpl3+)))

+(define-public emacs-plz
+ (let ((commit "7e456638a651bab3a814e3ea81742dd917509cbb")
+ (revision "1"))
+ (package
+ (name "emacs-plz")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/plz.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
+ (build-system emacs-build-system)
+ (inputs `(("curl" ,curl)))
+ (home-page "https://github.com/alphapapa/plz.el")
+ (synopsis "HTTP library for Emacs")
+ (description "This package provides HTTP library for Emacs. It uses curl
+as a backend, which avoids some of the issues with using Emacs’s built-in
+url.")
+ (license license:gpl3+))))
+
(define-public emacs-rpm-spec-mode
(package
(name "emacs-rpm-spec-mode")
--
2.33.1
P
P
phodina wrote on 8 Nov 2021 12:21
[PATCH 2/2] gnu: Add emacs-ement.
(address . 51686@debbugs.gnu.org)
4PNcLrGXgFsnKlyZOtGbsfjNSaC4clL8pq7tozK4DiUThLer7ZeGtD1HHAi4rimaLpcM2eJjF9NPBNfKKw9aAuC2UZtyaApF5aaoy71DOpA=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-ement): Add variable.

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7e5c05030..c772e86748 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15058,6 +15058,31 @@ (define-public emacs-plz
url.")
(license license:gpl3+))))

+(define-public emacs-ement
+ (let ((commit "c951737dc855604aba389166bb0e7366afadc533")
+ (revision "1"))
+ (package
+ (name "emacs-ement")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/ement.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00iwwz4hzg4g59wrb5df6snqz3ppvrsadhfp61w1pa8gvg2z9bvy"))))
+ (build-system emacs-build-system)
+ (inputs `(("emacs-plz" ,emacs-plz)
+ ("emacs-ts" ,emacs-ts)))
+ (home-page "https://github.com/alphapapa/ement.el")
+ (synopsis "Matrix client for Emacs")
+ (description "This package provides simple, fast, featureful and
+reliable Matrix client for Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-rpm-spec-mode
(package
(name "emacs-rpm-spec-mode")
--
2.33.1
N
N
Nicolas Goaziou wrote on 8 Nov 2021 12:27
Re: [bug#51686] [PATCH 1/2] gnu: Add emacs-plz.
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87r1bqnayz.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> here's a set of 2 patches to add Matrix client support to Emacs.

Thank you.

Toggle quote (9 lines)
> However, there is one warning about images:
>
> Warning (ement): This Emacs was not built with ImageMagick support, nor does it support Cairo/XRender scaling, so images can't be displayed in Ement
>
> Emacs inputs don't list imagemagick. However, it's deleted from a list in emacs-no-x.
>
> So should we patch Emacs as the magickimage is missing by mistake or
> is there a reason?

You need to provide a different emacs package to build it, using keyword
#:emacs. See, e.g., emacs-auctex definiton.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 8 Nov 2021 12:30
Re: [bug#51686] [PATCH 2/2] gnu: Add emacs-ement.
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87mtmenau5.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> + (package
> + (name "emacs-ement")
> + (version (git-version "0.0" revision commit))

Version keyword from ement.el mentions "0.1-pre" as the version. It
should be a better fit than "0.0".

Toggle quote (18 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/alphapapa/ement.el")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "00iwwz4hzg4g59wrb5df6snqz3ppvrsadhfp61w1pa8gvg2z9bvy"))))
> + (build-system emacs-build-system)
> + (inputs `(("emacs-plz" ,emacs-plz)
> + ("emacs-ts" ,emacs-ts)))
> + (home-page "https://github.com/alphapapa/ement.el")
> + (synopsis "Matrix client for Emacs")
> + (description "This package provides simple, fast, featureful and
> +reliable Matrix client for Emacs.")

simple + fast + featureful + reliable sounds like buzzwords to me.
I suggest to use:

Ement.el is a Matrix client for Emacs.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 8 Nov 2021 12:31
Re: [bug#51686] [PATCH 1/2] gnu: Add emacs-plz.
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87ilx2nasa.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> + (package
> + (name "emacs-plz")
> + (version (git-version "0.0" revision commit))

This should be "0.1-pre", not "0.0"

Toggle quote (18 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/alphapapa/plz.el")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
> + (build-system emacs-build-system)
> + (inputs `(("curl" ,curl)))
> + (home-page "https://github.com/alphapapa/plz.el")
> + (synopsis "HTTP library for Emacs")
> + (description "This package provides HTTP library for Emacs. It uses curl
> +as a backend, which avoids some of the issues with using Emacs’s built-in
> +url.")

Nitpick: I would add "... built-in url library."

Regards,
--
Nicolas Goaziou
P
P
phodina wrote on 10 Nov 2021 14:21
[PATCH v2 1/2] gnu: Add emacs-plz.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
JJ0i2LE3-mBE-5_rLHQdGeGr4MKKfENoxZo4liQnRDWs84_gpIMEKt9sv2wjOaCB-rwW6k8qzfto6Azn_5cUdM4skusa5xLIikCRkFiMmXk=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-plz): New variable.

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c87c8694d..88f0dd7f2f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15072,6 +15072,31 @@ (define-public emacs-emamux
multiplexer.")
(license license:gpl3+)))

+(define-public emacs-plz
+ (let ((commit "7e456638a651bab3a814e3ea81742dd917509cbb")
+ (revision "1"))
+ (package
+ (name "emacs-plz")
+ (version (git-version "0.1-pre" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/plz.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
+ (build-system emacs-build-system)
+ (inputs `(("curl" ,curl)))
+ (home-page "https://github.com/alphapapa/plz.el")
+ (synopsis "HTTP library for Emacs")
+ (description "This package provides HTTP library for Emacs. It uses curl
+as a backend, which avoids some of the issues with using Emacs’s built-in
+url library.")
+ (license license:gpl3+))))
+
(define-public emacs-rpm-spec-mode
(package
(name "emacs-rpm-spec-mode")
--
2.33.1
P
P
phodina wrote on 10 Nov 2021 14:21
[PATCH v2 2/2] gnu: Add emacs-ement.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
qyZe05ytNPs1B0w86F2aXNYNisTsVieZmvFZAj2WxGiA8BZ3KREWVN6tQC99rTK487IvfjVqrgjzcjwckL9MlERhi-39YVStROCEhH_AY_U=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-ement): New variable.

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 88f0dd7f2f..97c7ce8c1d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15097,6 +15097,32 @@ (define-public emacs-plz
url library.")
(license license:gpl3+))))

+(define-public emacs-ement
+ (let ((commit "c951737dc855604aba389166bb0e7366afadc533")
+ (revision "1"))
+ (package
+ (name "emacs-ement")
+ (version (git-version "0.1-pre" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/ement.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00iwwz4hzg4g59wrb5df6snqz3ppvrsadhfp61w1pa8gvg2z9bvy"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:emacs ,emacs))
+ (inputs `(("emacs-plz" ,emacs-plz)
+ ("emacs-ts" ,emacs-ts)))
+ (home-page "https://github.com/alphapapa/ement.el")
+ (synopsis "Matrix client for Emacs")
+ (description "Ement.el is a Matrix client for Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-rpm-spec-mode
(package
(name "emacs-rpm-spec-mode")
--
2.33.1
P
P
phodina wrote on 10 Nov 2021 14:23
[bug#51686] Feedback
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
44V3t5Zme84s2b6LvxihVgmDATMUcjLwRyzs5Ytn1U_DNrOhFoDVNCOaRLQ-Kkv7knSBL8lyWdutxRrUijeIRqo541xiBSuv04wFwxZIoAk=@protonmail.com
Hi Nicolas,

thanks for you're feedback :-)

--
Kind regards
Petr
N
N
Nicolas Goaziou wrote on 10 Nov 2021 15:00
Re: [bug#51750] [PATCH v2 1/2] gnu: Add emacs-plz.
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87czn8kt4n.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-plz): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 10 Nov 2021 15:00
Re: [bug#51686] [PATCH v2 2/2] gnu: Add emacs-ement.
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
878rxwkt44.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ement): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51686@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51686
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch