[PATCH]: gnu: Add cl-kaput

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5rqEZmNRDFN1kca-eWTWRfqdSxM37FvcR=K1m-KXZysww@mail.gmail.com
successfully built
/gnu/store/jyh8iflsyvifwf79clia00vsszgrn4pj-cl-kaputt-0.0.0-1.f26c9b0.drv
/gnu/store/zyzqfp6irid5qc187fw24i42gxk8cbl5-ecl-kaputt-0.0.0-1.f26c9b0
/gnu/store/qxi423lsgyd6xjb1hrjvj36pas158jjx-cl-kaputt-0.0.0-1.f26c9b0
/gnu/store/iins36vac6jg8blwn5gam9xygararclj-sbcl-kaputt-0.0.0-1.f26c9b0
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 9b36beb118ed902c640d2da9bb489597edc16016 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 7 Nov 2021 19:40:06 +0000
Subject: [PATCH] gnu: Add cl-kaputt

* gnu/packages/lisp-check.scm: (sbcl-kaputt, cl-kaputt, ecl-kaputt): New variables.
---
gnu/packages/lisp-check.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index ca00e5054e..2c9a503117 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -845,3 +845,44 @@ (define-public cl-xlunit
(define-public ecl-xlunit
(sbcl-package->ecl-package sbcl-xlunit))
+
+(define-public sbcl-kaputt
+ (let ((commit "f26c9b0f8219fe61d86249198ef85174eecafc10")
+ (revision "1"))
+ (package
+ (name "sbcl-kaputt")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/foretspaisibles/cl-kaputt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10a78032vnf12kjjpfmq9ign38cad237ycyq37dwnx922nxjjaj4"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)))
+ (home-page "https://github.com/foretspaisibles/cl-kaputt")
+ (synopsis "Simple Interactive Test Framework for Common Lisp")
+ (description
+ "KAPUTT is a test framework for Common Lisp that focuses on the
+following features:
+
+@itemize
+@item KAPUTT is simple, it only defines three abstractions testcase, assertion
+and protocol and does not add any artefact on the backtrace when errors occur.
+
+@item KAPUTT is extensible, it is possible to add problem-specific assertions
+to make test code more informative.
+
+@item KAPUTT fits well interactive development.
+@end itemize\n")
+ (license license:cecill-b))))
+
+(define-public ecl-kaputt
+ (sbcl-package->ecl-package sbcl-kaputt))
+
+(define-public cl-kaputt
+ (sbcl-package->cl-source-package sbcl-kaputt))
--
2.33.1
Guillaume Le Vaillant wrote 3 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 51671-done@debbugs.gnu.org)
8735o7jb1p.fsf@kitej
Patch pushed as 07a68587b0e00a7b7c231d1360bbc5fb47fc51bf.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYYjiUg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8kTQEAoBE/Bdc/19+GnL80hGQv1nD6GXyUVG1p9y0G
7kDt5xcA+gKtxRnly2CWFqYXTgxuu8GKwBTqiM8GPKFaKGG7UAQz
=DSbS
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51671@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51671
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help