[PATCH] gnu: Add cl-alloy

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5qs-Pbx9xm7B4-P_sxjtJgsbQ+n=Q++VxiAs48WUBkRUQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 052d9f07c42922f54b36bfbd126bbe63815313fc Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 7 Nov 2021 18:50:57 +0000
Subject: [PATCH] gnu: Add cl-alloy

* gnu/packages/lisp-xyz.scm (sbcl-alloy, cl-alloy, ecsl-alloy): New variables.
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 53911487ac..66accd59a1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17575,6 +17575,43 @@ (define-public ecl-trial
(define-public cl-trial
(sbcl-package->cl-source-package sbcl-trial))
+(define-public sbcl-alloy
+ (let ((commit "e86e22c2887836ec31cd97e039f0bca5248d8f1c")
+ (revision "1"))
+ (package
+ (name "sbcl-alloy")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shirakumo/alloy")
+ (commit commit)))
+ (file-name (git-file-name "alloy" version))
+ (sha256
+ (base32 "1jsqjr6sf86hcdvnjp4gd10qv0r7kfkr9hmda85irb5lha4q9n7w"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("parachute" ,sbcl-parachute)
+ ("alexandria" ,sbcl-alexandria)))
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)
+ ("closer-mop" ,sbcl-closer-mop)
+ ("array-utils" ,sbcl-array-utils)))
+ (home-page "https://shirakumo.github.io/alloy/")
+ (synopsis "Common Lisp user interface protocol and tolkit implementation")
+ (description
+ "Alloy is a user interface toolkit. It is defined through a set of
+protocols that allow for a clear interface, as well as a standardised way to
+integrate Alloy into a target backend.")
+ (license license:zlib))))
+
+(define-public ecl-alloy
+ (sbcl-package->ecl-package sbcl-alloy))
+
+(define-public cl-alloy
+ (sbcl-package->cl-source-package sbcl-alloy))
+
(define-public sbcl-org-sampler
(let ((commit "ee135a417750e5b1d810bb9574eb85223cb3038a")
(revision "1"))
--
2.33.1
Guillaume Le Vaillant wrote 3 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 51670-done@debbugs.gnu.org)
877ddjjb2x.fsf@kitej
Patch pushed as 6ec0c6c7678234ff5ab4c892903e0b682cbd876d.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYYjiJg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+/lwD/TV8weJ86oVAxV5lqQOWGmYJ3AcA6YwEc/Kxu
VYj623kBAIzaMcY4CKZtsGKysHOoEgPi1ot8nhk7vgtvQ3zAQZ6l
=4ue8
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51670@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51670
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help