[PATCH] gnu: Add fcitx5-rime.

  • Done
  • quality assurance status badge
Details
2 participants
  • dan
  • zimoun
Owner
unassigned
Submitted by
dan
Severity
normal
D
(address . guix-patches@gnu.org)
20211107154429.1163-1-igaryhe@gmail.com
---
gnu/packages/fcitx5.scm | 41 ++++++++++++++++++++++++++++++++++++++++-
1 file changed, 40 insertions(+), 1 deletion(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 737f47f20f..4391bbeadd 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -47,7 +47,8 @@ (define-module (gnu packages fcitx5)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages ibus))
(define-public xcb-imdkit
(package
@@ -453,3 +454,41 @@ (define (install-theme-variant variant target)
@item DeepPurple
@end itemize\n")
(license license:asl2.0)))
+
+(define-public fcitx5-rime
+ (package
+ (name "fcitx5-rime")
+ (version "5.0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fcitx/fcitx5-rime")
+ (commit version)))
+ (sha256
+ (base32
+ "17fi36m70d8gwwyragms4rl7xjx4k7g5ixs8rcj8r2ph1ak9ymhy"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list (string-append "-DRIME_DATA_DIR="
+ (assoc-ref %build-inputs "rime-data")
+ "/share/rime-data"))))
+ (inputs
+ `(("gettext", gettext-minimal)
+ ("fcitx5", fcitx5)
+ ("librime", librime)
+ ("rime-data", rime-data)))
+ (native-inputs
+ `(("extra-cmake-modules", extra-cmake-modules)
+ ("pkg-config", pkg-config)))
+ (home-page "https://github.com/fcitx/fcitx5-rime")
+ (synopsis "Rime Input Method Engine for fcitx5")
+ (description "@dfn{fcitx5-rime} provides the Rime input method engine for
++fcitx5. Rime is a lightweight, extensible input method engine supporting
++various input schemas including glyph-based input methods, romanization-based
++input methods as well as those for Chinese dialects. It has the ability to
++compose phrases and sentences intelligently and provide very accurate
++traditional Chinese output.")
+ (license license:lgpl2.1+)))
--
2.33.1.windows.1
D
Re: bug#51668: Acknowledgement ([PATCH] gnu: Add fcitx5-rime.)
(address . 51668@debbugs.gnu.org)
CAFp0n+71erj_neM+fOcmMrSwFo0dNhKmX9Uv89BYfF6czMY_1g@mail.gmail.com
This is a duplication of bug#51667. I submit this mainly because I was
afraid that the previous patch didn't follow the submission guidelines
since I attached 6 patches in the previous submission. If that one is OK,
please ignore this patch.

On Mon, Nov 8, 2021 at 12:54 AM GNU bug Tracking System <
help-debbugs@gnu.org> wrote:

Toggle quote (22 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 51668@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 51668: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=51668
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
Attachment: file
D
Re: [PATCH] gnu: Add fcitx5-rime.
(address . guix-patches@gnu.org)
CAFp0n+4aOSsT+xXF-RXZ9UHU+zc3apQa7h0JnT9L5JDO1H0d5w@mail.gmail.com
This is a duplication of #51667. I submit this mainly because I was afraid
that the previous patch didn't follow the submission guidelines since I
attached 6 patches in the previous submission. If that one is OK, please
ignore this patch.

On Sun, Nov 7, 2021 at 11:45 PM dan <igaryhe@gmail.com> wrote:

Toggle quote (67 lines)
> ---
> gnu/packages/fcitx5.scm | 41 ++++++++++++++++++++++++++++++++++++++++-
> 1 file changed, 40 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
> index 737f47f20f..4391bbeadd 100644
> --- a/gnu/packages/fcitx5.scm
> +++ b/gnu/packages/fcitx5.scm
> @@ -47,7 +47,8 @@ (define-module (gnu packages fcitx5)
> #:use-module (gnu packages web)
> #:use-module (gnu packages xdisorg)
> #:use-module (gnu packages xml)
> - #:use-module (gnu packages xorg))
> + #:use-module (gnu packages xorg)
> + #:use-module (gnu packages ibus))
>
> (define-public xcb-imdkit
> (package
> @@ -453,3 +454,41 @@ (define (install-theme-variant variant target)
> @item DeepPurple
> @end itemize\n")
> (license license:asl2.0)))
> +
> +(define-public fcitx5-rime
> + (package
> + (name "fcitx5-rime")
> + (version "5.0.8")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/fcitx/fcitx5-rime")
> + (commit version)))
> + (sha256
> + (base32
> + "17fi36m70d8gwwyragms4rl7xjx4k7g5ixs8rcj8r2ph1ak9ymhy"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f
> + #:configure-flags
> + (list (string-append "-DRIME_DATA_DIR="
> + (assoc-ref %build-inputs "rime-data")
> + "/share/rime-data"))))
> + (inputs
> + `(("gettext", gettext-minimal)
> + ("fcitx5", fcitx5)
> + ("librime", librime)
> + ("rime-data", rime-data)))
> + (native-inputs
> + `(("extra-cmake-modules", extra-cmake-modules)
> + ("pkg-config", pkg-config)))
> + (home-page "https://github.com/fcitx/fcitx5-rime")
> + (synopsis "Rime Input Method Engine for fcitx5")
> + (description "@dfn{fcitx5-rime} provides the Rime input method engine
> for
> ++fcitx5. Rime is a lightweight, extensible input method engine supporting
> ++various input schemas including glyph-based input methods,
> romanization-based
> ++input methods as well as those for Chinese dialects. It has the ability
> to
> ++compose phrases and sentences intelligently and provide very accurate
> ++traditional Chinese output.")
> + (license license:lgpl2.1+)))
> --
> 2.33.1.windows.1
>
>
Attachment: file
Z
Z
zimoun wrote on 8 Nov 2021 09:49
Re: [bug#51668] [PATCH] gnu: Add fcitx5-rime.
(name . dan)(address . igaryhe@gmail.com)(address . 51668-done@debbugs.gnu.org)
86h7cnt4l8.fsf@gmail.com
Hi,

On Mon, 08 Nov 2021 at 09:54, dan <igaryhe@gmail.com> wrote:

Toggle quote (5 lines)
> This is a duplication of #51667. I submit this mainly because I was
> afraid that the previous patch didn't follow the submission guidelines
> since I attached 6 patches in the previous submission. If that one is
> OK, please ignore this patch.

Thanks. I am closing this one in favor of #51667, thus.

FYI, you can close yourself by replying with appending -done to the
number inside the email address as with 51668-done@debbugs.gnu.org.


Cheers,
simon
Closed
D
[PATCH] gnu: Add fcitx5-rime.
(address . 51668@debbugs.gnu.org)
CAFp0n+7OmAjdqV6wuQHpLghqg_y1TsE17QqtDdsRJ6YcNkT_Lg@mail.gmail.com
From 2f8fef92b3fce1cfec7244e1bdca7e63f52b8a6c Mon Sep 17 00:00:00 2001
From: dan <igaryhe@gmail.com>
Date: Sun, 7 Nov 2021 21:57:24 +0800
Subject: [PATCH] gnu: Add fcitx5-rime.

* gnu/packages/fcitx5.scm (fcitx5-rime): New variable.
---
gnu/packages/fcitx5.scm | 47 +++++++++++++++++++++++++++++++++++++++--
1 file changed, 45 insertions(+), 2 deletions(-)
Toggle diff (54 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scmindex
0c4980aba2..27c28d56e1 100644--- a/gnu/packages/fcitx5.scm+++
b/gnu/packages/fcitx5.scm@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>+;;;
Copyright © 2021 dan <igaryhe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;@@ -47,7 +48,8 @@ (define-module (gnu packages fcitx5)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)- #:use-module (gnu packages
xorg))+ #:use-module (gnu packages xorg)+ #:use-module (gnu packages
ibus))

(define-public xcb-imdkit
(package@@ -139,7 +141,11 @@ (define-public fcitx5
(native-search-paths
(list (search-path-specification
(variable "FCITX_ADDON_DIRS")- (files
'("lib/fcitx5")))))+ (files '("lib/fcitx5")))+ ;
export XDG_DATA_DIRS so that fcitx5 could search other addons+
(search-path-specification+ (variable "XDG_DATA_DIRS")+
(files '("share")))))
(home-page "https://github.com/fcitx/fcitx5")
(synopsis "Input method framework")
(description "Fcitx 5 is a generic input method framework.")@@
-453,3 +459,40 @@ (define (install-theme-variant variant target)
@item DeepPurple
@end itemize\n")
(license license:asl2.0)))++(define-public fcitx5-rime+
(package+ (name "fcitx5-rime")+ (version "5.0.8")+ (source+
(origin+ (method url-fetch)+ (uri (string-append+
"https://download.fcitx-im.org/fcitx5"+
"/fcitx5-rime/fcitx5-rime-" version ".tar.xz"))+ (sha256+
(base32 "0rl8ng11jprzi3lvx3jdim5b5y8k31l14jgjricxzw5i3fvfqzp3"))))+
(build-system cmake-build-system)+ (arguments+ '(#:tests? #f
; no tests+ #:configure-flags+ (list
(string-append "-DRIME_DATA_DIR="+ (assoc-ref %build-inputs
"rime-data")+ "/share/rime-data"))))+ (inputs+
`(("fcitx5", fcitx5)+ ("librime", librime)+ ("rime-data",
rime-data)))+ (native-inputs+ `(("gettext", gettext-minimal)+
("extra-cmake-modules", extra-cmake-modules)+ ("pkg-config",
pkg-config)))+ (home-page "https://github.com/fcitx/fcitx5-rime")+
(synopsis "Rime Input Method Engine for Fcitx 5")+ (description
"@dfn{fcitx5-rime} provides the Rime input method engine for+fcitx5.
Rime is a lightweight, extensible input method engine
supporting+various input schemas including glyph-based input methods,
romanization-based+input methods as well as those for Chinese
dialects. It has the ability to+compose phrases and sentences
intelligently and provide very accurate+traditional Chinese output.")+
(license license:lgpl2.1+)))--
2.33.1
Attachment: file
?