[PATCH] gnu: Add xst.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Mathieu Othacehe
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 6 Nov 2021 09:52
(address . guix-patches@gnu.org)
20211106085247.4651-1-jgart@dismail.de
* gnu/packages/suckless.scm (xst): New variable.

Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name>
---
gnu/packages/suckless.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 912ff12422..0755700835 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -411,6 +411,36 @@ (define-public st
drawing.")
(license license:x11)))
+(define-public xst
+ (package
+ (inherit st)
+ (name "xst")
+ (version "0.8.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnotclub/xst")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q64x7czpbcg0v509qchn5v96zdnx7jmvy0zxhjmkk3d10x5rqlw"))))
+ (home-page "https://github.com/gnotclub/xst")
+ (synopsis "Fork of st that uses Xresources and some pretty good patches")
+ (description
+"@command{xst} applies the following patches to @command{st}:
+@itemize
+@item @uref{https://st.suckless.org/patches/alpha/, alpha}
+@item @uref{https://st.suckless.org/patches/boxdraw/, boxdraw}
+@item @uref{https://st.suckless.org/patches/clipboard/, clipboard}
+@item @uref{https://st.suckless.org/patches/disable_bold_italic_fonts/, disable_bold_italic_fonts}
+@item @uref{https://st.suckless.org/patches/externalpipe/, externalpipe}
+@item @uref{https://st.suckless.org/patches/scrollback/, scrollback}
+@item @uref{https://st.suckless.org/patches/spoiler/, spoiler}
+@item @uref{https://st.suckless.org/patches/vertcenter/, vertcenter}
+@end itemize")
+ (license license:expat)))
+
(define-public surf
(package
(name "surf")
--
2.33.1
M
M
Mathieu Othacehe wrote on 26 Dec 2021 19:23
(name . jgart)(address . jgart@dismail.de)
87bl13ns2q.fsf@gnu.org
Toggle quote (2 lines)
> * gnu/packages/suckless.scm (xst): New variable.

Applied with cosmetic fixes,

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51626@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51626
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch