'make check' test failures when run in parallel

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 5 Nov 2021 17:58
(name . bug-guix)(address . bug-guix@gnu.org)
87sfwa35gm.fsf@gmail.com
Hello,

Every time I run 'make check' with parallel jobs enabled (-j24 say), I
get something like this:

Toggle snippet (102 lines)
]$ make check -j32
[...]
PASS: tests/combinators.scm
PASS: tests/base16.scm
PASS: tests/glob.scm
PASS: tests/bournish.scm
PASS: tests/base32.scm
PASS: tests/base64.scm
PASS: tests/cache.scm
PASS: tests/file-systems.scm
PASS: tests/gnu-maintenance.scm
PASS: tests/cve.scm
PASS: tests/accounts.scm
PASS: tests/elpa.scm
PASS: tests/discovery.scm
PASS: tests/modules.scm
SKIP: tests/cpio.scm
PASS: tests/openpgp.scm
PASS: tests/egg.scm
PASS: tests/boot-parameters.scm
PASS: tests/pki.scm
PASS: tests/cran.scm
PASS: tests/minetest.scm
PASS: tests/networking.scm
PASS: tests/gremlin.scm
FAIL: tests/opam.scm
PASS: tests/gem.scm
PASS: tests/import-utils.scm
PASS: tests/search-paths.scm
PASS: tests/cpan.scm
PASS: tests/git.scm
PASS: tests/print.scm
PASS: tests/sets.scm
PASS: tests/scripts.scm
PASS: tests/records.scm
SKIP: tests/crate.scm
PASS: tests/status.scm
PASS: tests/services/file-sharing.scm
PASS: tests/monads.scm
FAIL: tests/pypi.scm
PASS: tests/services/telephony.scm
PASS: tests/services/linux.scm
PASS: tests/swh.scm
PASS: tests/services.scm
PASS: tests/git-authenticate.scm
PASS: tests/import-git.scm
PASS: tests/substitute.scm
PASS: tests/store-deduplication.scm
PASS: tests/store-roots.scm
PASS: tests/uuid.scm
PASS: tests/system.scm
SKIP: tests/upstream.scm
PASS: tests/utils.scm
PASS: tests/texlive.scm
PASS: tests/store-database.scm
PASS: tests/ui.scm
SKIP: tests/guix-git-authenticate.sh
PASS: tests/go.scm
SKIP: tests/syscalls.scm
PASS: tests/transformations.scm
PASS: tests/guix-download.sh
PASS: tests/guix-hash.sh
PASS: tests/workers.scm
PASS: tests/channels.scm
make[4]: *** [Makefile:6446: tests/grafts.log] Error 1
make[4]: *** Waiting for unfinished jobs....
FAIL: tests/build-utils.scm
make[4]: *** [Makefile:6446: tests/derivations.log] Error 1
PASS: tests/processes.scm
FAIL: tests/guix-pack.sh
PASS: tests/size.scm
PASS: tests/guix-home.sh
PASS: tests/containers.scm
SKIP: tests/hackage.scm
PASS: tests/style.scm
PASS: tests/union.scm
PASS: tests/guix-package-aliases.sh
PASS: tests/debug-link.scm
PASS: tests/guix-pack-localstatedir.sh
PASS: tests/graph.scm
PASS: tests/nar.scm
PASS: tests/publish.scm
PASS: tests/builders.scm
PASS: tests/guix-build-branch.sh
SKIP: tests/gexp.scm
PASS: tests/profiles.scm
FAIL: tests/guix-build.sh
SKIP: tests/inferior.scm
PASS: tests/store.scm
PASS: tests/challenge.scm
PASS: tests/guix-package-net.sh
PASS: tests/packages.scm

FAIL: tests/guix-system.sh
FAIL: tests/guix-package.sh
PASS: tests/pack.scm
PASS: tests/lint.scm
PASS: tests/guix-pack-relocatable.sh
[...]
make: *** [Makefile:6679: check] Error 2

Ludovic suggested that it was perhaps the daemon socket being already in
use.

To be investigated; it'd be nice to tackle this wart before the next
release.

Thanks,

Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 51615@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51615
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch