[PATCH] gnu: Add vim-nerdtree.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Ludovic Courtès
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 5 Nov 2021 03:42
(address . guix-patches@gnu.org)
PU1PR01MB21554FED67A22439A08097A78D8E9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/vim.scm (vim-nerdtree): New variable.
---
gnu/packages/vim.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 1abfffbce2..3f87c18631 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1325,3 +1325,33 @@ the class they are defined in.")
operations and styles which are invoked via key mappings and a menu. These
operations are available for most filetypes.")
(license license:cc0))))
+
+(define-public vim-nerdtree
+ (package
+ (name "vim-nerdtree")
+ (version "6.10.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/nerdtree")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1si8qla86ng8cffbmfrk9gss0i3912yw0f1ph4bsiq0kk837lccp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("lib" "share/vim/vimfiles/")
+ ("nerdtree_plugin" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/nerdtree")
+ (synopsis "Tree explorer plugin for Vim")
+ (description
+ "The NERDTree is a file system explorer for the Vim editor. Using this
+plugin, users can visually browse complex directory hierarchies, quickly open
+files for reading or editing, and perform basic file system operations.")
+ (license license:wtfpl2)))

base-commit: 575fcd3045ff1649e5319b6701ff9e28e97793e0
--
2.25.1
F
F
Foo Chuan Wei wrote on 18 Nov 2021 08:04
[PATCH v2] gnu: Add vim-nerdtree.
(address . 51603@debbugs.gnu.org)
PU1PR01MB21550B1029ED6CB5FF06013A8D9B9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/vim.scm (vim-nerdtree): New variable.
---
gnu/packages/vim.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 1abfffbce2..c2c913ba5f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1297,6 +1297,36 @@ by their scope. This means that for example methods in C++ are displayed under
the class they are defined in.")
(license license:vim)))
+(define-public vim-nerdtree
+ (package
+ (name "vim-nerdtree")
+ (version "6.10.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/nerdtree")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1si8qla86ng8cffbmfrk9gss0i3912yw0f1ph4bsiq0kk837lccp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("lib" "share/vim/vimfiles/")
+ ("nerdtree_plugin" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/nerdtree")
+ (synopsis "Tree explorer plugin for Vim")
+ (description
+ "The NERDTree is a file system explorer for the Vim editor. Using this
+plugin, users can visually browse complex directory hierarchies, quickly open
+files for reading or editing, and perform basic file system operations.")
+ (license license:wtfpl2)))
+
(define-public vim-nerdcommenter
(let ((commit "a65465d321f2f8a74b2ffa540b9b87563f7e12e8")
(revision "1"))

base-commit: 7537ec816ffe0aaa6677c53604ac12fe9d9ca250
--
2.25.1
L
L
Ludovic Courtès wrote on 1 Dec 2021 16:52
Re: bug#51603: [PATCH] gnu: Add vim-nerdtree.
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 51603-done@debbugs.gnu.org)
87wnko1fwa.fsf_-_@gnu.org
Hi,

Foo Chuan Wei <chuanwei.foo@hotmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/vim.scm (vim-nerdtree): New variable.

Applied, thanks!

Ludo’.
Closed
?