[PATCH] gnu: Add emacs-orglink.

  • Done
  • quality assurance status badge
Details
2 participants
  • Aleksandr Vityazev
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Aleksandr Vityazev
Severity
normal

Debbugs page

Aleksandr Vityazev wrote 3 years ago
(address . guix-patches@gnu.org)
87k0hshr7k.fsf@posteo.org
* gnu/packages/emacs-xyz.scm (emacs-orglink): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e584a14eb0..f184443c65 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28884,6 +28884,30 @@ (define-public emacs-org-webring
displayed for sharing.")
(license license:gpl3+)))
+(define-public emacs-orglink
+ (package
+ (name "emacs-orglink")
+ (version "1.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarsius/orglink")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ipy1p2cr5i0465hchqazmgn9jrgwzbyrb3prfgkl7z2m1gd7fcg"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/tarsius/orglink")
+ (synopsis
+ "Use Org Mode links in other modes")
+ (description "This library implements support for some Org Mode
+link types in other major modes. Links can be opened and edited like
+in Org Mode.")
+ (license license:gpl3+)))
+
(define-public emacs-scpaste
(let ((commit "cd4fa0aafecd839736e0b6cba68b4fc4d7045472")
(revision "0"))
--
2.33.1



--

Aleksandr Vityazev
Nicolas Goaziou wrote 3 years ago
(name . Aleksandr Vityazev)(address . avityazev@posteo.org)(address . 51553-done@debbugs.gnu.org)
87fsseuw4j.fsf@nicolasgoaziou.fr
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-orglink): New variable.

I removed some spurious newline characters and applied your patch.

Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51553@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51553
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help